Sound was previously working in 16.04, now stopped

Asked by Abe Voelker on 2017-09-06

This is an install that was upgraded from 14.04 to 16.04. It's also a dual boot (with Windows 10) using GRUB. Originally on 14.04 I had to use an ALSA daily build to get sound working ( When I upgraded to 16.04 I uninstalled that daily build .deb as it was no longer necessary. But just this past week the sound suddenly stopped - not sure if a package or kernel upgrade caused it or what.

Based on my previous experience the first thing I tried was installing an ALSA daily build. I tried both oem-audio-hda-daily-dkms_0.201708220416~ubuntu16.04.1_all.deb and oem-audio-hda-daily-lts-xenial-dkms_0.201708220446~ubuntu16.04.1_all.deb (from this page without any luck.

After that I went through the troubleshooting steps here:

and here:

Including obvious steps like "Refreshing/reinstalling the drivers," trying all the different audio ports, making sure the right output device is selected (Intel Corporation Sunrise Point-H HD Audio) and not muted / volume cranked way up, trying my headphones and speakers (different hardware), etc., but none of the suggestions has fixed it. I know it's not a hardware problem because when I boot into Windows the sound works fine.

When I run pavucontrol the audio meter correctly shows when my applications are playing audio, and detects when I've plugged my speaker cable in or not (when it's not plugged in the analog options disappear and S/PDIF shows up):

I'm not sure what else to try other than a fresh 16.04 install... hopefully that can be avoided. Here is my also-info.txt debug info:

And here is the "Step 4" debug info:

Question information

English Edit question
Ubuntu alsa-driver Edit question
No assignee Edit question
Solved by:
Abe Voelker
Last query:
Last reply:
Abe Voelker (abevoelker) said : #1

Just to clarify my setup, I'm trying to use the analog out port on my motherboard's built-in sound, which I believe is showing up as "Intel Corporation Sunrise Point-H HD Audio." There is also an NVIDIA soundcard detected that I believe is coming from my graphics card (a GeForce GTX 980 Ti - I'm using the closed source drivers if that matters), but I don't want that one. I also have a USB webcam plugged in (a Logitech C615) but that only has a microphone (no speaker).

What is the output of:

wget -O && chmod +x ./ && ./



killall pulseaudio; rm -r ~/.pulse* ~/.config/pulse*

Wait ten seconds then reboot

Abe Voelker (abevoelker) said : #5

Tried that again; it still doesn't work.

If you reset your BIOS to defaults then reset it. Up does it help?

Abe Voelker (abevoelker) said : #7

Thanks for the suggestion, however it didn't work.

Abe Voelker (abevoelker) said : #8

I tried some commands found in random Google searches, and one of them fixed my sound (not sure which):

alsactl restore
sudo alsactl restore
sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload
(then restarted my PC)

I'm guessing it was purging/reinstalling pulseaudio, as according to my history file I had tried all the other commands at some point. I noticed that pulseaudio is not included in the purge+reinstall command in the wiki: