audio won't work on tvtime or gnome radio but works on everyting else

Asked by Dennis L Huffman on 2009-03-13

I recently got a new speaker system(virtual surround sound with subwoofer).the sound works with movie player,lastfm,videos,etc,but not gnome radio & tvtime.Is there a fix for this?I have Nvidia Gforce sound card.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Craig Huffstetler
Solved:
Last query:
Last reply:

        Subsystem: nVidia Corporation Device cb84
        Flags: bus master, 66MHz, fast devsel, latency 0
        Capabilities: <access denied>

00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
        Subsystem: nVidia Corporation Device cb84
        Flags: bus master, 66MHz, fast devsel, latency 0
        I/O ports at 4f00 [size=256]

00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 7309
        Flags: 66MHz, fast devsel, IRQ 11
        I/O ports at 4900 [size=64]
        I/O ports at 4d00 [size=64]
        I/O ports at 4e00 [size=64]
        Capabilities: <access denied>
        Kernel driver in use: nForce2_smbus
        Kernel modules: i2c-nforce2

00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 7309
        Flags: 66MHz, fast devsel
:

Best Craig Huffstetler (xq) said : #3

Let's try a few things here:

1) Ensure that no channels are muted and that all channels are "checked" off in ALSA Mixer or whatever mixer you are using. I want to ensure that the channel has not become muted.

If ALSA Mixer is not installed, install it (Synaptic > Search for "AlSA Mixer" > Install It). It can now be found in your Applications > Media Apps...

If you're running GNOME, double-click speaker icon (upper right corner), click capture tab, then make sure line-in(s) are unmuted (tiny speaker icon, bottom of window).

2) Also ensure the cables are connected properly.

3) I really think this is a setting for the programs (gnome radio and tvtime). They are getting the proper tuner device confused since you most likely have 1 - 3 sound/video devices on your system for them to filter through. You must ensure they are using the correct device. Check all settings for the applications (double check them) and ensure the above are correct.

If you can let me know the output of these commands (via a terminal) -- use http://www.pastebin.ca or here for the output (they shouldn't be too long...):
arecord -l
cat /proc/asound/cards

I found three posts that may interest you:
http://ubuntuforums.org/showthread.php?t=976045 (gnome radio)
http://fixunix.com/mandriva/525762-sound-tvtime.html & http://steveyoung.wordpress.com/2007/12/16/tvtime-no-sound/ & https://lists.ubuntu.com/archives/ubuntu-users/2005-June/037340.html (tvtime)

I hope this helps.

Sincerely and regards,

Craig H.

Thanks Craig Huffstetler, that solved my question.