Audio glitches occuring randomly every 2-10 minutes

Asked by Raphael Höps on 2017-05-15

Hi,
when watching any video or playing any sound, I get some pretty annoying audio glitches every 2-10 minutes. It sounds like about half a seconds was cut out of the audio.
This seems to be some kind of a common problem to a lot of users as there can be found a lot of discussions and ideas of solutions on different pages. I have tried a lot of possible solutions (see below) but none of them did the job for me.
I followed the instructions on https://help.ubuntu.com/community/SoundTroubleshootingProcedure and on "Step 3" it is suggested to run a diagnosis script and post the results here. This is what I am doing now. My data can be found here:

http://www.alsa-project.org/db/?f=14670ac814ac9f84dbf20e15aa8025c5e917ea84

I hope you can help me with other suggestions on how to solve my issue. Thanks a lot!

-----------------------------------------------------------------------------------------------------
*** Here is some kind of documentation of what I have already tried: ***
-----------------------------------------------------------------------------------------------------

sudo gedit /etc/modprobe.d/alsa-base.conf
add the line:
 snd-hda-intel model=auto
==============================================================
killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*
==============================================================
sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
==============================================================
sudo gedit /etc/pulse/default.pa
find the line: load-module module-udev-detect
change it to: load-module module-udev-detect tsched=0
pulseaudio -k
==============================================================
sudo -H gedit /etc/pulse/daemon.conf
find the line: ; resample-method =
change it to: resample-method = src-sinc-best-quality
(ohne semikolon)
=============================================================
sudo gedit /etc/modprobe.d/alsa-base.conf
add the line: options snd-hda-intel vid=8086 pid=8ca0 snoop=0
==============================================================
from https://askubuntu.com/questions/160882/popping-noise-from-laptop-speakers
---------------
sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave
Find the line:

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

Comment it out using "#". Underneath add the line:

INTEL_AUDIO_POWERSAVE=false

Save and exit, then restart.

sudo sh -c 'echo 0 > /sys/module/snd_hda_intel/parameters/power_save'
sudo sh -c 'echo N > /sys/module/snd_hda_intel/parameters/power_save_controller'

sudo chmod 550 /sys/module/snd_hda_intel/parameters/power_save
sudo chmod 550 /sys/module/snd_hda_intel/parameters/power_save_controller

===================================================
from https://askubuntu.com/questions/160882/popping-noise-from-laptop-speakers
---------------
alsamixer -c0
Press F6 and select your sound card (in my case HDA Intel PCH).
Go towards the right and disable Auto-Mute M.
===============================================
gksudo gedit /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=auto vid=8086 pid=8ca0 snoop=0 power_save=0 power_save_controller=N

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2017-05-15
Last reply:
2017-05-31
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.