After attempting to install mythtv (then purging it) and installed kaffeine, sound card is not recognized. Ubuntu will play a sound on the login screen but then all audio output options are disabled once logged in.

Asked by Joshua Knoke on 2017-04-17

The problem happened when I attempted to install mythtv. After hours of frustration, mythtv was purged. I then installed kaffeine and all its dependencies. I noticed when I finished installing and configuring kaffeine, my sound card is no longer listed under audio settings/output. My computer has mute checked and will not allow me to make any changes. I started following the directions on https://help.ubuntu.com/community/SoundTroubleshootingProcedure and here is the output after running the following command: wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Mon Apr 17 00:53:08 UTC 2017

!!Linux Distribution
!!------------------

Ubuntu 16.04.2 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 16.04.2 LTS" HOME_URL="http://www.ubuntu.com/" SUPPORT_URL="http://help.ubuntu.com/" BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" UBUNTU_CODENAME=xenial

!!DMI Information
!!---------------

Manufacturer: Dell Inc
Product Name: OptiPlex 740 Enhanced
Product Version:
Firmware Version: 2.0.12
Board Vendor: Dell Inc
Board Name: 0YP806

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/PNP0400:00/status 15
/sys/bus/acpi/devices/PNP0501:00/status 15
/sys/bus/acpi/devices/PNP0700:00/status 15
/sys/bus/acpi/devices/PNP0A08:00/status 15
/sys/bus/acpi/devices/PNP0C0C:00/status 11
/sys/bus/acpi/devices/PNP0C0F:00/status 9
/sys/bus/acpi/devices/PNP0C0F:01/status 9
/sys/bus/acpi/devices/PNP0C0F:02/status 9
/sys/bus/acpi/devices/PNP0C0F:03/status 9
/sys/bus/acpi/devices/PNP0C0F:04/status 11
/sys/bus/acpi/devices/PNP0C0F:05/status 9
/sys/bus/acpi/devices/PNP0C0F:06/status 9
/sys/bus/acpi/devices/PNP0C0F:07/status 9
/sys/bus/acpi/devices/PNP0C0F:08/status 11
/sys/bus/acpi/devices/PNP0C0F:09/status 9
/sys/bus/acpi/devices/PNP0C0F:0a/status 9
/sys/bus/acpi/devices/PNP0C0F:0b/status 9
/sys/bus/acpi/devices/PNP0C0F:0c/status 11
/sys/bus/acpi/devices/PNP0C0F:0d/status 9
/sys/bus/acpi/devices/PNP0C0F:0e/status 9
/sys/bus/acpi/devices/PNP0C0F:0f/status 9
/sys/bus/acpi/devices/PNP0C0F:10/status 11
/sys/bus/acpi/devices/PNP0C0F:11/status 9
/sys/bus/acpi/devices/PNP0C0F:12/status 11
/sys/bus/acpi/devices/PNP0C0F:13/status 11
/sys/bus/acpi/devices/PNP0C0F:14/status 9
/sys/bus/acpi/devices/PNP0C0F:15/status 9
/sys/bus/acpi/devices/PNP0C0F:16/status 9
/sys/bus/acpi/devices/PNP0C0F:17/status 9
/sys/bus/acpi/devices/PNP0C0F:18/status 11
/sys/bus/acpi/devices/PNP0C0F:19/status 9
/sys/bus/acpi/devices/PNP0C0F:1a/status 9
/sys/bus/acpi/devices/PNP0C0F:1b/status 9
/sys/bus/acpi/devices/PNP0C0F:1c/status 11
/sys/bus/acpi/devices/PNP0C0F:1d/status 9
/sys/bus/acpi/devices/PNP0C0F:1e/status 9
/sys/bus/acpi/devices/PNP0C0F:1f/status 9
/sys/bus/acpi/devices/PNP0C0F:20/status 9
/sys/bus/acpi/devices/PNP0C0F:21/status 11
/sys/bus/acpi/devices/PNP0C0F:22/status 9
/sys/bus/acpi/devices/PNP0C0F:23/status 9
/sys/bus/acpi/devices/PNP0C0F:24/status 11
/sys/bus/acpi/devices/PNP0C0F:25/status 9
/sys/bus/acpi/devices/PNP0C0F:26/status 9
/sys/bus/acpi/devices/PNP0C0F:27/status 11
/sys/bus/acpi/devices/PNP0C0F:28/status 11
/sys/bus/acpi/devices/device:00/status 15

!!Kernel Information
!!------------------

Kernel release: 4.8.0-46-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k4.8.0-46-generic
Library version: 1.1.0
Utilities version: 1.1.0

!!Loaded ALSA modules
!!-------------------

snd_hda_intel

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

 0 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 23

!!PCI Soundcards installed in the system
!!--------------------------------------

00:10.1 Audio device: NVIDIA Corporation MCP51 High Definition Audio (rev a2)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:10.1 0403: 10de:026c (rev a2)
 Subsystem: 1028:1f90

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
 align_buffer_size : -1
 bdl_pos_adj : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 beep_mode : N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N
 enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
 enable_msi : -1
 id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 jackpoll_ms : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
 model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 patch : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 position_fix : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 power_save : 0
 power_save_controller : Y
 probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 probe_only : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
 single_cmd : N
 snoop : -1

!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: SigmaTel STAC9200
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x83847690
Subsystem Id: 0x102801ec
Revision Id: 0x102201
No Modem Function Group found
Default PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
State of AFG node 0x01:
  Power states: D0 D1 D2 D3
  Power: setting=D0, actual=D0
GPIO: io=4, o=0, i=0, unsolicited=1, wake=1
  IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
  IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
  IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
  IO[3]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
Node 0x02 [Audio Output] wcaps 0xd0401: Stereo
  Device: name="STAC9200 Analog", type="Audio", device=0
  Converter: stream=5, channel=0
  Power states:
  Power: setting=D0, actual=D0
  Delay: 13 samples
Node 0x03 [Audio Input] wcaps 0x1d0541: Stereo
  Device: name="STAC9200 Analog", type="Audio", device=0
  Converter: stream=1, channel=0
  SDI-Select: 0
  Power states:
  Power: setting=D0, actual=D0
  Delay: 13 samples
  Connection: 1
     0x0a
  Processing caps: benign=0, ncoeff=0
Node 0x04 [Audio Input] wcaps 0x140311: Stereo Digital
  Converter: stream=0, channel=0
  SDI-Select: 0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x160]: 44100 48000 96000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Delay: 4 samples
  Connection: 1
     0x08
Node 0x05 [Audio Output] wcaps 0x40211: Stereo Digital
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x1e0]: 44100 48000 88200 96000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Delay: 4 samples
Node 0x06 [Vendor Defined Widget] wcaps 0xf30201: Stereo Digital
  Delay: 3 samples
Node 0x07 [Audio Selector] wcaps 0x300901: Stereo R/L
  Connection: 3
     0x02* 0x08 0x0a
Node 0x08 [Pin Complex] wcaps 0x430681: Stereo Digital
  Pincap 0x00010024: IN EAPD Detect
  EAPD 0x2: EAPD
  Pin Default 0x40f000f0: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:
  Power: setting=D0, actual=D0
  Delay: 3 samples
Node 0x09 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x00000010: OUT
  Pin Default 0x40f000f1: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x1
  Pin-ctls: 0x00:
  Connection: 2
     0x05* 0x0a
Node 0x0a [Audio Selector] wcaps 0x30090d: Stereo Amp-Out R/L
  Control: name="Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x00, nsteps=0x0f, stepsize=0x05, mute=1
  Amp-Out vals: [0x0d 0x0d]
  Connection: 1
     0x0c
Node 0x0b [Audio Selector] wcaps 0x300105: Stereo Amp-Out
  Control: name="Line Out Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Line Out Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: N/A
  Amp-Out vals: [0x1f 0x1f]
  Connection: 1
     0x07
Node 0x0c [Audio Selector] wcaps 0x30010d: Stereo Amp-Out
  Control: name="Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x00, nsteps=0x04, stepsize=0x27, mute=0
  Amp-Out vals: [0x00 0x00]
  Connection: 5
     0x10* 0x0f 0x0e 0x0d 0x12
Node 0x0d [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x0221101f: [Jack] HP Out at Ext Front
    Conn = 1/8, Color = Black
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0xc0: OUT HP
  Unsolicited: tag=01, enabled=1
  Connection: 1
     0x0b
Node 0x0e [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x0000003f: IN OUT HP Detect Trigger ImpSense
  Pin Default 0x01014010: [Jack] Line Out at Ext Rear
    Conn = 1/8, Color = Green
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=04, enabled=1
  Connection: 1
     0x0b
Node 0x0f [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x00000037: IN OUT Detect Trigger ImpSense
  Pin Default 0x0181302e: [Jack] Line In at Ext Rear
    Conn = 1/8, Color = Blue
    DefAssociation = 0x2, Sequence = 0xe
  Pin-ctls: 0x20: IN
  Unsolicited: tag=03, enabled=1
  Connection: 1
     0x0b
Node 0x10 [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x00001737: IN OUT Detect Trigger ImpSense
    Vref caps: HIZ 50 GRD 80
  Pin Default 0x02a11020: [Jack] Mic at Ext Front
    Conn = 1/8, Color = Black
    DefAssociation = 0x2, Sequence = 0x0
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=02, enabled=1
  Connection: 1
     0x0b
Node 0x11 [Pin Complex] wcaps 0x400104: Mono Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals: [0x9f]
  Pincap 0x00000010: OUT
  Pin Default 0x40f000f2: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x2
  Pin-ctls: 0x00:
  Connection: 1
     0x13
Node 0x12 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x00000020: IN
  Pin Default 0x40f000f3: [N/A] Other at Ext N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x3
  Pin-ctls: 0x20: IN
Node 0x13 [Audio Mixer] wcaps 0x200100: Mono
  Connection: 1
     0x07
Node 0x14 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
  Amp-Out caps: ofs=0x03, nsteps=0x03, stepsize=0x17, mute=1
  Amp-Out vals: [0x83]
--endcollapse--

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 2 Apr 16 20:43 /dev/snd/controlC0
crw-rw---- 1 root audio 116, 5 Apr 16 20:43 /dev/snd/hwC0D0
crw-rw---- 1 root audio 116, 4 Apr 16 20:53 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 3 Apr 16 20:53 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 1 Apr 16 20:43 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Apr 16 20:43 /dev/snd/timer

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root 60 Apr 16 20:43 .
drwxr-xr-x 3 root root 180 Apr 16 20:43 ..
lrwxrwxrwx 1 root root 12 Apr 16 20:43 pci-0000:00:10.1 -> ../controlC0

!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: STAC9200 Analog [STAC9200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: STAC9200 Analog [STAC9200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [NVidia]

Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 23'
  Mixer name : 'SigmaTel STAC9200'
  Components : 'HDA:83847690,102801ec,00102201'
  Controls : 17
  Simple ctrls : 9
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Line',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Line Out',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [0.00dB] [on]
  Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 13 [87%] [19.50dB] [on]
  Front Right: Capture 13 [87%] [19.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]

!!Alsactl output
!!--------------

--startcollapse--
state.NVidia {
 control.1 {
  iface MIXER
  name 'Line Out Playback Volume'
  value.0 31
  value.1 31
  comment {
   access 'read write'
   type INTEGER
   count 2
   range '0 - 31'
   dbmin -9999999
   dbmax 0
   dbvalue.0 0
   dbvalue.1 0
  }
 }
 control.2 {
  iface MIXER
  name 'Line Out Playback Switch'
  value.0 true
  value.1 true
  comment {
   access 'read write'
   type BOOLEAN
   count 2
  }
 }
 control.3 {
  iface MIXER
  name 'Auto-Mute Mode'
  value Enabled
  comment {
   access 'read write'
   type ENUMERATED
   count 1
   item.0 Disabled
   item.1 Enabled
  }
 }
 control.4 {
  iface MIXER
  name 'Capture Source'
  value Mic
  comment {
   access 'read write'
   type ENUMERATED
   count 1
   item.0 Mic
   item.1 Line
  }
 }
 control.5 {
  iface MIXER
  name 'Capture Volume'
  value.0 13
  value.1 13
  comment {
   access 'read write'
   type INTEGER
   count 2
   range '0 - 15'
   dbmin 0
   dbmax 2250
   dbvalue.0 1950
   dbvalue.1 1950
  }
 }
 control.6 {
  iface MIXER
  name 'Capture Switch'
  value.0 true
  value.1 true
  comment {
   access 'read write'
   type BOOLEAN
   count 2
  }
 }
 control.7 {
  iface MIXER
  name 'Mic Boost Volume'
  value.0 0
  value.1 0
  comment {
   access 'read write'
   type INTEGER
   count 2
   range '0 - 4'
   dbmin 0
   dbmax 4000
   dbvalue.0 0
   dbvalue.1 0
  }
 }
 control.8 {
  iface MIXER
  name 'Master Playback Volume'
  value 31
  comment {
   access 'read write'
   type INTEGER
   count 1
   range '0 - 31'
   dbmin -9999999
   dbmax 0
   dbvalue.0 0
  }
 }
 control.9 {
  iface MIXER
  name 'Master Playback Switch'
  value true
  comment {
   access 'read write'
   type BOOLEAN
   count 1
  }
 }
 control.10 {
  iface CARD
  name 'Mic Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.11 {
  iface CARD
  name 'Line Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.12 {
  iface CARD
  name 'Line Out Jack'
  value true
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.13 {
  iface CARD
  name 'Front Headphone Jack'
  value false
  comment {
   access read
   type BOOLEAN
   count 1
  }
 }
 control.14 {
  iface PCM
  name 'Playback Channel Map'
  value.0 0
  value.1 0
  comment {
   access read
   type INTEGER
   count 2
   range '0 - 36'
  }
 }
 control.15 {
  iface PCM
  name 'Capture Channel Map'
  value.0 0
  value.1 0
  comment {
   access read
   type INTEGER
   count 2
   range '0 - 36'
  }
 }
 control.16 {
  iface MIXER
  name 'PCM Playback Volume'
  value.0 255
  value.1 255
  comment {
   access 'read write user'
   type INTEGER
   count 2
   range '0 - 255'
   tlv '0000000100000008ffffec1400000014'
   dbmin -5100
   dbmax 0
   dbvalue.0 0
   dbvalue.1 0
  }
 }
 control.17 {
  iface MIXER
  name 'Digital Capture Volume'
  value.0 60
  value.1 60
  comment {
   access 'read write user'
   type INTEGER
   count 2
   range '0 - 120'
   tlv '0000000100000008fffff44800000032'
   dbmin -3000
   dbmax 3000
   dbvalue.0 0
   dbvalue.1 0
  }
 }
}
--endcollapse--

!!All Loaded Modules
!!------------------

Module
dcdbas
snd_hda_codec_idt
snd_hda_codec_generic
snd_hda_intel
snd_hda_codec
snd_hda_core
snd_hwdep
snd_pcm
kvm_amd
snd_seq_midi
kvm
snd_seq_midi_event
snd_rawmidi
joydev
input_leds
snd_seq
snd_seq_device
snd_timer
irqbypass
snd
soundcore
serio_raw
k8temp
shpchp
i2c_nforce2
binfmt_misc
mac_hid
parport_pc
ppdev
lp
parport
autofs4
hid_generic
usbhid
hid
amdkfd
amd_iommu_v2
radeon
i2c_algo_bit
ttm
pata_acpi
drm_kms_helper
syscopyarea
sysfillrect
sysimgblt
fb_sys_fops
drm
sata_nv
fjes
floppy
tg3
ptp
pps_core

!!Sysfs Files
!!-----------

/sys/class/sound/hwC0D0/init_pin_configs:
0x08 0x40f000f0
0x09 0x40f000f1
0x0d 0x0221101f
0x0e 0x01014010
0x0f 0x0181302e
0x10 0x02a11020
0x11 0x40f000f2
0x12 0x40f000f3

/sys/class/sound/hwC0D0/driver_pin_configs:

/sys/class/sound/hwC0D0/user_pin_configs:

/sys/class/sound/hwC0D0/init_verbs:

/sys/class/sound/hwC0D0/hints:

!!ALSA/HDA dmesg
!!--------------

[ 13.482435] ACPI: PCI Interrupt Link [AAZA] enabled at IRQ 23
[ 13.482449] snd_hda_intel 0000:00:10.1: Disabling MSI
[ 14.276030] snd_hda_codec_idt hdaudioC0D0: autoconfig for STAC9200: line_outs=1 (0xe/0x0/0x0/0x0/0x0) type:line
[ 14.276034] snd_hda_codec_idt hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 14.276035] snd_hda_codec_idt hdaudioC0D0: hp_outs=1 (0xd/0x0/0x0/0x0/0x0)
[ 14.276036] snd_hda_codec_idt hdaudioC0D0: mono: mono_out=0x0
[ 14.276037] snd_hda_codec_idt hdaudioC0D0: inputs:
[ 14.276039] snd_hda_codec_idt hdaudioC0D0: Mic=0x10
[ 14.276040] snd_hda_codec_idt hdaudioC0D0: Line=0xf
[ 14.908688] input: HDA NVidia Mic as /devices/pci0000:00/0000:00:10.1/sound/card0/input7
[ 14.908767] input: HDA NVidia Line as /devices/pci0000:00/0000:00:10.1/sound/card0/input8
[ 14.908837] input: HDA NVidia Line Out as /devices/pci0000:00/0000:00:10.1/sound/card0/input9
[ 14.908906] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:10.1/sound/card0/input10
[ 16.026456] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Joshua Knoke
Solved:
2017-04-17
Last query:
2017-04-17
Last reply:
2017-04-17

Try:

killall pulseaudio; rm -r ~/.config/pulse* ~/.pulse*

Wait ten seconds then reboot

Thanks

Joshua Knoke (jknoke) said : #2

jknoke@jknoke:~$ killall pulseaudio; rm -r ~/.config/pulse* ~/.pulse*
pulseaudio: no process found
rm: cannot remove '/home/jknoke/.pulse*': No such file or directory

Joshua Knoke (jknoke) said : #3

I looked up all the processes currently running, here is that list.

jknoke@jknoke:~$ sudo ps -A
  PID TTY TIME CMD
    1 ? 00:00:01 systemd
    2 ? 00:00:00 kthreadd
    3 ? 00:00:00 ksoftirqd/0
    5 ? 00:00:00 kworker/0:0H
    7 ? 00:00:02 rcu_sched
    8 ? 00:00:00 rcu_bh
    9 ? 00:00:00 migration/0
   10 ? 00:00:00 lru-add-drain
   11 ? 00:00:00 watchdog/0
   12 ? 00:00:00 cpuhp/0
   13 ? 00:00:00 cpuhp/1
   14 ? 00:00:00 watchdog/1
   15 ? 00:00:00 migration/1
   16 ? 00:00:00 ksoftirqd/1
   19 ? 00:00:00 kdevtmpfs
   20 ? 00:00:00 netns
   21 ? 00:00:00 khungtaskd
   22 ? 00:00:00 oom_reaper
   23 ? 00:00:00 writeback
   24 ? 00:00:00 kcompactd0
   25 ? 00:00:00 ksmd
   26 ? 00:00:00 khugepaged
   27 ? 00:00:00 crypto
   28 ? 00:00:00 kintegrityd
   29 ? 00:00:00 bioset
   30 ? 00:00:00 kblockd
   31 ? 00:00:00 ata_sff
   32 ? 00:00:00 md
   33 ? 00:00:00 devfreq_wq
   34 ? 00:00:00 watchdogd
   38 ? 00:00:00 kswapd0
   39 ? 00:00:00 vmstat
   40 ? 00:00:00 ecryptfs-kthrea
   79 ? 00:00:00 kthrotld
   80 ? 00:00:00 acpi_thermal_pm
   81 ? 00:00:00 bioset
   82 ? 00:00:00 bioset
   83 ? 00:00:00 bioset
   84 ? 00:00:00 bioset
   85 ? 00:00:00 bioset
   86 ? 00:00:00 bioset
   87 ? 00:00:00 bioset
   88 ? 00:00:00 bioset
   94 ? 00:00:00 ipv6_addrconf
  115 ? 00:00:00 deferwq
  116 ? 00:00:00 charger_manager
  152 ? 00:00:00 bioset
  153 ? 00:00:00 bioset
  154 ? 00:00:00 bioset
  155 ? 00:00:00 bioset
  156 ? 00:00:00 bioset
  157 ? 00:00:00 bioset
  158 ? 00:00:00 bioset
  159 ? 00:00:00 bioset
  160 ? 00:00:00 scsi_eh_0
  161 ? 00:00:00 scsi_tmf_0
  162 ? 00:00:00 scsi_eh_1
  163 ? 00:00:00 scsi_tmf_1
  165 ? 00:00:00 scsi_eh_2
  167 ? 00:00:00 scsi_tmf_2
  168 ? 00:00:00 scsi_eh_3
  170 ? 00:00:00 scsi_tmf_3
  174 ? 00:00:00 ttm_swap
  175 ? 00:00:00 bioset
  177 ? 00:00:00 bioset
  178 ? 00:00:00 bioset
  185 ? 00:00:00 kworker/0:1H
  212 ? 00:00:00 jbd2/sda1-8
  213 ? 00:00:00 ext4-rsv-conver
  243 ? 00:00:00 kauditd
  247 ? 00:00:25 systemd-journal
  270 ? 00:00:00 systemd-udevd
  418 ? 00:00:00 systemd-timesyn
  447 ? 00:00:00 kvm-irqfd-clean
  654 ? 00:00:00 atd
  657 ? 00:00:00 snapd
  663 ? 00:00:00 cron
  673 ? 00:00:07 avahi-daemon
  682 ? 00:00:01 acpid
  692 ? 00:00:00 ModemManager
  694 ? 00:00:07 rsyslogd
  695 ? 00:00:00 accounts-daemon
  696 ? 00:00:00 whoopsie
  700 ? 00:00:00 systemd-logind
  704 ? 00:01:34 dbus-daemon
  736 ? 00:00:00 avahi-daemon
  760 ? 00:00:07 cups-browsed
  761 ? 00:00:00 NetworkManager
  819 ? 00:00:00 lightdm
  832 ? 00:00:00 irqbalance
  833 ? 00:00:00 colord
  835 ? 00:01:22 polkitd
  848 tty7 00:00:55 Xorg
  958 ? 00:00:00 lightdm
 1026 tty1 00:00:00 agetty
 1066 ? 00:00:00 upowerd
 1091 ? 00:00:00 apache2
 1092 ? 00:00:00 apache2
 1093 ? 00:00:00 apache2
 1094 ? 00:00:00 apache2
 1095 ? 00:00:00 apache2
 1096 ? 00:00:00 apache2
 1119 ? 00:00:00 dnsmasq
 1290 ? 00:00:00 systemd
 1293 ? 00:00:00 (sd-pam)
 1365 ? 00:00:02 gnome-keyring-d
 1381 ? 00:00:01 upstart
 1459 ? 00:00:00 upstart-udev-br
 1469 ? 00:00:10 dbus-daemon
 1481 ? 00:00:00 window-stack-br
 1513 ? 00:00:01 ibus-daemon
 1519 ? 00:00:05 upstart-dbus-br
 1523 ? 00:00:01 upstart-dbus-br
 1541 ? 00:00:00 gvfsd
 1546 ? 00:00:00 gvfsd-fuse
 1554 ? 00:00:00 upstart-file-br
 1557 ? 00:00:00 ibus-dconf
 1558 ? 00:00:00 ibus-ui-gtk3
 1560 ? 00:00:00 ibus-x11
 1565 ? 00:00:00 gpg-agent
 1573 ? 00:00:00 at-spi-bus-laun
 1578 ? 00:00:00 dbus-daemon
 1580 ? 00:00:00 at-spi2-registr
 1589 ? 00:00:01 bamfdaemon
 1590 ? 00:00:00 ibus-engine-sim
 1606 ? 00:00:00 hud-service
 1608 ? 00:00:00 unity-settings-
 1619 ? 00:00:02 gnome-session-b
 1624 ? 00:00:04 unity-panel-ser
 1641 ? 00:00:00 indicator-messa
 1642 ? 00:00:00 indicator-bluet
 1643 ? 00:00:00 indicator-power
 1647 ? 00:00:00 indicator-datet
 1650 ? 00:00:00 indicator-keybo
 1651 ? 00:00:09 indicator-sound
 1652 ? 00:00:00 indicator-print
 1653 ? 00:00:00 indicator-sessi
 1661 ? 00:00:01 indicator-appli
 1697 ? 00:00:00 evolution-sourc
 1727 ? 00:00:00 dconf-service
 1773 ? 00:00:00 nm-applet
 1774 ? 00:00:00 polkit-gnome-au
 1775 ? 00:00:54 compiz
 1776 ? 00:00:02 nautilus
 1777 ? 00:00:00 unity-fallback-
 1780 ? 00:00:06 gnome-software
 1794 ? 00:00:00 gvfs-udisks2-vo
 1803 ? 00:00:00 udisksd
 1814 ? 00:00:00 gvfs-goa-volume
 1819 ? 00:00:00 gvfs-mtp-volume
 1824 ? 00:00:00 gvfs-afc-volume
 1830 ? 00:00:00 gvfs-gphoto2-vo
 1852 ? 00:00:00 evolution-calen
 1855 ? 00:00:01 fwupd
 1872 ? 00:00:00 gvfsd-trash
 1905 ? 00:00:00 evolution-calen
 1913 ? 00:00:00 gvfsd-metadata
 1925 ? 00:00:00 evolution-addre
 1927 ? 00:00:00 evolution-calen
 1947 ? 00:00:00 evolution-addre
 2010 ? 00:00:00 kworker/1:3H
 2066 ? 00:00:00 zeitgeist-datah
 2078 ? 00:00:00 sh
 2082 ? 00:00:02 zeitgeist-daemo
 2095 ? 00:00:02 zeitgeist-fts
 2372 ? 00:00:00 update-notifier
 2727 ? 00:00:00 deja-dup-monito
 8641 ? 00:00:00 kworker/u8:2
10533 ? 00:00:00 kworker/u8:1
12326 ? 00:00:00 kworker/1:1
12553 ? 00:00:00 kworker/1:1H
13311 ? 00:01:12 chromium-browse
13362 ? 00:00:01 chromium-browse
13382 ? 00:00:00 chromium-browse
13391 ? 00:00:00 gconfd-2
13473 ? 00:00:19 chromium-browse
13836 ? 00:00:01 kworker/0:0
14014 ? 00:00:00 notify-osd
14049 ? 00:00:05 rtkit-daemon
14186 ? 00:00:00 dhclient
14514 ? 00:00:01 kworker/1:2
14626 ? 00:00:00 chromium-browse
14648 ? 00:00:43 chromium-browse
14668 ? 00:00:00 chromium-browse
14678 ? 00:00:00 chromium-browse
14688 ? 00:00:00 chromium-browse
14697 ? 00:00:00 chromium-browse
14721 ? 00:00:01 chromium-browse
14743 ? 00:00:00 chromium-browse
14759 ? 00:00:01 chromium-browse
14769 ? 00:00:00 chromium-browse
14803 ? 00:00:00 kworker/1:0H
14804 ? 00:00:01 chromium-browse
14812 ? 00:00:00 chromium-browse
14830 ? 00:00:00 chromium-browse
14840 ? 00:00:00 chromium-browse
14857 ? 00:00:00 chromium-browse
14866 ? 00:00:00 chromium-browse
14886 ? 00:00:00 chromium-browse
14902 ? 00:00:01 chromium-browse
14921 ? 00:00:01 chromium-browse
14937 ? 00:00:01 chromium-browse
14967 ? 00:00:02 chromium-browse
14988 ? 00:00:00 chromium-browse
15014 ? 00:00:00 chromium-browse
15668 ? 00:00:02 chromium-browse
15683 ? 00:00:00 kworker/u8:0
15793 ? 00:00:01 unity-control-c
15836 ? 00:00:00 kworker/0:2H
16110 ? 00:00:00 kworker/0:2
16657 ? 00:00:00 kworker/1:0
16959 ? 00:00:00 kworker/u8:3
17103 ? 00:00:00 kworker/1:2H
17404 ? 00:00:00 kworker/0:3H
17446 ? 00:00:00 gnome-terminal-
17458 pts/2 00:00:00 bash
17734 ? 00:00:13 chromium-browse
17926 ? 00:00:00 kworker/0:1
18109 ? 00:00:00 pulseaudio
18111 ? 00:00:00 pulseaudio
18112 ? 00:00:00 pulseaudio
18113 pts/2 00:00:00 sudo
18114 pts/2 00:00:00 ps

Is it OK after a reboot?

Joshua Knoke (jknoke) said : #5

After rebooting, it will play the notification sound at the log in screen. Once I log in, all audio stops working. Here is an update of other attempts to get the audio working. I manually killed the pulse audio processes (18109, 18111, 18112), rebooted, and the problem remains. Attempted to launch the pulse audio daemon through command and I got an error message. I deleted the ./config/pulse folder, rebooted, same problem (on reboot it did make a sound at the login screen, once logged in no sound).

Joshua Knoke (jknoke) said : #6

Solved: I purged pulseaudio. As a side effect of purging, several applications that had depended on pulseaudio were also removed (including system settings). I had to sudo apt-get install ubuntu-desktop to restore 'system settings'. I still have other applications that I need to reinstall; however, I now have working audio and 'system settings'. Thank you for your help!