ASUS P5Q SE Plus sound hardware not supported in Intrepid

Asked by raevol on 2009-02-02

I have an ASUS P5Q SE Plus motherboard. It has an onboard VIA VT1708s soundcard. With the default Intrepid alsa installed, audio only comes out of the "rear" audio port, as opposed to the "front" audio port as it should. This is not the ports located on the front and rear of the case, borth ports are on the back of the case, but one is for "front" speakers and one for "rear" in a surround sound speaker setup. This is due to an incorrect driver being used by the outdated alsa version in Intrepid.

I can upgrade my alsa with the script here (http://ubuntuforums.org/showthread.php?p=6589810#post6589810) to solve this problem, HOWEVER THIS CREATES ANOTHER PROBLEM. With this solution I can only get sound from one application at a time. If another application opens that uses audio, all previously playing audio stops and will not come back until the muted application is closed and reopened, stopping audio in all other applications.

I think that the alsa version in Intrepid needs to get upgraded to fix this so that we don't need to jerry-rig our alsa setup and break pulse audio, but I am not a developer and don't know for sure. From a user's perspective this is endlessly frustrating.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
raevol
Solved:
2009-02-20
Last query:
2009-02-20
Last reply:
2009-02-07
Tom (tom6) said : #1

Is it this bug affecting Asus too?

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/286610

I think there's a workaround near the midlle/end of the thread. Also does this help?

http://alsa.opensrc.org/index.php/TroubleShooting

I agree with you that multimedia apps (and games) are still a longer way behind. Even getting the most recent Alsa wont help much but while people keep on going on about picture quality there doesn't seem to be so much attention on sound. Personally i am lucky enough to be able to hear quite clearly even with the sound turned right down because they are so close to where i sit. Listening to music while not sitting in front of my machine is likely to be a different story tho. I think we need to keep plugging away at hardware manufacturers to point out the benefits of investing in OpenSource development as a good way for them to get high quality secure cross-platform drivers/mixers and other tools cheaply.

Hopefully tho, someone will be able to answer your specific query soon
Good luck and regards from
Tom :)

raevol (raevol) said : #2

I'm a bit wary to try that first solution because my box isn't a laptop, and that thread seems to be about a different motherboard. Everything checks out fine when I go through that troubleshooting guide, but the problem persists.

Thanks for the reply! :)

raevol (raevol) said : #4

raevol@jabberwock:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: VIA VT1708S

That codec isn't listed. When I went to the alsa irc channel they told me that my card isn't supported in 1.0.17, which is the current in intrepid. Upgrading to 1.0.18/19 fixed the wrong port problem, but the multiple application problem persists. I assume this is because the upgrade script I used doesn't hook everything up properly, but I don't know.

Tom (tom6) said : #5

Hmmm, we'll get there eventually (i hope) sorry i thought your Asus was a latop because i've been admiring the eee lately. It's nice to see Dell and Asus market ranges with Linux pre-installed :)

raevol (raevol) said : #6

I have an eee, it's super nice. :D I have the very first model though, so the SSD is a bit too small for ubuntu. :( Sorry, off topic!

Tom (tom6) said : #7

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

raevol (raevol) said : #8

Thanks Tom. Do you mean I should post a new launchpad question or post a topic in the forum? I cross-posted this as a topic in the forum, what is the policy on bumping threads in there? I didn't want to cause trouble.

Tom (tom6) said : #9

Ahh, i'm a bit new to this. If you get an answer from elsewhere it'd be nice if you could post it back here so that people can look up this answer in the future - but don't worry hugely
Regards from
Tom :)

raevol (raevol) said : #10

Finally solved my problem by editing my /etc/asound.conf as described here:

http://www.pulseaudio.org/wiki/PerfectSetup#ALSAApplications

Tom (tom6) said : #11

Brilliant. Nicely fixed and well-handled. Welcome in to the Ubuntu communtiy and thanks for contributing more than you received :) All good :)

I'm hoping that this might help with my Glest gaming issue

Good luck and have fun
Regards from
Tom :)

PS any help you can give in answering questions in this forum would be gratefully received. It seems we're a little short on Sound experts in here so your help could go a long way.