Problems with enabling surround (5.1) in hardy on a Realtek HD audio (ALC861VD)

Asked by Joey Michael on 2008-07-21

Trying to enable surround sound with 5.1 creative speakers on Realtek HD audio onboard sound. Tried different sugestions found on the forums but in vain. Please help.

mj@mj-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I'm not able to find the options under volume control preferences for the surround speakers. I tried different things like creating a .asoundrc file with some parameters suggested on some forums. Tried changing the pulse daemon file. None have worked so far.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-27
Last reply:
Joey Michael (joey-eddy) said : #1

I have partially solved this problem by adding
options snd-hda-intel model=6stack-digout to /etc/modprobe.d/alsa-base
Now I have the surround and center tracks in alsa mixer but I'm not able to get sound out of all the speakers yet. Probably some more researching will help solve that problem.

Joey Michael (joey-eddy) said : #2

I still haven't got surround sound working though I now have the channels in the mixer. I have tried out various solutions available but without success.

Can you help with this problem?

Provide an answer of your own, or ask Joey Michael for more information if necessary.

To post a message you must log in.