Headphones not working on Ubuntu 16.04

Asked by Sagar B Hathwar on 2016-09-12

Machine - Alienware 17 R3
Processor - i7-6700HQ
Sound Card (according to alsamixer) - HDA Intel PCH,
Chip (According to alsamixer) - Creative CA0132

Output of alsa-info.sh - http://www.alsa-project.org/db/?f=3f5c34a8a68316209faf24a8d34eeb0fdc0e3199

Output of Alsa-base.conf:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Sound through speakers works perfectly but though wired headphones, doesn't work. I haven't tried using bluetooth headphoens yet

Any help is appreciated
Thank you

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2016-10-10
Last reply:
2016-09-13

Try:

echo "options snd-hda-intel model=laptop" | sudo tee -a /etc/modprobe.d/alsa-base.conf > /dev/null

Reboot to test

Did the required change and rebooted. No changes in the behavior whatsoever. Would like to give out any other required information to get the headphones working.

Thank you

Run:

sudo gedit /etc/modprobe.d/alsa-base.conf

Remove the last line, save the new file and close gedit.

Reboot.

Ok, that is just the opposite of what I did earlier. But it did not work. Any other solution is welcome

Thank you

Yes, the line doesn't do anything so should be removed.

Try:

echo "options snd-hda-intel position_fix=1" | sudo tee -a /etc/modprobe.d/alsa-base.conf > /dev/null

Reboot to test

Tried. Headphones still not working. Sound still being output through speakers

Ok, remove the line and reboot, then use alsamixer in the terminal

Check volume levels and unmute any muted levels.

I fear that your computer is experiencing the following bug, for which there is no solution yet:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1609211

Is there any way in which I can help debug this problem faster? I would really love to help since I have the hardware and can experiment with actions suggested by developers.

Thank you

Can you help with this problem?

Provide an answer of your own, or ask Sagar B Hathwar for more information if necessary.

To post a message you must log in.