16.04 sound issues - "Play Sound through' displays just SPDF & headphones

Asked by William Burden on 2016-08-22

Sound settings used to offer "Play analog sound and allow 5.1 surround sound through my Logitech X-540 5.1 Surround Sound Speaker System. 16.04 upgrade now only displays: Digital Output (S/PDIF) & Headphones and fresh install offered same.

sudo lspci displays (audio only):

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
...
01:05.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series]

aplay -l prints:

    **** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2016-08-22
Last reply:
bitboy (zeus557) said : #1

Hi,

i have a similar Problem on Linuxmint 18.

For me there was a Workaround, which at least makes the card working:
Try adding the following line to your alsa-base.conf
options snd-hda-intel model=intel-alc889a

install pavucontrol
within this program under Input devices you should be able to select analogue 5.1 Output in the Dropdown box. You may Need to try a few Settings.
Note that in my case not all of the 5.1 are working correctly (left side has no Sound). Sadly the original HD Audio Driver from realtek can't be compiled in LM18 /Ubuntu 16.04, ist only for kernel 3.x

If you make any changes in the Default Sound control app, expect that your Sound will be gone and you have to start pavucontrol again.

Can you help with this problem?

Provide an answer of your own, or ask William Burden for more information if necessary.

To post a message you must log in.