How to disable internal microphone and use the one on the headset?

Asked by Rafał Ochmański on 2012-11-03

I have filed a bug[1] because it doesn't happen automatically but maybe there is a way to manually disable internal microphone, and enable the one on headset connected via a combo jack (TRRS)?

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1074641

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-03
Last reply:
2012-11-03

If you open the sound app in dash, you should be able to select the input device there. Do you get one for the inbuilt and one for the plugged in one?

Rafał Ochmański (rmopl) said : #2

There's only one device: Built-in-Audio, and only one input: Analog Input. This is not a USB headset with its own sound card, it's a regular headset connected to the combo mini jack port of the computer's sound card.

Rafał Ochmański (rmopl) said : #3

I have installed hda-jack-retask following http://voices.canonical.com/david.henningsson/2011/11/29/turn-your-mic-jack-into-a-headphone-jack/ and managed to disable the internal mic with the following settings http://makeshiftco.de/~rmo/jack-override.png but not to activate the external microphone.

Can you help with this problem?

Provide an answer of your own, or ask Rafał Ochmański for more information if necessary.

To post a message you must log in.