Ubuntu

Codec: Conexant CX20590 - Mixer: Intel CougarPoint HDMI - card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog] - Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller 8086:1c20 (rev 05) - internal microphone not working on Lenovo G570 in Ubuntu 12.04 LTS

Asked by CatOgre on 2012-06-02

Hello!

I have installed (new installation) Ubuntu 12.04 on Lenovo G570 notebook. Internal microfone doesn't work, but external microfone, connected to according 3,5mm jeck is working normally. There is no different microphones (input devices) in sound settings dialog box.

Sound Card (from aslamixer): HDA Intel PCH, chip: Intel CougarPoint HDMI

Thanks in advance!

Regards,
Vasily

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
CatOgre
Solved:
2012-06-04
Last query:
2012-06-04
Last reply:
2012-06-03

What is the output of:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh

Thanks

CatOgre (vasily-demin) said : #2

The text from this coomands:

alya@Alya-Lenovo-G570:~$ sudo wget -O alsa-info.sh
http://www.alsa-project.org/alsa-info.sh && sudo chmod +x ./alsa-info.sh &&
sudo ./alsa-info.sh
--2012-06-03 10:58:13-- http://www.alsa-project.org/alsa-info.sh
Преобразование адреса www.alsa-project.org (www.alsa-project.org)...
77.48.224.243
Подключение к www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80...
соединились.
Запрос HTTP послан, ожидание ответа... 302 Found
Адрес:
http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh[переход]
--2012-06-03 10:58:13--
http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh
Преобразование адреса git.alsa-project.org (git.alsa-project.org)...
77.48.224.243
Повторное использование соединения с www.alsa-project.org:80.
Запрос HTTP послан, ожидание ответа... 200 OK
Длина: нет данных [text/plain]
Сохранение в каталог: <<<<alsa-info.sh>>>>.

    [ <=> ] 27 247 88,7K/s за
0,3s

2012-06-03 10:58:13 (88,7 KB/s) - <<alsa-info.sh>> сохранено [27247]

ALSA Information Script v 0.4.60
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

pcilib: sysfs_read_vpd: read failed: Connection timed out
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at
http://www.alsa-project.org/db/?f=9c9584e54edb1dd4fa0b557e086b01a245f59250

Please inform the person helping you.

2012/6/2 actionparsnip <email address hidden>

> Your question #199174 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/199174
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> What is the output of:
>
> wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod
> +x ./alsa-info.sh && ./alsa-info.sh
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/199174
>
> You received this question notification because you asked the question.
>

--
~~~~~~~~~~~~~~~~~~~~~~~~~
Vasily Demin
E-mail: <email address hidden>
Skype: CatOgre
ICQ: 272-273-016
~~~~~~~~~~~~~~~~~~~~~~~~~

It seems that the following thread should solve your issue:

https://bugzilla.novell.com/show_bug.cgi?id=735237

So please try this procedure:

Step 1: Open a Terminal

Step 2: Run the following command (copy/paste command into the Terminal
and then hit <enter>)

gksudo gedit /etc/modprobe.d/alsa-base.conf

In the gedit editor, scroll down to the last lines of the alsa-base.conf
file and ADD these 2 lines to the end of the alsa-base.conf file (with
the file open inside the gedit editor!):

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

Step 3: Reboot pc and retest sound input.

Step 4: Make sure that the internal mic is NOT muted in alsamixer after the reboot.

Source: https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/198822

CatOgre (vasily-demin) said : #4

OK! Thank you, Mark! It works!

Both microphones (internal and external) are working well now.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Mark Rijckenberg
Sent: Sunday, June 03, 2012 1:46 PM
To: <email address hidden>
Subject: Re: [Question #199174]: Internal microfone don't work on 12.04

Your question #199174 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/199174

    Status: Open => Answered

Mark Rijckenberg proposed the following answer:
It seems that the following thread should solve your issue:

https://bugzilla.novell.com/show_bug.cgi?id=735237

So please try this procedure:

Step 1: Open a Terminal

Step 2: Run the following command (copy/paste command into the Terminal and then hit <enter>)

gksudo gedit /etc/modprobe.d/alsa-base.conf

In the gedit editor, scroll down to the last lines of the alsa-base.conf file and ADD these 2 lines to the end of the alsa-base.conf file (with the file open inside the gedit editor!):

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

Step 3: Reboot pc and retest sound input.

Step 4: Make sure that the internal mic is NOT muted in alsamixer after the reboot.

Source: https://answers.launchpad.net/ubuntu/+source/alsa-
driver/+question/198822

--
If this answers your question, please go to the following page to let us know that it is solved:
https://answers.launchpad.net/ubuntu/+question/199174/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/199174

You received this question notification because you asked the question.

Please set the thread status to "solved", if the issue is still solved.

CatOgre (vasily-demin) said : #6

Ok! Thanks! Problem solved, I think.