Ubuntu

The sound works when testing but doesnt work in apps

Asked by linden bleijie on 2012-05-27

Hi all, I am having the issue that I have no sound when playing movies/games etc.

When I go into sound preferences and click the test left and right, it works fine. but when I try to watch a movie it is no go!!!

I have a ASUS g51 laptop with built in speakers (it doesnt work from the headphone jack either).

I have done most of the basic trouble shooting guides out there and now am here.

this is the link to the alsa info http://www.alsa-project.org/db/?f=6d73fe776a5e649aaebd34ccf0438a4390bdaa42

Thank you.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-27
Last reply:
2012-05-27

Please read the following:

http://www.gossamer-threads.com/lists/linux/kernel/1167366

If you search for your PC model in that thread, you will see the following:

+ SND_PCI_QUIRK(0x1043, 0x1333, "ASUS G60Jx", ALC663_ASUS_MODE1),

Now if you look up asus mode1 and codec ALC663 in the following document:

tp://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt

you will find the following model option to use and enable in your alsa-base.conf configuration file:

  asus-mode1 (ASUS)

So please proceed with the following procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2a: Use alsamixer to UNMUTE and INCREASE volume on all mixer channels. Some channels are still muted.

Step 2b: Run the following commands (copy/paste each command into the
Terminal and then hit <enter>)

gksudo gedit /etc/modprobe.d/alsa-base.conf

Using the gedit editor, scroll down and add these 3 lines to the end of the alsa-base.conf file and save the
changes:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=asus-mode1

If the asus-mode1 model option does not work, try each of the following model
options ONE BY ONE (NOT several model options at the same time!) and
reboot+retest sound after every change to the alsa-base.conf file:

ALC662/663/272
==============
  3stack-dig 3-stack (2-channel) with SPDIF
  3stack-6ch 3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  5stack-dig 5-stack with SPDIF
  lenovo-101e Lenovo laptop
  eeepc-p701 ASUS Eeepc P701
  eeepc-ep20 ASUS Eeepc EP20
  ecs ECS/Foxconn mobo
  m51va ASUS M51VA
  g71v ASUS G71V
  h13 ASUS H13
  g50v ASUS G50V
  asus-mode1 ASUS
  asus-mode2 ASUS
  asus-mode3 ASUS
  asus-mode4 ASUS
  asus-mode5 ASUS
  asus-mode6 ASUS
  asus-mode7 ASUS
  asus-mode8 ASUS
  dell Dell with ALC272
  dell-zm1 Dell ZM1 with ALC272
  samsung-nc10 Samsung NC10 mini notebook
  auto auto-config reading BIOS (default)

Reboot pc and retest sound using headphones AND speakers.

Please make sure to test sound on both the internal speakers and
headphones on ALL audio ports located on the back and front of your
motherboard.

Before you ask us the question: yes, I know you wrote that your ASUS model is ASUS g51.

But more important is what ALSA THINKS your model is. ALSA wrote that your model is ASUS G60Jx, according to the URL link you sent us:

!!DMI Information
!!---------------

Manufacturer: ASUSTek Computer Inc.
Product Name: G60JX
Product Version: 1.0

That is why I am giving ALSA instructions for model ASUS G60Jx instead of ASUS g51.

Can you help with this problem?

Provide an answer of your own, or ask linden bleijie for more information if necessary.

To post a message you must log in.