Ubuntu

No sound in 12.04

Asked by Pete Heleva on 2012-05-07

Sound mysteriously disappeared after an update/reboot in Ubuntu 12.04. I'm running the Sound Troubleshooting procedure, and have completed step 3 of the Sound Troubleshooting procedure at https://help.ubuntu.com/community/SoundTroubleshootingProcedure.

Here's an output:

!!################################
!!ALSA Information Script v 0.4.60
!!################################

!!Script ran on: Mon May 7 14:03:35 UTC 2012

!!Linux Distribution
!!------------------

Ubuntu 12.04 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"

!!DMI Information
!!---------------

Manufacturer: ASUSTeK Computer Inc.
Product Name: K50IJ
Product Version: 1.0

!!Kernel Information
!!------------------

Kernel release: 3.2.0-24-generic
Operating System: GNU/Linux
Architecture: i686
Processor: i686
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version:
Library version: 1.0.25
Utilities version: 1.0.25

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:293e (rev 03)
 Subsystem: 1111:1043

!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-caiaq: index=-2
snd-usb-ua101: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2
snd-usb-audio: index=-2

!!Loaded sound module options
!!--------------------------

!!ALSA Device nodes
!!-----------------

crw-rw---T 1 root audio 116, 1 May 7 09:55 /dev/snd/seq
crw-rw---T 1 root audio 116, 33 May 7 09:55 /dev/snd/timer

!!Aplay/Arecord output
!!------------

APLAY

aplay: device_list:252: no soundcards found...

ARECORD

arecord: device_list:252: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!-------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
bnep
rfcomm
bluetooth
parport_pc
ppdev
dm_crypt
uvcvideo
videodev
arc4
joydev
ath9k
mac80211
ath9k_common
ath9k_hw
psmouse
binfmt_misc
ath
cfg80211
snd_hda_intel
asus_laptop
sparse_keymap
serio_raw
mac_hid
input_polldev
lp
parport
usbhid
hid
i915
atl1e
drm_kms_helper
drm
i2c_algo_bit
video

!!ALSA/HDA dmesg
!!------------------

As you can see, for some reason the drivers for Alsa aren't showing up. Will continue to step 4, in the meantime any advice to prevent this from happening again is appreciated. The sound was working fine two days ago, stopped working after I put the laptop to sleep for a while.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Pete Heleva
Solved:
2012-05-07
Last query:
2012-05-07
Last reply:
2012-05-07
Pete Heleva (jerryfabin) said : #1

So here's an output of step 4:

cat: /proc/asound/version: No such file or directory
cat: /proc/asound/cards: No such file or directory
cat: /proc/asound/devices: No such file or directory
cat: /proc/asound/hwdep: No such file or directory
cat: /proc/asound/pcm: No such file or directory
cat: /proc/asound/seq/clients: No such file or directory
rm: cannot remove `/etc/asound.conf': No such file or directory
rm: cannot remove `/home/joey/.asound*': No such file or directory
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Ign http://security.ubuntu.com precise-security InRelease
Get:2 http://dl.google.com stable Release [1,347 B]
Ign http://ppa.launchpad.net precise InRelease
Ign http://ppa.launchpad.net precise InRelease
Ign http://us.archive.ubuntu.com precise InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://us.archive.ubuntu.com precise-updates InRelease
Get:3 http://security.ubuntu.com precise-security Release.gpg [198 B]
Get:4 http://dl.google.com stable/main i386 Packages [1,241 B]
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://extras.ubuntu.com precise Release.gpg
Get:5 http://us.archive.ubuntu.com precise Release.gpg [198 B]
Ign http://dl.google.com stable/main TranslationIndex
Get:6 http://security.ubuntu.com precise-security Release [49.6 kB]
Get:7 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B]
Hit http://extras.ubuntu.com precise Release
Hit http://ppa.launchpad.net precise Release.gpg
Get:8 http://us.archive.ubuntu.com precise Release [49.6 kB]
Hit http://extras.ubuntu.com precise/main i386 Packages
Hit http://ppa.launchpad.net precise Release
Ign http://extras.ubuntu.com precise/main TranslationIndex
Hit http://ppa.launchpad.net precise Release
Get:9 http://security.ubuntu.com precise-security/main Sources [7,089 B]
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:10 http://us.archive.ubuntu.com precise-updates Release [49.6 kB]
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main i386 Packages
Get:11 http://security.ubuntu.com precise-security/restricted Sources [14 B]
Get:12 http://security.ubuntu.com precise-security/universe Sources [3,146 B]
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:13 http://security.ubuntu.com precise-security/multiverse Sources [696 B]
Get:14 http://security.ubuntu.com precise-security/main i386 Packages [32.9 kB]
Get:15 http://security.ubuntu.com precise-security/restricted i386 Packages [14 B]
Get:16 http://security.ubuntu.com precise-security/universe i386 Packages [7,470 B]
Get:17 http://security.ubuntu.com precise-security/multiverse i386 Packages [1,393 B]
Get:18 http://security.ubuntu.com precise-security/main TranslationIndex [73 B]
Get:19 http://security.ubuntu.com precise-security/multiverse TranslationIndex [71 B]
Get:20 http://security.ubuntu.com precise-security/restricted TranslationIndex [70 B]
Get:21 http://security.ubuntu.com precise-security/universe TranslationIndex [72 B]
Get:22 http://us.archive.ubuntu.com precise/main Sources [934 kB]
Ign http://dl.google.com stable/main Translation-en_US
Ign http://dl.google.com stable/main Translation-en
Get:23 http://security.ubuntu.com precise-security/main Translation-en [13.6 kB]
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Hit http://security.ubuntu.com precise-security/universe Translation-en
Ign http://extras.ubuntu.com precise/main Translation-en_US
Ign http://extras.ubuntu.com precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_US
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en_US
Ign http://ppa.launchpad.net precise/main Translation-en
Get:24 http://us.archive.ubuntu.com precise/restricted Sources [5,470 B]
Get:25 http://us.archive.ubuntu.com precise/universe Sources [5,019 kB]
Get:26 http://us.archive.ubuntu.com precise/multiverse Sources [155 kB]
Get:27 http://us.archive.ubuntu.com precise/main i386 Packages [1,274 kB]
Get:28 http://us.archive.ubuntu.com precise/restricted i386 Packages [8,431 B]
Get:29 http://us.archive.ubuntu.com precise/universe i386 Packages [4,796 kB]
Get:30 http://us.archive.ubuntu.com precise/multiverse i386 Packages [121 kB]
Hit http://us.archive.ubuntu.com precise/main TranslationIndex
Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise/universe TranslationIndex
Get:31 http://us.archive.ubuntu.com precise-updates/main Sources [19.6 kB]
Get:32 http://us.archive.ubuntu.com precise-updates/restricted Sources [765 B]
Get:33 http://us.archive.ubuntu.com precise-updates/universe Sources [7,430 B]
Get:34 http://us.archive.ubuntu.com precise-updates/multiverse Sources [696 B]
Get:35 http://us.archive.ubuntu.com precise-updates/main i386 Packages [58.6 kB]
Get:36 http://us.archive.ubuntu.com precise-updates/restricted i386 Packages [770 B]
Get:37 http://us.archive.ubuntu.com precise-updates/universe i386 Packages [19.9 kB]
Get:38 http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages [1,393 B]
Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://us.archive.ubuntu.com precise/main Translation-en
Hit http://us.archive.ubuntu.com precise/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise/restricted Translation-en
Hit http://us.archive.ubuntu.com precise/universe Translation-en
Hit http://us.archive.ubuntu.com precise-updates/main Translation-en
Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en
Fetched 12.6 MB in 41s (305 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
No candidate version found for padevchooser
No candidate version found for libsdl1.2debian-pulseaudio
No candidate version found for padevchooser
No candidate version found for libsdl1.2debian-pulseaudio
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

H/W path Device Class Description
======================================================
                               system Notebook
/0 bus K50IJ
/0/0 memory 64KiB BIOS
/0/4 processor Pentium(R) Dual-Core CPU T4200
/0/4/5 memory 64KiB L1 cache
/0/4/7 memory 1MiB L2 cache
/0/4/1.1 processor Logical CPU
/0/4/1.2 processor Logical CPU
/0/6 memory 64KiB L1 cache
/0/1d memory 2GiB System Memory
/0/1d/0 memory 2GiB SODIMM DDR2 Synchronous 667 MHz
/0/1d/1 memory SODIMM [empty]
/0/1 processor
/0/1/1.1 processor Logical CPU
/0/1/1.2 processor Logical CPU
/0/100 bridge Mobile 4 Series Chipset Memory Contro
/0/100/2 display Mobile 4 Series Chipset Integrated Gr
/0/100/2.1 display Mobile 4 Series Chipset Integrated Gr
/0/100/1a bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.1 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.2 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.7 bus 82801I (ICH9 Family) USB2 EHCI Contro
/0/100/1b multimedia 82801I (ICH9 Family) HD Audio Control
/0/100/1c bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.1 bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.1/0 wlan0 network AR9285 Wireless Network Adapter (PCI-
/0/100/1c.5 bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.5/0 eth2 network AR8121/AR8113/AR8114 Gigabit or Fast
/0/100/1d bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.1 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.2 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.7 bus 82801I (ICH9 Family) USB2 EHCI Contro
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1f bridge ICH9M LPC Interface Controller
/0/100/1f.2 scsi0 storage 82801IBM/IEM (ICH9M/ICH9M-E) 4 port S
/0/100/1f.2/0 /dev/sda disk 320GB ST9320325AS
/0/100/1f.2/0/1 /dev/sda1 volume 11GiB Windows FAT volume
/0/100/1f.2/0/2 /dev/sda2 volume 86GiB Windows NTFS volume
/0/100/1f.2/0/3 /dev/sda3 volume 199GiB Extended partition
/0/100/1f.2/0/3/5 /dev/sda5 volume 191GiB Linux filesystem partition
/0/100/1f.2/0/3/6 /dev/sda6 volume 8346MiB Linux swap / Solaris partitio
/0/100/1f.2/1 /dev/cdrom disk DVD A DS8A3S
/1 power F82--22
total 0
drwxr-xr-x 2 root root 80 May 7 09:55 .
crw-rw---T 1 root audio 116, 33 May 7 09:55 timer
crw-rw---T 1 root audio 116, 1 May 7 09:55 seq
drwxr-xr-x 16 root root 4340 May 7 10:12 ..
cat: /dev/sndstat: No such file or directory
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] [8086:2929] (rev 03)
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8121/AR8113/AR8114 Gigabit or Fast Ethernet [1969:1026] (rev b0)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 006 Device 002: ID 0461:4d65 Primax Electronics, Ltd
/usr/sbin/alsactl
Specified filename /dev/dsp does not exist.
dpkg-query: no path found matching pattern *bin/slmodemd*.
[ 0.000000] Found optimal setting for mtrr clean up
[ 0.000000] found SMP MP-table at [c00ff780] ff780
[ 0.163824] ACPI: EC: EC description table is found, configuring boot EC
[ 0.175945] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.223486] ACPI: No dock devices found.
[ 0.223489] HEST: Table not found.
[ 0.272877] pnp: PnP ACPI: found 15 devices
[ 0.312128] audit: initializing netlink socket (disabled)
[ 0.312144] type=2000 audit(1336384498.308:1): initialized
[ 0.367534] ERST: Table is not found!
[ 0.723045] isapnp: No Plug & Play device found
[ 0.793618] Fixed MDIO Bus: probed
[ 0.812196] hub 1-0:1.0: USB hub found
[ 0.832155] hub 2-0:1.0: USB hub found
[ 0.832560] hub 3-0:1.0: USB hub found
[ 0.832899] hub 4-0:1.0: USB hub found
[ 0.833233] hub 5-0:1.0: USB hub found
[ 0.833567] hub 6-0:1.0: USB hub found
[ 0.833897] hub 7-0:1.0: USB hub found
[ 0.834227] hub 8-0:1.0: USB hub found
[ 0.854957] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 26.547117] lp: driver loaded but no devices found
[ 29.452356] psmouse serio4: elantech: assuming hardware version 2 (with firmware version 0x040101)
[ 30.965562] uvcvideo: Found UVC 1.00 device CNF7129 (04f2:b071)
[ 33.472749] type=1400 audit(1336398932.117:2): apparmor="STATUS" operation="profile_load" name="/sbin/dhclient" pid=713 comm="apparmor_parser"
[ 33.472761] type=1400 audit(1336398932.117:3): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=723 comm="apparmor_parser"
[ 33.473263] type=1400 audit(1336398932.117:4): apparmor="STATUS" operation="profile_load" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=723 comm="apparmor_parser"
[ 33.473274] type=1400 audit(1336398932.117:5): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=713 comm="apparmor_parser"
[ 33.473538] type=1400 audit(1336398932.117:6): apparmor="STATUS" operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" pid=723 comm="apparmor_parser"
[ 33.473553] type=1400 audit(1336398932.117:7): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=713 comm="apparmor_parser"
[ 33.474187] type=1400 audit(1336398932.117:8): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=712 comm="apparmor_parser"
[ 33.474707] type=1400 audit(1336398932.117:9): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=712 comm="apparmor_parser"
[ 33.474993] type=1400 audit(1336398932.117:10): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=712 comm="apparmor_parser"
[ 38.522032] type=1400 audit(1336398937.165:11): apparmor="STATUS" operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" pid=857 comm="apparmor_parser"
[ 38.522612] type=1400 audit(1336398937.165:12): apparmor="STATUS" operation="profile_load" name="/usr/sbin/cupsd" pid=857 comm="apparmor_parser"
[ 38.911275] type=1400 audit(1336398937.553:13): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=899 comm="apparmor_parser"
[ 38.914759] type=1400 audit(1336398937.557:14): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=902 comm="apparmor_parser"
[ 38.915267] type=1400 audit(1336398937.557:15): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=902 comm="apparmor_parser"
[ 38.915546] type=1400 audit(1336398937.557:16): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=902 comm="apparmor_parser"
[ 39.284057] type=1400 audit(1336398937.929:17): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=898 comm="apparmor_parser"
[ 39.564511] type=1400 audit(1336398938.209:18): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=907 comm="apparmor_parser"
[ 39.565081] type=1400 audit(1336398938.209:19): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/telepathy-*" pid=907 comm="apparmor_parser"
[ 39.569968] type=1400 audit(1336398938.213:20): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=909 comm="apparmor_parser"
[ 43.793958] apm: BIOS not found.
[ 44.739210] init: alsa-restore main process (968) terminated with status 19
sudo: /etc/init.d/sl-modem-daemon: command not found
 Release Date: 12/04/2009
 Manufacturer: ASUSTeK Computer Inc.
 Product Name: K50IJ
 Serial Number: A3N0AS53266212C
 Manufacturer: ASUSTeK Computer Inc.
 Product Name: K50IJ
 Serial Number: BSN12345678901234567
 Manufacturer: ASUSTeK Computer Inc.
 Serial Number: CSN12345678901234567
 Manufacturer: Intel
 Serial Number: PSN12345678901234567
 Manufacturer: N/A
 Serial Number: N/A
 Manufacturer: N/A
 Serial Number: N/A
 Manufacturer: AS044Ih43E
 Manufacture Date: 01/04/04
 Serial Number: <600
snd_hda_intel 10251 0
usbhid 41906 0
hid 77367 1 usbhid
aplay: device_list:252: no soundcards found...
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).
  *-multimedia UNCLAIMED
       description: Audio device
       product: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:fe9f4000-fe9f7fff

Looks like the sound card isn't working for some reason.

Pete Heleva (jerryfabin) said : #2

Okay, so despite having just loaded alsa, when I try the alsamixer command in terminal, it gives me

cannot open mixer: No such file or directory

So I'm not sure what's up with that.

Pete Heleva (jerryfabin) said : #3

pavu control does not work, either.

I know this is for 9.X ubuntu but may still work for 12.04

http://www.howtogeek.com/howto/10964/how-to-fix-sound-issues-in-ubuntu-9.10/

also is it no sound regardless through the speakers or do you get system sounds but no music?

Pete Heleva (jerryfabin) said : #5

No sounds at all. Sound test in the settings provides nothing.

try:

killall pulseaudio; rm -r ~/.pulse*

wait 10 secods then reboot

Pete Heleva (jerryfabin) said : #7

My friend suggested removing alsa-hda-dkms, and it worked.

The hda had already been loaded, since last week I was using the troubleshooter to solve sound problems (laptop speakers not shutting off when headphone jack plugged in) that turned out to be related to the wrong linux kernel being booted.

So alsa-hda-dkms was the problem. Make of that what you will, devs.

Pete Heleva (jerryfabin) said : #8

kernel problem: I was running linux 3.0 instead of 3.2

Rick Joyner (rljoyner) said : #9

I let the software center upgrade my system this morning and the intel HDA driver stopped working. I removed alsa-hda-dkms, rebooted, and it now works again. These are the current (working) settings:

$grep -i version /tmp/alsa-info.txt.943hLtIZ78
Product Version: To be filled by O.E.M.
!!ALSA Version
Driver version: 1.0.24
Library version: 1.0.25
Utilities version: 1.0.25

$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 42)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:16.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: USB [AudioBox USB], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Only the USB device was showing before the uninstall, i.e. cards 0 & 1 were missing from the "aplay -l" list.

Prior to the removal the sound devices showed the "multimedia UNCLAIMED" messages which I have seen mentioned in other sound card problem reports.