Ubuntu

No sound output from IBM thinkpad - ubuntu 11.10

Asked by Ricky Somerville on 2012-02-25

a few days ago my sound stopped working. happened straight after muting and unmuting from notebooks keyboard. when it was unmuted the sound didn't return, even after several reboots.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-25
Last reply:
2012-02-25

Your Terminal output shows the following issue:

!!-------Mixer controls for card 29 [ThinkPadEC]

Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7BHT37WW-1.10'
  Mixer name : 'ThinkPad EC 7BHT37WW-1.10'
  Components : ''
  Controls : 2
  Simple ctrls : 1
Simple mixer control 'Console',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 14
  Mono: Playback 13 [93%] [off]

Please use alsamixer to switch from mixer 'Analog Devices AD1981' to 'ThinkPad EC 7BHT37WW-1.10'

Then use the M key to UNMUTE the following mixer control which is currently muted:

Simple mixer control 'Console',0

MM = muted (in alsamixer)
00 = unmuted (in alsamixer)

Then retest sound output using headphones and speakers.

If that does not help, please try this procedure:

Step 1: Open Terminal

Step 2: Run the following command (copy/paste command into the Terminal
and then hit <enter>)

gksudo gedit /etc/modprobe.d/alsa-base.conf

In the gedit editor, scroll down and ADD these 2 configuration lines to the end of the
/etc/modprobe.d/alsa-base.conf file:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=thinkpad

SAVE the change to the /etc/modprobe.d/alsa-base.conf file.

Here are the valid model options for the AD1981 codec:

AD1981
======
  basic 3-jack (default)
  hp HP nx6320
  thinkpad Lenovo Thinkpad T60/X60/Z60
  toshiba Toshiba U205

Don't forget to reboot your pc after every change you make to the /etc/modprobe.d/alsa-base.conf file.

Do NOT mix several different model options in the alsa-base.conf file. Only test ONE model option between each reboot.

After each reboot, retest sound output using headphones and speakers.

Hi Mark, thanks heaps for you reply.

Tried to you this....

Please use alsamixer to switch from mixer 'Analog Devices AD1981' to 'ThinkPad EC 7BHT37WW-1.10'

....but I don't get the option to select 'ThinkPad EC 7BHT37WW-1.10' ..... :(

Just trying you second suggestion and about to reboot....

Anyway, still didn't work after the reboot....

I just got it working by doing the following. Maybe it will help others.

Some history... I remember this being an issue some time back (losing sound).

End up being muted in the program called "Banshee media player" (installed in the Sound and Video section). So anyway I unmuted in Banshee and all was fine till it happened again .... so as I don't even use Banshee I unmuted and uninstalled the blasted program thinking that will be the end of it/

Well it after going thru the above with no luck I just re-installed banshee and low and behold it was muted. I unmuted and now have my sound back.

Hope this info helps in improving Ubuntu.

Can you help with this problem?

Provide an answer of your own, or ask Ricky Somerville for more information if necessary.

To post a message you must log in.