no sound after do-release-upgrade to precise p. how to fix?

Asked by ray on 2012-01-13

i have no sound after the upgrade. which steps revive the soundcard? where can i see where it fails now? driver? alsa? pulseaudio?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-12
Last reply:
2012-01-13

try:

killall pulseaudio; rm -r ~/.pulse*

i also suggest you report a bug. precise is not ready and not stable

ray (arkibott) said : #2

this did not solve the issue. i found some details.

the gui sound tools report only the hdmi sound output and the normal sound output is not there. i tried some configurations to get pulseaudio to recognise my soundcard but it does not.

for example i tried to add
load-module module-alsa-sink device=hw:0,0
to the file:
/etc/pulse/default.pa

pulseaudio --kill

pulseaudio --start
but starting does not work when i add the module-alsa-sink lines

i get the device number with aplay -l

so how to fix it? is it a bug?

ray (arkibott) said : #3

for now it works. i did this:

removed the folder ~/.pulse
logout and login - pulseaudio was broken then and no sound settings were shown.

pulseaudio --kill
# killall pulseaudio # as root

# alsamixer -D hw:0 # as root

there i muted/disabled all the hdmi outputs (2nd sound device)
and i set levels and unmuted almost all for the 1st sound device.

pulseaudio --start

i checked the output of pacmd with the command 'list-cards'

while pulseaudio wasn't running i was not able to run pacmd or play files directly with aplay.
somehow it works for now. the sound indicator and system settings show 2 cards and headphones and speakers work.

ray (arkibott) said : #4

Well, the settings won't persist :(

Can you help with this problem?

Provide an answer of your own, or ask ray for more information if necessary.

To post a message you must log in.