snd-ice1724 audio driver not loading for Shuttle SN25P in 11.10

Asked by jlk on 2011-10-21

http://ubuntuforums.org/showpost.php?p=11372897

There is an error recognizing my sound device. From dmesg:

[ 8.865556] ICE1724 0000:06:06.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
[ 8.897462] ice1724: Invalid EEPROM (size = 255)
[ 8.897475] ICE1724 0000:06:06.0: PCI INT A disabled
[ 8.897498] ICE1724: probe of 0000:06:06.0 failed with error -5

I googled a while and found this http://forum.soft32.com/linux2/Sound-Chip-IC-Ensemble-ICE1724-Envy24HT-ftopict23784.html. But I am unable to get that hack to work for me.

~# lspci -v | grep -A7 -i "audio"
06:06.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
        Subsystem: VIA Technologies Inc. Albatron PX865PE 7.1
        Flags: medium devsel, IRQ 18
        I/O ports at a000 [size=32]
        I/O ports at a400 [size=128]
        Capabilities: [80] Power Management version 1
        Kernel modules: snd-ice1724

~# lspci -d 1412:1724 -nvx
06:06.0 0401: 1412:1724 (rev 01)
        Subsystem: 1412:1724
        Flags: medium devsel, IRQ 18
        I/O ports at a000 [size=32]
        I/O ports at a400 [size=128]
        Capabilities: [80] Power Management version 1
        Kernel modules: snd-ice1724
00: 12 14 24 17 01 00 10 02 01 00 01 04 00 20 00 00
10: 01 a0 00 00 01 a4 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 12 14 24 17
30: 00 00 00 00 80 00 00 00 00 00 00 00 0c 01 00 00

 ./alsa-info.sh
ALSA Information Script v 0.4.60
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

/sbin/alsactl: save_state:1519: No soundcards found...
cat: /tmp/alsa-info.bbZ42ttm31/alsactl.tmp: No such file or directory
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=207ae51333d1dd2961b6051c5ee40a9502891a50

Please inform the person helping you.

bash alsa-info.sh --stdout
/sbin/alsactl: save_state:1519: No soundcards found...
cat: /tmp/alsa-info.XuDvsfwP9c/alsactl.tmp: No such file or directory
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.60
!!################################

!!Script ran on: Fri Oct 21 02:48:15 UTC 2011

!!Linux Distribution
!!------------------

Ubuntu 11.10 \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 11.10"

!!DMI Information
!!---------------

Manufacturer: Shuttle Inc
Product Name: SN25V10
Product Version:

!!Kernel Information
!!------------------

Kernel release: 3.0.0-12-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.24
Library version: 1.0.24.1
Utilities version: 1.0.24.2

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

06:06.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!--------------------------------------------------------

06:06.0 0401: 1412:1724 (rev 01)
 Subsystem: 1412:1724

!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-caiaq: index=-2
snd-usb-ua101: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-envy1724: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2
snd-usb-audio: index=-2

!!Loaded sound module options
!!--------------------------

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Oct 20 21:39 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 Oct 20 21:39 /dev/snd/timer

!!Aplay/Arecord output
!!------------

APLAY

aplay: device_list:240: no soundcards found...

ARECORD

arecord: device_list:240: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!-------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
rfcomm
bnep
bluetooth
binfmt_misc
nls_utf8
ntfs
vesafb
nvidia
uvcvideo
videodev
snd_ice1724
snd_rawmidi
v4l2_compat_ioctl32
snd_seq_device
snd_ice17xx_ak4xxx
snd_ac97_codec
ac97_bus
snd_ak4xxx_adda
snd_ak4114
snd_pt2258
snd_i2c
snd_ak4113
snd_pcm
snd_timer
edac_core
ppdev
edac_mce_amd
snd
k8temp
soundcore
snd_page_alloc
parport_pc
i2c_nforce2
shpchp
lp
parport
usbhid
hid
usb_storage
uas
firewire_ohci
firewire_core
crc_itu_t
floppy
sata_nv
pata_amd
forcedeth

!!ALSA/HDA dmesg
!!------------------

cat /proc/asound/{version,cards,devices,hwdep,pcm,seq/clients}; sudo rm /etc/asound.conf; sudo rm -r ~/.pulse ~/.asound* ;sudo rm ~/.pulse-cookie; sudo apt-get update; sudo apt-get install aptitude; sudo aptitude install paman gnome-alsamixer libasound2-plugins padevchooser libsdl1.2debian-pulseaudio; sudo lshw -short;ls -lart /dev/snd; cat /dev/sndstat; lspci -nn; sudo which alsactl; sudo fuser -v /dev/dsp /dev/snd/* ; dpkg -S bin/slmodemd; dmesg | egrep 'EMU|probe|emu|ALSA|alsa|ac97|udi|snd|ound|irmware'; sudo /etc/init.d/sl-modem-daemon status; sudo grep model /etc/modprobe.d/* ; sudo dmidecode|egrep 'anufact|roduct|erial|elease'; lsmod | egrep 'snd|usb|midi|udio'; aplay -l; sudo lshw -C sound
Advanced Linux Sound Architecture Driver Version 1.0.24.
--- no soundcards ---
 33: : timer
cat: /proc/asound/hwdep: No such file or directory
cat: /proc/asound/seq/clients: No such file or directory

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-05
Last reply:
2011-11-05
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

jlk (ibodog) said : #2

Launchpad is useless...

Can you help with this problem?

Provide an answer of your own, or ask jlk for more information if necessary.

To post a message you must log in.