Ubuntu 11.04 No sound, missing hardware

Asked by Saurabh Bajaj on 2011-06-08

About three weeks back, after installing an Ubuntu upgrade, my sound hardware disappeared. Since, then I have no sound from my desktop. I have tried several fixes but with no success....

Any help is greatly appreciated......

Following is the output of the command: ubuntu-bug audio

4509
ERROR: symptom script /usr/share/apport/symptoms/audio.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 56, in thread_collect_info
    package = symb['run'](report, ui)
  File "/usr/share/apport/symptoms/audio.py", line 192, in run
    (package, card, isOutput, jack) = ask_jack_and_card(report, ui)
  File "/usr/share/apport/symptoms/audio.py", line 22, in ask_jack_and_card
    cards = parse_cards()
  File "/usr/share/apport/symptoms/_audio_data.py", line 301, in parse_cards
    cards = add_pa_cards(cards, pactl_parsed)
  File "/usr/share/apport/symptoms/_audio_data.py", line 188, in add_pa_cards
    for pa_card in pactlvalues['Card'].itervalues():
KeyError: 'Card'

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-13
Last reply:
2011-06-10

Can you give the output of:

wget -O alsa-info.sh http://alsa-project.org/alsa-info.sh && bash ./alsa-info.sh

Thanks

Driver version:
Library version: 1.0.24.1
Utilities version: 1.0.24.2

You have no ALSA driver version, which you need. Try:

sudo apt-get -y --reinstall install alsa-base alsa-utils; killall pulseaudio; rm -r ~/.pulse*

Then reboot, should be ok

These instructions have been given in the past by actionparsnip and may help here.

Saurabh Bajaj (saurabhfor02) said : #4

Thanks for your reply. I ran those three commands, but still no sound hardware is detected....

I ran the alsa script again, and looks like still there is no ALSA driver version. Here is the new link: http://www.alsa-project.org/db/?f=cb73e2841ba221eabc76e25e6c56ec53c4ae67e9

Also, FYI, I noticed the below statements when I ran the above script. I though they might be useful in diagnosing the problem:

grep: /proc/asound/cards: No such file or directory
cat: /proc/asound/cards: No such file or directory
cat: /proc/asound/modules: No such file or directory
grep: /proc/asound/cards: No such file or directory
/sbin/alsactl: save_state:1519: No soundcards found...
cat: /tmp/alsa-info.tv0FWucEec/alsactl.tmp: No such file or directory

Thanks!

Saurabh Bajaj (saurabhfor02) said : #5

Anyone?

Can you help with this problem?

Provide an answer of your own, or ask Saurabh Bajaj for more information if necessary.

To post a message you must log in.