Ubuntu

Codec + Mixer: Analog Devices AD1984B - Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04) - sound output working via headphones but not via speakers on HP-Pavilion KT457AA-ABA IQ804 (TouchSmart) in Ubuntu 11.04

Asked by Jay Pritchett on 2011-06-04

Installed Ubuntu 11.04 on HP IQ804 from Windows &. The headphone-jack works but the speakers do not work at all (no sound is coming out). Speakers were working with Windows 7. Played videos from Youtube and played a game of solitaire. No sound from each.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-06-07
Last query:
2011-06-07
Last reply:
2011-06-07

Can you give the output of:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh; chmod +x ./alsa-info.sh; ./alsa-info.sh

Thanks

Jay Pritchett (16397-8) said : #2

Sorry if I didn't mention this earlier but I'm a beginner to the whole linux thing.

Jay Pritchett (16397-8) said : #3

Sorry if I didn't mention this earlier but I'm a beginner to the whole linux thing.

Copy the command and launch a terminal, you can do this easily with CTRL+ALT+T

Paste the command in and hit ENTER

Copy the output and paste here as an update

Thanks

Jay Pritchett (16397-8) said : #5

Update -

Warning: All config files need .conf: /ect/modprobe.d/options, it will be ignored in a future release.
Warning: All config files need .conf: /ect/modprobe.d/alsa-base, it will be ignored in a future release.
Automatically upload ALSA information to www.alsa-project.org? [y/N] :

Your AlSA information is in /tmp/alsa.txt.HhJrjllPPE

Hitting Yes help here, no worry we can just run:

sudo apt-get -y install pastebinit; clear; pastebinit /tmp/alsa.txt.HhJrjllPPE

What is the URL generated?

Thanks

Try:

gksudo gedit /etc/modprobe.d/alsa-base.conf

add:

options snd_hda_intel model=hp-dv5

Save the new file and reboot to test

Jay Pritchett (16397-8) said : #9

added and rebooted but still nothing

Please try this procedure:

Step 1: Open Terminal

Step 2: Run the following command (copy/paste command into the Terminal
and then hit <enter>)

gksudo gedit /etc/modprobe.d/alsa-base.conf

In gedit, scroll down and REMOVE the following configuration line at the end of the
/etc/modprobe.d/alsa-base.conf file:

options snd_hda_intel model=hp-dv5

In gedit, scroll down and ADD these 2 configuration lines to the end of the
/etc/modprobe.d/alsa-base.conf file:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=touchsmart

So try using the touchsmart model option instead of the hp-dv5 model option.

If those alsa-base.conf options don't work, please try these 2 lines
instead and reboot after making the change:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=laptop

Here are more model options:

AD1884A / AD1883 / AD1984A / AD1984B
====================================
  desktop 3-stack desktop (default)
  laptop laptop with HP jack sensing
  mobile mobile devices with HP jack sensing
  thinkpad Lenovo Thinkpad X300
  touchsmart HP Touchsmart

Don't forget to reboot your pc after every change you make to the /etc/modprobe.d/alsa-base.conf file.
So add the desktop model option, reboot, retest sound via headphones AND speakers. Then - if necessary - replace the desktop model option with the laptop model option, reboot and retest sound via headphones AND speakers.
Do NOT mix several different model options in the alsa-base.conf file. Only test ONE model option between each reboot.

A similar issue was solved at the following URL:

https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/153127

Jay Pritchett (16397-8) said : #11

I reinstalled Ubuntu to start fresh and redid the terminal code from your first comment and the output is:

http://www.alsa-project.org/db/?f=c267284e6e3c345d22e9e4263501db2a36a8fb44

Jay Pritchett (16397-8) said : #12

how do you delete comments you need to ignore that last one

We'll just ignore it as you request :)

Jay Pritchett (16397-8) said : #14

Thanks Mark Rijckenberg, that solved my question.

Jay Pritchett (16397-8) said : #15

thanks, changing it to touchsmart fixed it