Mic not working on ALC 880 in Ubuntu 10.10

Asked by Richdan007-gmail on 2011-03-25

Hello,
I've moved for Windows XP to Ubuntu 10.10 and love it! Unfortunately I need to use Skype and Google phone but can't get any sound out of my Microphone which is plugged in the back of my tower. I have tried the front pink plug and that doesn't work either. My sound works fine in my speakers, but nothing comes out from my microphone even in sound recorder.
My tower is a Gateway 505GR with P4 HT Can someone please help me solve this? Other than this problem Ubuntu rocks!
Thanking you in advance.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-25
Last reply:
2011-03-25

Can you please give the output of:

wget -O alsa-info.sh http://alsa-project.org/alsa-info.sh && bash ./alsa-info.sh

thanks

Thank you for the fast response. Like I said I am new to Ubuntu. Can you please tell me how to obtain the output?

copy the line as ONE, press CTRL+ALT+T and paste the command into the terminal. Use TAB and ENTER to navigate the interface and select to upload to the server, it will generate a red URL. What is the URL?

ok run:

gksudo gedit /etc/modprobe.d/alsa-base.conf

add this line:

options snd-hda-intel model=generic

Save the new file and reboot, then test

Still no sound out of the mic. Music, movies, startup sound all work except the mic.

Any body have a solution? Please?

Can you help with this problem?

Provide an answer of your own, or ask Richdan007-gmail for more information if necessary.

To post a message you must log in.