No sound on FRESH install of 10.04 with VIA vt1720/24 envy24 pt/ht ice1724

Asked by triksteerx on 2010-08-23

No sound with via vt1720/24 ubuntu 10.04

   1. Ubuntu
   2. “alsa-driver” package
   3. Questions
   4. Question #122429

Asked by triksteerx on 11 hours ago

On a fresh install of Ubuntu 10.04, alsa does not detect my sound card. This has been a problem on the last three releases of Ubuntu as well. The last released the VIA vt1720/24 line of sound cards worked on was 8.04. I have tried to open alsamixer to unmute, but I get the error no file found. The ICE1724 drivers necessary for this sound card are present. I have tried all tutorials available at help.ubuntu. I was hoping the fact that 10.04 is the newest LTS would mean this would be taken a bit more seriously. The soundcard is present when I run lspci in a terminal.

I have attempted to install alsa-driver-1.0.23 on both Ubuntu 8.04 and 10.04 and both fail to compile at the same point:

  CC [M] /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers/dummy.o
In file included from /usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers/dummy.c:2:
/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers/../alsa-kernel/drivers/dummy.c: In function ‘dummy_hrtimer_callback’:
/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers/../alsa-kernel/drivers/dummy.c:391: error: implicit declaration of function ‘hrtimer_forward_now’
make[3]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers/dummy.o] Error 1
make[2]: *** [/usr/src/Alsa-1.0.23/alsa-driver-1.0.23/drivers] Error 2
make[1]: *** [_module_/usr/src/Alsa-1.0.23/alsa-driver-1.0.23] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-25-generic'
make: *** [compile] Error 2

Why is this? I have tried to manually install and use the script found here:

http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1046137

Question information

triksteerx (triksterx) said : #1

http://monespaceperso.org/blog-en/2010/05/02/upgrade-alsa-1-0-23-on-ubuntu-lucid-lynx-10-04/

This guide has so far worked for getting the compile to work on 10.04. I am waiting until my download grace period to get the "xmlto" program since it is a 450 MB download. I'll update on whether this works for both 8.04 and 10.04 tomorrow after I have gotten the xmlto, which is necessary for alsa-utils to compile correctly.

I think the compile fails because it is not the best procedure to follow....

Instead, please execute step 1 and step 2, then reboot and send us the full terminal output from step 3 and step 4 from this procedure:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

And please also specify the exact model and make of your PC (if known)

Keep in mind that the ALSA upgrade procedure only works for Ubuntu 9.10 or Ubuntu 10.04.

I believe that Ubuntu 8.04 is too old to try to compile ALSA driver 1.0.23

triksteerx (triksterx) said : #5

The guide worked for solving the make problem I was having on 10.04. I didn't get around to downloading the massive program on 8.04, so I don't know if it works there yet. I will do some digging and find out what the most recent version of ALSA compatible with 8.04 is to further help with getting my no sound problem fixed.

triksteerx (triksterx) said : #6

alex@media:~$ bash alsa-info.sh --stdout
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.59
!!################################

!!Script ran on: Tue Aug 24 16:47:34 UTC 2010

!!Linux Distribution
!!------------------

Ubuntu 10.04 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"

!!DMI Information
!!---------------

Manufacturer:
Product Name:

!!Kernel Information
!!------------------

Kernel release: 2.6.32-21-generic
Operating System: GNU/Linux
Architecture: i686
Processor: unknown
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.23
Library version: 1.0.23
Utilities version: 1.0.23

!!Loaded ALSA modules
!!-------------------

snd_mpu401

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

 1 [UART ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10

!!PCI Soundcards installed in the system
!!--------------------------------------

02:0f.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

02:0f.0 0401: 1412:1724 (rev 01)
 Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-

!!Modprobe options (Sound related)
!!--------------------------------

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-usb-caiaq: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2

!!Loaded sound module options
!!--------------------------

!!Module: snd_mpu401
 enable : Y,N,N,N,N,N,N,N
 id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
 index : -2,-2,-2,-2,-2,-2,-2,-2
 irq : 10,65535,65535,65535,65535,65535,65535,65535
 pnp : Y,Y,Y,Y,Y,Y,Y,Y
 port : 816,1,1,1,1,1,1,1
 uart_enter : Y,Y,Y,Y,Y,Y,Y,Y

!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116, 32 Aug 24 09:11 /dev/snd/controlC1
crw-rw----+ 1 root audio 116, 40 Aug 24 09:11 /dev/snd/midiC1D0
crw-rw----+ 1 root audio 116, 1 Aug 24 09:11 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 Aug 24 09:11 /dev/snd/timer

!!Aplay/Arecord output
!!------------

APLAY

**** List of PLAYBACK Hardware Devices ****

ARECORD

**** List of CAPTURE Hardware Devices ****

!!Amixer output
!!-------------

!!-------Mixer controls for card 1 [UART]

Card hw:1 'UART'/'MPU-401 UART at 0x330, irq 10'
  Mixer name : ''
  Components : ''
  Controls : 0
  Simple ctrls : 0

!!Alsactl output
!!-------------

--startcollapse--
state.UART {
 control {
 }
}
--endcollapse--

!!All Loaded Modules
!!------------------

Module
binfmt_misc
snd_wavefront
snd_cs4236
snd_ice1724
snd_ice17xx_ak4xxx
snd_wss_lib
snd_opl3_lib
snd_ac97_codec
ac97_bus
snd_hwdep
snd_mpu401
snd_mpu401_uart
snd_seq_dummy
snd_ak4xxx_adda
snd_ak4114
snd_pt2258
snd_i2c
snd_ak4113
snd_seq_oss
snd_seq_midi
snd_pcm_oss
snd_rawmidi
snd_mixer_oss
snd_seq_midi_event
fbcon
tileblit
font
bitblit
softcursor
vga16fb
vgastate
arc4
snd_seq
snd_pcm
snd_timer
ath5k
nouveau
mac80211
ath
snd_seq_device
snd_page_alloc
ttm
cfg80211
led_class
drm_kms_helper
ppdev
drm
i2c_algo_bit
snd
psmouse
serio_raw
ns558
shpchp
k8temp
gameport
soundcore
parport_pc
amd64_agp
i2c_nforce2
agpgart
lp
parport
ohci1394
usb_storage
tg3
sata_sil
ieee1394
pata_amd
floppy

!!ALSA/HDA dmesg
!!------------------

triksteerx (triksterx) said : #7

alex@media:~$ cat /proc/asound/cards; sudo rm /etc/asound.conf; sudo rm -r ~/.pulse ~/.asound* ;sudo rm ~/.pulse-cookie; sudo apt-get update; sudo apt-get install aptitude; sudo aptitude install paman gnome-alsamixer libasound2-plugins padevchooser libsdl1.2debian-pulseaudio; aplay -l; sudo lshw -C sound; sudo lshw -short;ls -lart /dev/snd; cat /dev/sndstat; lspci -nn; sudo which alsactl; sudo fuser -v /dev/dsp /dev/snd/* ; dpkg -S bin/slmodemd; dmesg | egrep 'EMU|probe|emu|ALSA|alsa|ac97|udi|snd|ound|irmware'; sudo /etc/init.d/sl-modem-daemon status; sudo grep model /etc/modprobe.d/* ; sudo dmidecode|grep roduct; lsmod | grep snd
 1 [UART ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10
[sudo] password for alex:
rm: cannot remove `/etc/asound.conf': No such file or directory
rm: cannot remove `/home/alex/.asound*': No such file or directory
Get:1 http://us.archive.ubuntu.com lucid Release.gpg [189B]
Get:2 http://security.ubuntu.com lucid-security Release.gpg [189B]
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Get:3 http://us.archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Get:4 http://security.ubuntu.com lucid-security Release [38.5kB]
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Get:5 http://us.archive.ubuntu.com lucid Release [57.2kB]
Get:6 http://us.archive.ubuntu.com lucid-updates Release [44.7kB]
Get:7 http://security.ubuntu.com lucid-security/main Packages [60.0kB]
Hit http://us.archive.ubuntu.com lucid/main Packages
Get:8 http://us.archive.ubuntu.com lucid/restricted Packages [6,208B]
Get:9 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:10 http://security.ubuntu.com lucid-security/main Sources [19.6kB]
Hit http://us.archive.ubuntu.com lucid/main Sources
Get:11 http://us.archive.ubuntu.com lucid/restricted Sources [3,775B]
Get:12 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Hit http://us.archive.ubuntu.com lucid/universe Packages
Get:13 http://security.ubuntu.com lucid-security/universe Packages [32.9kB]
Get:14 http://security.ubuntu.com lucid-security/universe Sources [7,041B]
Hit http://us.archive.ubuntu.com lucid/universe Sources
Get:15 http://security.ubuntu.com lucid-security/multiverse Packages [1,998B]
Get:16 http://us.archive.ubuntu.com lucid/multiverse Packages [180kB]
Get:17 http://security.ubuntu.com lucid-security/multiverse Sources [573B]
Get:18 http://us.archive.ubuntu.com lucid/multiverse Sources [119kB]
Hit http://us.archive.ubuntu.com lucid-updates/main Packages
Get:19 http://us.archive.ubuntu.com lucid-updates/restricted Packages [3,252B]
Get:20 http://us.archive.ubuntu.com lucid-updates/main Sources [103kB]
Get:21 http://us.archive.ubuntu.com lucid-updates/restricted Sources [1,292B]
Get:22 http://us.archive.ubuntu.com lucid-updates/universe Packages [102kB]
Get:23 http://us.archive.ubuntu.com lucid-updates/universe Sources [33.8kB]
Get:24 http://us.archive.ubuntu.com lucid-updates/multiverse Packages [3,766B]
Get:25 http://us.archive.ubuntu.com lucid-updates/multiverse Sources [1,508B]
Fetched 820kB in 2min 58s (4,587B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 253 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
The following packages are BROKEN:
  libsdl1.2debian
The following NEW packages will be installed:
  gnome-alsamixer libgconfmm-2.6-1c2{a} libglademm-2.4-1c2a{a} padevchooser
  paman paprefs{a} pavucontrol{a} pavumeter{a}
  pulseaudio-module-zeroconf{a}
The following packages will be upgraded:
  libsdl1.2debian-pulseaudio
1 packages upgraded, 9 newly installed, 0 to remove and 252 not upgraded.
Need to get 658kB of archives. After unpacking 3,482kB will be used.
The following packages have unmet dependencies:
  libsdl1.2debian: Depends: libsdl1.2debian-alsa (= 1.2.14-4ubuntu1) but it is not installable or
                            libsdl1.2debian-all (= 1.2.14-4ubuntu1) but it is not installable or
                            libsdl1.2debian-esd (= 1.2.14-4ubuntu1) but it is not installable or
                            libsdl1.2debian-oss (= 1.2.14-4ubuntu1) but it is not installable or
                            libsdl1.2debian-nas (= 1.2.14-4ubuntu1) but it is not installable or
                            libsdl1.2debian-pulseaudio (= 1.2.14-4ubuntu1) but 1.2.14-4ubuntu1.1 is to be installed.
The following actions will resolve these dependencies:

Upgrade the following packages:
libsdl1.2debian [1.2.14-4ubuntu1 (lucid, now) -> 1.2.14-4ubuntu1.1
(lucid-updates)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  gnome-alsamixer libgconfmm-2.6-1c2{a} libglademm-2.4-1c2a{a} padevchooser
  paman paprefs{a} pavucontrol{a} pavumeter{a}
  pulseaudio-module-zeroconf{a}
The following packages will be upgraded:
  libsdl1.2debian libsdl1.2debian-pulseaudio
2 packages upgraded, 9 newly installed, 0 to remove and 251 not upgraded.
Need to get 681kB of archives. After unpacking 3,482kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/universe gnome-alsamixer 0.9.7~cvs.20060916.ds.1-2 [53.7kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ lucid/main libgconfmm-2.6-1c2 2.28.0-1 [31.4kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ lucid/main libglademm-2.4-1c2a 2.6.7-2build1 [21.8kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main libsdl1.2debian 1.2.14-4ubuntu1.1 [23.3kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main libsdl1.2debian-pulseaudio 1.2.14-4ubuntu1.1 [204kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ lucid/universe pavumeter 0.9.3-1ubuntu1 [29.2kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ lucid/universe pavucontrol 0.9.9-1 [121kB]
Get:8 http://us.archive.ubuntu.com/ubuntu/ lucid/universe paman 0.9.4-1ubuntu2 [92.2kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ lucid/main pulseaudio-module-zeroconf 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 [20.2kB]
Get:10 http://us.archive.ubuntu.com/ubuntu/ lucid/universe paprefs 0.9.9-2ubuntu1 [64.0kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ lucid/universe padevchooser 0.9.3-2ubuntu4 [20.2kB]
Fetched 681kB in 3min 5s (3,676B/s)
Selecting previously deselected package gnome-alsamixer.
(Reading database ... 156595 files and directories currently installed.)
Unpacking gnome-alsamixer (from .../gnome-alsamixer_0.9.7~cvs.20060916.ds.1-2_i386.deb) ...
Selecting previously deselected package libgconfmm-2.6-1c2.
Unpacking libgconfmm-2.6-1c2 (from .../libgconfmm-2.6-1c2_2.28.0-1_i386.deb) ...
Selecting previously deselected package libglademm-2.4-1c2a.
Unpacking libglademm-2.4-1c2a (from .../libglademm-2.4-1c2a_2.6.7-2build1_i386.deb) ...
Preparing to replace libsdl1.2debian 1.2.14-4ubuntu1 (using .../libsdl1.2debian_1.2.14-4ubuntu1.1_i386.deb) ...
Unpacking replacement libsdl1.2debian ...
Preparing to replace libsdl1.2debian-pulseaudio 1.2.14-4ubuntu1 (using .../libsdl1.2debian-pulseaudio_1.2.14-4ubuntu1.1_i386.deb) ...
Unpacking replacement libsdl1.2debian-pulseaudio ...
Selecting previously deselected package pavumeter.
Unpacking pavumeter (from .../pavumeter_0.9.3-1ubuntu1_i386.deb) ...
Selecting previously deselected package pavucontrol.
Unpacking pavucontrol (from .../pavucontrol_0.9.9-1_i386.deb) ...
Selecting previously deselected package paman.
Unpacking paman (from .../paman_0.9.4-1ubuntu2_i386.deb) ...
Selecting previously deselected package pulseaudio-module-zeroconf.
Unpacking pulseaudio-module-zeroconf (from .../pulseaudio-module-zeroconf_1%3a0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14_i386.deb) ...
Selecting previously deselected package paprefs.
Unpacking paprefs (from .../paprefs_0.9.9-2ubuntu1_i386.deb) ...
Selecting previously deselected package padevchooser.
Unpacking padevchooser (from .../padevchooser_0.9.3-2ubuntu4_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Setting up gnome-alsamixer (0.9.7~cvs.20060916.ds.1-2) ...

Setting up libgconfmm-2.6-1c2 (2.28.0-1) ...

Setting up libglademm-2.4-1c2a (2.6.7-2build1) ...

Setting up libsdl1.2debian-pulseaudio (1.2.14-4ubuntu1.1) ...

Setting up libsdl1.2debian (1.2.14-4ubuntu1.1) ...
Setting up pavumeter (0.9.3-1ubuntu1) ...

Setting up pavucontrol (0.9.9-1) ...

Setting up paman (0.9.4-1ubuntu2) ...

Setting up pulseaudio-module-zeroconf (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14) ...
Setting up paprefs (0.9.9-2ubuntu1) ...

Setting up padevchooser (0.9.3-2ubuntu4) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

Current status: 251 updates [-2].
**** List of PLAYBACK Hardware Devices ****
  *-multimedia UNCLAIMED
       description: Multimedia audio controller
       product: VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
       vendor: VIA Technologies Inc.
       physical id: f
       bus info: pci@0000:02:0f.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=32
       resources: ioport:c000(size=32) ioport:c400(size=128)
H/W path Device Class Description
====================================================
                             system PROD00000000
/0 bus nForce3
/0/0 memory 128KiB BIOS
/0/4 processor AMD Athlon(tm) 64 Processor 3200+
/0/4/9 memory 128KiB L1 cache
/0/4/a memory 512KiB L2 cache
/0/1b memory 768MiB System Memory
/0/1b/0 memory 256MiB DIMM
/0/1b/1 memory 256MiB DIMM
/0/1b/2 memory 256MiB DIMM
/0/100 bridge nForce3 250Gb Host Bridge
/0/100/1 bridge nForce3 250Gb LPC Bridge
/0/100/1.1 bus nForce 250Gb PCI System Management
/0/100/2 bus CK8S USB Controller
/0/100/2.1 bus CK8S USB Controller
/0/100/2.2 bus nForce3 EHCI USB 2.0 Controller
/0/100/8 scsi0 storage CK8S Parallel ATA Controller (v2.5)
/0/100/8/0 /dev/sda disk 45GB WDC WD450AA-00BA
/0/100/8/0/1 /dev/sda1 volume 5075MiB EXT4 volume
/0/100/8/0/2 /dev/sda2 volume 36GiB Extended partition
/0/100/8/0/2/5 /dev/sda5 volume 21GiB Linux filesystem partition
/0/100/8/0/2/6 /dev/sda6 volume 1411MiB Linux swap / Solaris partition
/0/100/8/0/2/7 /dev/sda7 volume 5247MiB Linux filesystem partition
/0/100/8/1 /dev/sdb disk 120GB ST3120020A
/0/100/8/1/1 /dev/sdb1 volume 111GiB EXT3 volume
/0/100/8/2 /dev/cdrom1 disk DVD-RAM GSA-H55L
/0/100/8/3 /dev/cdrom disk DVD-ROM SD-M1612
/0/100/b bridge nForce3 250Gb AGP Host to PCI Bridge
/0/100/b/0 display NV34 [GeForce FX 5200]
/0/100/e bridge nForce3 250Gb PCI-to-PCI Bridge
/0/100/e/8 wlan0 network Atheros AR5001X+ Wireless Network Adapt
/0/100/e/a bus VT82xxxxx UHCI USB 1.1 Controller
/0/100/e/a.1 bus VT82xxxxx UHCI USB 1.1 Controller
/0/100/e/a.2 bus USB 2.0
/0/100/e/b bus VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI
/0/100/e/c storage SiI 3114 [SATALink/SATARaid] Serial ATA
/0/100/e/d eth0 network NetXtreme BCM5788 Gigabit Ethernet
/0/100/e/f multimedia VT1720/24 [Envy24PT/HT] PCI Multi-Chann
/0/101 bridge K8 [Athlon64/Opteron] HyperTransport Te
/0/102 bridge K8 [Athlon64/Opteron] Address Map
/0/103 bridge K8 [Athlon64/Opteron] DRAM Controller
/0/104 bridge K8 [Athlon64/Opteron] Miscellaneous Con
/0/1 scsi6 storage
/0/1/0.0.0 /dev/sdc disk SCSI Disk
/0/1/0.0.1 /dev/sdd disk SCSI Disk
/0/1/0.0.2 /dev/sde disk SCSI Disk
/0/1/0.0.3 /dev/sdf disk SCSI Disk
total 0
crw-rw----+ 1 root audio 116, 33 2010-08-24 09:11 timer
crw-rw----+ 1 root audio 116, 1 2010-08-24 09:11 seq
crw-rw----+ 1 root audio 116, 40 2010-08-24 09:11 midiC1D0
drwxr-xr-x 2 root root 120 2010-08-24 09:11 .
crw-rw----+ 1 root audio 116, 32 2010-08-24 09:11 controlC1
drwxr-xr-x 17 root root 4440 2010-08-24 09:57 ..
Sound Driver:3.8.1a-980706 (ALSA v1.0.23 emulation code)
Kernel: Linux media 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
MPU-401 UART at 0x330, irq 10

Audio devices: NOT ENABLED IN CONFIG

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
1: MPU-401 UART MIDI

Timers:
7: system timer

Mixers:
1: mixer10
00:00.0 Host bridge [0600]: nVidia Corporation nForce3 250Gb Host Bridge [10de:00e1] (rev a1)
00:01.0 ISA bridge [0601]: nVidia Corporation nForce3 250Gb LPC Bridge [10de:00e0] (rev a2)
00:01.1 SMBus [0c05]: nVidia Corporation nForce 250Gb PCI System Management [10de:00e4] (rev a1)
00:02.0 USB Controller [0c03]: nVidia Corporation CK8S USB Controller [10de:00e7] (rev a1)
00:02.1 USB Controller [0c03]: nVidia Corporation CK8S USB Controller [10de:00e7] (rev a1)
00:02.2 USB Controller [0c03]: nVidia Corporation nForce3 EHCI USB 2.0 Controller [10de:00e8] (rev a2)
00:08.0 IDE interface [0101]: nVidia Corporation CK8S Parallel ATA Controller (v2.5) [10de:00e5] (rev a2)
00:0b.0 PCI bridge [0604]: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge [10de:00e2] (rev a2)
00:0e.0 PCI bridge [0604]: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge [10de:00ed] (rev a2)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
02:08.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
02:0a.0 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 62)
02:0a.1 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 62)
02:0a.2 USB Controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 65)
02:0b.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller [1106:3044] (rev 46)
02:0c.0 RAID bus controller [0104]: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid] Serial ATA Controller [1095:3114] (rev 02)
02:0d.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet [14e4:169c] (rev 03)
02:0f.0 Multimedia audio controller [0401]: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller [1412:1724] (rev 01)
/usr/sbin/alsactl
Specified filename /dev/dsp does not exist.
dpkg: *bin/slmodemd* not found.
[ 0.000000] Phoenix BIOS detected: BIOS may corrupt low RAM, working around it.
[ 0.000000] found SMP MP-table at [c00f4cb0] f4cb0
[ 0.103746] ACPI: No dock devices found.
[ 0.163236] pnp: PnP ACPI: found 16 devices
[ 0.252453] audit: initializing netlink socket (disabled)
[ 0.252475] type=2000 audit(1282666251.251:1): initialized
[ 0.301338] input: Macintosh mouse button emulation as /devices/virtual/input/input3
[ 0.301995] Fixed MDIO Bus: probed
[ 0.351941] hub 1-0:1.0: USB hub found
[ 0.364449] hub 2-0:1.0: USB hub found
[ 0.441918] hub 3-0:1.0: USB hub found
[ 0.529899] hub 4-0:1.0: USB hub found
[ 0.530569] hub 5-0:1.0: USB hub found
[ 0.530944] hub 6-0:1.0: USB hub found
[ 0.543477] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.547168] powernow-k8: Found 1 AMD Athlon(tm) 64 Processor 3200+ processors (1 cpu cores) (version 2.20.00)
[ 0.549557] [Firmware Bug]: powernow-k8: No PSB or ACPI _PSS objects
[ 0.552835] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.870437] isapnp: No Plug & Play device found
[ 1.330723] scsi6 : SCSI emulation for USB Mass Storage devices
[ 1.330922] usb-storage: device found at 2
[ 20.765304] lp: driver loaded but no devices found
[ 21.604491] type=1505 audit(1282666273.551:2): operation="profile_load" pid=667 name="/sbin/dhclient3"
[ 21.604769] type=1505 audit(1282666273.551:3): operation="profile_load" pid=667 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 21.604922] type=1505 audit(1282666273.551:4): operation="profile_load" pid=667 name="/usr/lib/connman/scripts/dhclient-script"
[ 22.418522] [drm] nouveau 0000:01:00.0: BMP BIOS found
[ 22.418533] [drm] nouveau 0000:01:00.0: Found Display Configuration Block version 2.2
[ 22.523884] agpgart: modprobe tried to set rate=x12. Setting to AGP3 x8 mode.
[ 22.628296] ath5k phy0: Atheros AR2414 chip found (MAC: 0x79, PHY: 0x45)
[ 23.533609] type=1505 audit(1282666275.479:5): operation="profile_load" pid=836 name="/usr/share/gdm/guest-session/Xsession"
[ 23.535380] type=1505 audit(1282666275.479:6): operation="profile_replace" pid=837 name="/sbin/dhclient3"
[ 23.535686] type=1505 audit(1282666275.479:7): operation="profile_replace" pid=837 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 23.535855] type=1505 audit(1282666275.479:8): operation="profile_replace" pid=837 name="/usr/lib/connman/scripts/dhclient-script"
[ 23.541971] type=1505 audit(1282666275.487:9): operation="profile_load" pid=838 name="/usr/bin/evince"
[ 23.545950] type=1505 audit(1282666275.491:10): operation="profile_load" pid=838 name="/usr/bin/evince-previewer"
[ 23.548354] type=1505 audit(1282666275.495:11): operation="profile_load" pid=838 name="/usr/bin/evince-thumbnailer"
[ 23.869936] ice1724: No valid ID is found
[ 23.869996] ICE1724: probe of 0000:02:0f.0 failed with error -5
[ 24.136330] tg3 0000:02:0d.0: firmware: requesting tigon/tg3_tso5.bin
[ 32.580620] wlan0: direct probe to AP 00:1c:df:f2:ba:55 (try 1)
[ 32.585118] wlan0: direct probe responded
[ 932.824021] No probe response from AP 00:1c:df:f2:ba:55 after 500ms, disconnecting.
[ 934.076555] wlan0: direct probe to AP 00:1c:df:f2:ba:55 (try 1)
[ 934.080603] wlan0: direct probe responded
[ 2252.808569] No probe response from AP 00:1c:df:f2:ba:55 after 500ms, disconnecting.
[ 2254.115096] wlan0: direct probe to AP 00:1c:df:f2:ba:55 (try 1)
[ 2254.119635] wlan0: direct probe responded
sudo: /etc/init.d/sl-modem-daemon: command not found
 Product Name:
 Product Name: nForce3
snd_wavefront 34151 0
snd_cs4236 24441 0
snd_ice1724 102967 0
snd_ice17xx_ak4xxx 2547 1 snd_ice1724
snd_wss_lib 21878 2 snd_wavefront,snd_cs4236
snd_opl3_lib 9059 2 snd_wavefront,snd_cs4236
snd_ac97_codec 100600 1 snd_ice1724
ac97_bus 1002 1 snd_ac97_codec
snd_hwdep 5604 2 snd_wavefront,snd_opl3_lib
snd_mpu401 4516 0
snd_mpu401_uart 5809 3 snd_wavefront,snd_cs4236,snd_mpu401
snd_seq_dummy 1434 0
snd_ak4xxx_adda 7968 2 snd_ice1724,snd_ice17xx_ak4xxx
snd_ak4114 7292 1 snd_ice1724
snd_pt2258 3071 1 snd_ice1724
snd_i2c 4233 2 snd_ice1724,snd_pt2258
snd_ak4113 6923 1 snd_ice1724
snd_seq_oss 27242 0
snd_seq_midi 4557 0
snd_pcm_oss 34539 0
snd_rawmidi 19077 4 snd_wavefront,snd_ice1724,snd_mpu401_uart,snd_seq_midi
snd_mixer_oss 13897 1 snd_pcm_oss
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47530 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_pcm 71582 7 snd_cs4236,snd_ice1724,snd_wss_lib,snd_ac97_codec,snd_ak4114,snd_ak4113,snd_pcm_oss
snd_timer 18646 4 snd_wss_lib,snd_opl3_lib,snd_seq,snd_pcm
snd_seq_device 5988 6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_page_alloc 7076 2 snd_wss_lib,snd_pcm
snd 56303 24 snd_wavefront,snd_cs4236,snd_ice1724,snd_wss_lib,snd_opl3_lib,snd_ac97_codec,snd_hwdep,snd_mpu401,snd_mpu401_uart,snd_seq_dummy,snd_ak4xxx_adda,snd_ak4114,snd_pt2258,snd_i2c,snd_ak4113,snd_seq_oss,snd_seq_midi,snd_pcm_oss,snd_rawmidi,snd_mixer_oss,snd_seq,snd_pcm,snd_timer,snd_seq_device
soundcore 6620 1 snd

please also specify the exact model and make of your PC (if known)

triksteerx (triksterx) said : #9

So I also followed steps 5-7. Step 6 gives me control of a virtual dummy device but there is still no actual hardware recognized by Ubuntu. Step 7 just opens a blank window titled GNOME ALSA mixer. Funny thing is when I ran "sudo alsaconf" from the upgrade guide found in step 1 of the help.ubuntu page, alsa saw and configured my sound card successfully. But as soon as I checked aplay and alsa mixer, I got:

alex@media:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
alex@media:~$ alsamixer
cannot open mixer: No such file or directory
alex@media:~$

And I still get that after I have completed step 4 of the troubleshooting guide.

I believe that ALSA is giving the error "ICE1724: probe of 0000:02:0f.0 failed with error -5", because the soundcard has not been manually configured yet using the following ALSA command:

sudo alsaconf

That command is actually the very last command in the ALSA upgrade procedure.

Please read the workaround procedure described at the following location (concerning a very similar issue):

http://<email address hidden>/msg23471.html

So after booting the PC, your sound card is not working out-of-the-box, but should be configured manually using:

sudo alsaconf

Hope it helps.

Is the VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller embedded in the motherboard or an external PCI audio card that you can put into a different PCI slot?

triksteerx (triksterx) said : #12

I did that when I did the manual update like the guide from the troubleshooting page says, and I still have no sound. The controller is embedded on the motherboard. I don't have the make and model of the computer because it was a custom built computer that was given to me by a family member. If there is a way to get the info through a command, I would be more than happy to supply it.

alex@media:~$ sudo alsaconf
Running update-modules...
/usr/sbin/alsaconf: line 929: update-modules: command not found
Setting default volumes...
amixer: Mixer attach default error: No such file or directory
===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

alex@media:~$

Most of the configuration tool is graphical, so this is all the output I could get from running it again.

triksteerx (triksterx) said : #13

I ran "dmidecode -t 2" and all I could get is this:

alex@media:~$ sudo dmidecode -t 2
[sudo] password for alex:
# dmidecode 2.9
SMBIOS 2.2 present.

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
 Manufacturer:
 Product Name: nForce3
 Version:
 Serial Number:

It gives the chipset on my mobo, but it doesn't come up with a manufacturer, sorry.

Bad news.

Apparently there is already a bugreport about this issue that was never solved:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/390410

triksteerx (triksterx) said : #15

How does showing me an expired bug answer my question?

Can you help with this problem?

Provide an answer of your own, or ask triksteerx for more information if necessary.

To post a message you must log in.