audio and video problem on lucid

Asked by Chris Hicks on 2010-08-01

I have a problem with all forms of audio and video, both of which can best be described as "jittery" and the sound also reverberates. The problem appears to be peculiar to Lucid Lynx as it manifests itself on my installed version of Ubuntu 10.04 and the live CD version of Xubuntu 10.04, but not on my installed version of Linux Mint 8 Fluxbox (separate drive on same computer) or the live CD version of Xubuntu 9.04. I would add that with the live CD versions, I was able to test audio only using an audio CD. My sound card is a ForteMedia FM801. Although it is an old-ish computer, running top whilst playing an audio CD does not indicate a resource problem with either CPU (AMD Sempron 1.1GHz) or RAM (750MB).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Chris Hicks
Solved:
2010-08-07
Last query:
2010-08-07
Last reply:
2010-08-03
Jim Bauwens (jimbauwens) said : #1

Try adding the CPU-frequency-scalling applet to a panel to see if your cpu frequency is jumping up and down, if so then set it to the higest frequency.
I had a simular problem and doing this solved it.
But it can also have a total diffent cause.

Jim

Chris Hicks (cph261248) said : #2

Thanks for the suggestion, but applet says my hardware does not support CPU frequency scaling.

Jim Bauwens (jimbauwens) said : #3

Ahh, sorry can't really help you then :(

Jim

Chris Hicks (cph261248) said : #5

I don't think I have the multiple audio card problem. The input tab on Preferences>Sound shows only 1 input device. Also, alplay -l gives:

**** List of PLAYBACK Hardware Devices ****
Home directory /home/christopher not ours.
card 0: FM801AU [ForteMedia FM801-AU], device 0: FM801 [FM801]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I tried tweaking the alsamixer settings, but it made no difference.

I wonder if we're focussing too much on audio only as both audio and video have the jitters.

Jim Bauwens (jimbauwens) said : #6

What graphical card do you have?

Chris Hicks (cph261248) said : #7

My graphics card is a nVidia GeForce2 Ti

Jim Bauwens (jimbauwens) said : #8

Are you using the driver of Nvidia ?
If so then try turning them of, otherwise turn them on.

I don't know if it will help, but you can always try :)

Jim

Chris Hicks (cph261248) said : #9

I installed and enabled the nvidia-96 driver which is the legacy driver that supports GeForce2 cards. That said, the Lucid package details says it specifically excludes support for the Ti. Perhaps not unexpectedly, there was no improvement.

I can't help thinking that the problem is not something that is video-specific or audio-specific, but something that affects both. However, rather than waste any more time on this, maybe I should wait and see what happens when I upgrade Linux Mint to version 9 which I understand is based on Ubuntu 10.04. If the problem manifests itself again, I guess I'll have to resign myself to a hardware upgrade.

Chris Hicks (cph261248) said : #10

Tried the suggestion at http://art.ubuntuforums.org/showthread.php?t=1313253&page=14 to remove pulseaudio and gstreamer0.10-pulseaudio and audio and video now both OK.