installing rpm pack

Asked by bessem

i want to install the MEGA 4 software,
it was tested for ubuntu 7.1
the downloaded pack is rpm
when i use the alien command
"sudo alien -k MEGA-4-02.i386.rpm"
i get this answer
"Unpacking of 'MEGA-4-02.i386.rpm' failed at /usr/share/perl5/Alien/Package/ line 155"
can you help me, or is there another way to install the soft.
thanks for your help

Question information

English Edit question
Ubuntu alien Edit question
No assignee Edit question
Solved by:
Alan Pope 🍺🐧🐱 🦄
Last query:
Last reply:
Revision history for this message
Best Alan Pope 🍺🐧🐱 🦄 (popey) said :

You haven't run out of disk space have you?

Please read this before using alien:-

Installing packages which have been converted from rpm to deb format is generally not recommended.

I tried to do the same thing on my machine and it worked. Here's the resulting deb.

Use at your own risk.

Revision history for this message
bessem (c-bessem) said :

thanks a lot,
i used the deb pack u generated
and install it successfully
(checking with synaptic)
but i can't find it on applications or using the "Add/remove"
cause normally it's a soft for phylogenesis like treeview and clustal X combined.
for the space i have more than 70 Go free

Revision history for this message
juancarlospaco (juancarlospaco) said :

Run the installed program from Terminal, or make a Launcher on Desktop

Revision history for this message
Malick DIATTA (maxi-milck) said :

FIRST try to connect as you by sudo your name.
try to move in the repertory wwhere you're installing the rpm package, and then use the commande tar -xzvf name file
to decompress then type the commande make name file, then make install name file.

Revision history for this message
bessem (c-bessem) said :

thanks for your help
i discovered that it needs wine to be launched
when i tried to launch it from the terminal

Revision history for this message
bessem (c-bessem) said :

Thanks Alan Pope, that solved my question.