Error When Running Alien

Asked by radtad on 2014-12-17

I've been trying to convert a .rpm to a .deb and it errors out.

Here is the command I run.

sudo alien -c adlmflexnetclient-9.0.23-0.x86_64.rpm

Here is what the error I get.

chmod: invalid option -- '/'
Try 'chmod --help' for more information.
mkdir: invalid option -- '/'
Try 'mkdir --help' for more information.
mkdir -p -/debian failed: at /usr/share/perl5/Alien/Package/Deb.pm line 299.

Any help would be great.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alien Edit question
Assignee:
No assignee Edit question
Last query:
2014-12-18
Last reply:
2015-01-02

What is the output of :

lsb_release -a; uname -a; apt-cache policy alien

Thanks

radtad (justinrfischer) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
Linux jfischer-VGN-Z540E 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
alien:
  Installed: 8.90
  Candidate: 8.90
  Version table:
 *** 8.90 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

That doesn't look good. I've done apt-get lsb and lsb-core. Am I missing something here?

radtad (justinrfischer) said : #3

I was able to do this.

sudo apt-get install lsb-core

Now When I run.

lsb_release -a; uname -a; apt-cache policy alien

I get this.

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
Linux jfischer-VGN-Z540E 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
alien:
  Installed: 8.90
  Candidate: 8.90
  Version table:
 *** 8.90 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

But, I still get the same error message in the original post.

Manfred Hampl (m-hampl) said : #4

What is the output of

alien --verbose adlmflexnetclient-9.0.23-0.x86_64.rpm

radtad (justinrfischer) said : #5

 LANG=C rpm -qp --queryformat %{NAME} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{VERSION} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{RELEASE} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{ARCH} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{CHANGELOGTEXT} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{SUMMARY} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{DESCRIPTION} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{PREFIXES} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{POSTIN} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{PREIN} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{PREUN} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{POSTUN} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qp --queryformat %{LICENSE} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qcp 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 rpm -qpi 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 LANG=C rpm -qpl 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 mkdir -
 chmod 755 -
 rpm2cpio 'adlmflexnetclient-9.0.23-0.x86_64.rpm' | lzma -t -q > /dev/null 2>&1
 rpm2cpio 'adlmflexnetclient-9.0.23-0.x86_64.rpm' | (cd -; cpio --extract --make-directories --no-absolute-filenames --preserve-modification-time) 2>&1
 chmod 755 '-/./'
chmod: invalid option -- '/'
Try 'chmod --help' for more information.
 mkdir -p -/debian
mkdir: invalid option -- '/'
Try 'mkdir --help' for more information.
mkdir -p -/debian failed: at /usr/share/perl5/Alien/Package/Deb.pm line 299.
 find - -type d -exec chmod 755 {} ;
 rm -rf -

Manfred Hampl (m-hampl) said : #6

I do not have much experience with rpm packages and alien, but it seems to me that the adlmflexnetclient.rpm file contains data that are different from the format that alien expects.

Speculation: the rpm file does not contain values for name and version, and so the alien script creates wrong commands like "mkdir -" and "cd -" instead of "mkdir name-version" etc.

What is the output of
LANG=C rpm -qp --queryformat %{NAME} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
and
LANG=C rpm -qp -I 'adlmflexnetclient-9.0.23-0.x86_64.rpm'

Manfred Hampl (m-hampl) said : #7

Sorry, typo error (wrong autocorrect), the commands should have been

What is the output of
 LANG=C rpm -qp --queryformat %{NAME} 'adlmflexnetclient-9.0.23-0.x86_64.rpm'
 and
 LANG=C rpm -qp -i 'adlmflexnetclient-9.0.23-0.x86_64.rpm'

radtad (justinrfischer) said : #8

Thanks for the input. I don't get any message when I run those commands.

Manfred Hampl (m-hampl) said : #9

It seems that my guess might be right, and that package does not fulfill the prerequisites for converting it with alien.
You could try installing it with the rpm program instead of converting to .deb and installing with dpkg.

What is the output of

rpm --install --test adlmflexnetclient-9.0.23-0.x86_64.rpm

If that does not produce errors, maybe

rpm -ivh adlmflexnetclient-9.0.23-0.x86_64.rpm

might work.

Azam (azam-joe) said : #10

Hi, I got same problem here. Here the error output:

root@svr007:~# rpm -ivh oracle-instantclient11.2-basic-11.2.0.4.0-1.x86_64.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: oracle-instantclient11.2-basic-11.2.0.4.0-1.x86_64.rpm: rpmReadSignature failed: region trailer: BAD, tag 15872 type 2047 offset 20480 count 4096
error: oracle-instantclient11.2-basic-11.2.0.4.0-1.x86_64.rpm cannot be installed

Azam (azam-joe) said : #11

I think, i got it right. file got a little problem when transferred using ftp. some like binary error. got no problem when transfer using pendrive

Manfred Hampl (m-hampl) said : #12

If the alien command was successful with the other file, and if there is no other problem open with it, you might mark this question as solved.

Can you help with this problem?

Provide an answer of your own, or ask radtad for more information if necessary.

To post a message you must log in.