application submenu gone

Asked by novice on 2011-05-29

I freshly installed Ubuntu 10.10. It worked fine until one day i found that:
[a] The application menu did not display any submenu while clicking on it.
[b] The "Preferences" and "Administration" submenu entries in "System" menu have disappeared.
[c] On right clicking the above two does not display "Edit menus" option in submenu.
Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alacarte Edit question
Assignee:
No assignee Edit question
Solved by:
novice
Solved:
2011-05-30
Last query:
2011-05-30
Last reply:
2011-05-29

gconftool --recursive-unset /apps/panel && killall gnome-panel

Will reset the panels to defaults, does it help?

novice (nnnn-2006) said : #2

It didn't help. I am sorry for slight mistake in part [c] of my question. On right clicking the "Application" & "System" menus, the "Edit menus" option appears but nothing happens on clicking it. Rest of the question is correct.

Sam_ (and-sam) said : #3

To exclude user misconfiguration create a test-user, login and verify if the issue remains on a clean user account.
If the issue isn't in test-user, unfortunately, unless you remember which recent changes have been made in order to revert them, you could move .gnome2 and .config, which means some user defined configurations will be gone and you have to start from scratch.

Close all GUIs and save your work.
Switch to tty (virtual console, text mode only): ctrl+alt+f1
Login with username and passwd.

## To move (backup) .gnome2 and .config type:
mv ~/.gnome2 gnome-backup
mv ~/.config config-backup

sudo reboot

## The *-backup directories will be in your /home/user, where, if necessary, contents successive can be reimported from.

novice (nnnn-2006) said : #4

Thanks!. That solved my problem.