GNOME: .desktop files in /usr/share/applications ignores by menu

Asked by Tobias on 2011-01-25

Hi.
Now I've got a problem.
I used http://library.gnome.org/devel/integration-guide/stable/desktop-files.html.en to create my own .desktop file, containing:
cat /usr/share/applications/sphinxes.desktop
[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=Sphinxes 0.7b
GenericName=Simulation dynamischer Systeme
Comment=Simuliert komplexe dynamische Systeme, Systemdynamik
Type=Application
Exec=/opt/sphinxes_0.7b/run.sh
Icon=application-default-icon
Terminal=true
Categories=Education;Math;

in the right directory with the right permissions.
At first it appears in the gnome-menu (under Education).
Later (when I login again) it is gone.
It appears in the menu-configuration-applet but I have to disable then enable it again to have it in the menu.

Under xubuntu (in the xfce-menu) I find the icons alright all the time.

helpless,

Tobias.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alacarte Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-25
Last reply:
2011-01-26
Tobias (ulbricht-tobias) said : #2

That was done as root. So problem still there.
But thanks for the links, I can try it in /usr/share/gnome/apps additionally.

Sam_ (and-sam) said : #3

When it is gone after login, review .xsession-errors if there is any hint why the entry disappears.
To exclude user misconfiguration, create a test user and reproduce the steps.
If the issue remains consider to file a bug.

Can you help with this problem?

Provide an answer of your own, or ask Tobias for more information if necessary.

To post a message you must log in.