Help I can't rid of the error message. Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

Asked by Rebecca Bigelow on 2010-04-08

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system. i tried going to system monitor but firefox is not listed..i believe i have probably deleted something i wasn't supposed..then when i try to uninstall to reinstall it tells me...One or more applications depend on firefox-3.0. To remove firefox-3.0 and the dependent applications, use the Synaptic package manager. but i don't know which files to remove..can someone please help me.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alacarte Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-08
Last reply:
2011-10-12

I have tried the other related answers and it's not working, system/adm/system monitor and no firefox. What do I do???

Tom (tom6) said : #2

Hi :)

First thing is DONT PANIC :)) lol

Go up to the top taskbar and click on

Applications - Accessories - Terminal

Tom (tom6) said : #3

in the terminal console please type in (or copy & paste with the mouse)

ps aux

or even better use the strange pipe symbol which is usually somewhere near the enter key on american keyboards or between the z and the shift on british ones, it looks a bit like this | but has a whole in the middle on the keyboard. Anyway, try

ps aux | grep firefox

and notice the "Process Id" number

Tom (tom6) said : #4

then use the "Process Id" number you get to do

kill PId

Notice that when you entered

ps aux | grep firefox

it gave you 2 lines? One of them is the real Firefox process but the other is the "ps aux" command itself so you might have to try killing both processes just to be sure.

Good luck and regards from
Tom :)

Thanks for the help, but I don't have applications on my tool bar. The only options I really have is Places and Systems. This program is weird.....

Tom (tom6) said : #6

Hi :)

Alt & F2 should bring up a command-line. Just type in

gnome-terminal

with no spaces in there. Tha\t should bring up a proper terminal console. Into that type

ps aux | grep firefox

kill whatever number

and that should stop the firefox process. I t might be worth right clicking on the top taskbar/panel and doing "Add to panel" and find "Menu Bar". It sounds as though your monitor just needs a bit of adjusting so that the left part of the screen is back on the monitor.

Good luck and regards from
Tom :)

Thanks, but that didn't work either.

Tom (tom6) said : #8

Rebooting or even just logging out should kill the process automatically

Rajinder Sandhu (sandy744) said : #9

for the time being you can use other browser like opera, seamonkey, Namoroka (new name given to firefox 3.6.4pre)

Rajinder Sandhu (sandy744) said : #10

for the time being you can use other browser like opera, seamonkey, Namoroka (new name given to firefox 3.6.4pre)

David Jones (dj) said : #11

This worked for me
   1. Restart your computer. After it restarts, don't try to start Firefox.
   2. Go to your Firefox profile folder - # At the top of the Firefox windowOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Firefox button, go over to the Help menu (on Windows XP, click on the Help menu)On the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.
# Under the Application Basics section, click on Open Containing FolderShow in Finder. A window with your profile filesfolder will open.
   3. Delete the lock file parent.lock.parentlock

  David
  in TN

Can you help with this problem?

Provide an answer of your own, or ask Rebecca Bigelow for more information if necessary.

To post a message you must log in.