Ubuntu

Files deleted after installing adobe flash 10 on AMD 64 Ubuntu 8.10

Asked by Ian22 on 2009-12-10

Last night I tried installing Adobe Flashplayer 10. I have Ubuntu 8.10 64 bit. First, I tried the tutorial at:
http://www.myscienceisbetter.info/install-adobe-flash-player-10-on-ubuntu-64bit.html
but I couldn't get it to work. There is a line that refers to something I assume is 32 bit stuff:
sudo apt-get install ia32-libs nspluginwrapper

Since I couldn't get this to work, I tried using the script at: http://www.myscienceisbetter.info/install-native-64bit-flash-player-10-on-linux.html
The script is:
#!/bin/bash
# Script created by
# Romeo-Adrian Cioaba <email address hidden>

echo "Stopping any Firefox that might be running"
sudo killall -9 firefox

echo "Removing any other flash plugin previously installed:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

echo "Installing Flash Player 10"
cd ~
wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz
tar zxvf libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

echo "Linking the libraries so Firefox and apps depending on XULRunner (vuze, liferea, rsswol) can find it."
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/xulrunner-addons/plugins/

# now doing some cleaning up:
sudo rm -rf libflashplayer.so
sudo rm -rf libflashplayer-10.0.d20.7.linux-x86_64.so.tar.gz

Afterwards, the flashplayer worked. However, my add-ons and bookmarks from firefox were removed, Evolution didn't have my emails or any of my settings, all of my video files are gone, some of my documents are gone, statistics for games like free cell have been reset, and my files for Gnu Cash are gone.

Does anyone have any ideas as to what may have happened? Would that line with the 32 bit stuff have caused this problem? I would like to get my old files, if possible. Thanks in advance.

Ian

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Last query:
2009-12-10
Last reply:
2009-12-16

You have ran a 3rd party script from an unknown author which has deleted some files from your system. The rm lines are not needed really and are there to tidy up. I sugest you reinstall your plugins

If you are using native 64bit flash you do not need ia32-libs or nspluginwrapper. Bookmarks are stored in ~/.mozilla unless you use some online storage for those too in which case reinstalling the addon will work fine.

The dudes email address is there. I suggest you contact him as its is script which screwed your system. There is a lot in there which simply isn't needed and is potentially destructive (using wildcards with rm isnt particularly intelligent)

Can you help with this problem?

Provide an answer of your own, or ask Ian22 for more information if necessary.

To post a message you must log in.