Flash install on 64bit didn't work

Asked by JazMac on 2009-07-17

I'm new to Linux but this is most frustrating to me. Anyway, I followed these instruction
Here is a link to the release notes which has a download link. Here are the install instructions for Flash.

Here are the install scripts
64bit Flash Alpha*
64bit Sun Java beta.*
1. Download either script.
2. Right click on the tar.gz and select "Extract Here"
3. Close all browsers.
4. Inside the folder that extracts is a "Get64bitFlash" or "Get64bitJave" file, double click on it.
5. Select "Run in Terminal"
6. When the terminal closes, restart your browser.
7. Your done.

from this link...
http://ubuntuforums.org/showthread.php?t=772490

I didn't see any errors pop up but when I go to youtube, I'm getting the older flash message and the tubes don't play.

I'm running Ubuntu 9.04 on a AMD 64bit processor

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-17
Last reply:
2009-07-23

This question was originally filed as bug #400658.

Philip Muškovac (yofel) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Mike (mjohnston) said : #2

You might want to try installing flash using the package manager: System > Administration > Synaptic Package Manager

Go to Settings > Repositories and make sure the box for the Multiverse repository is checked.

Search for the package flashplugin-nonfree. If you have already installed an older version of the package you should be able to right click/mark for upgrade. If not, you can right click/mark for installation. Make sure you apply changes when you're done.

You can find more information on using the package manager here: https://help.ubuntu.com/community/SynapticHowto

Jeruvy (jeruvy) said : #3

Give this a try.
Remove any previous packages for flash you installed via synaptic.
Go to this link:

http://labs.adobe.com/downloads/flashplayer10.html

Download the .tar.gz file on this page. I'm assuming it's saved in your '~/Desktop' directory, then
right click on the file and 'Extract here' As of writing this file is called "libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz"
This should extract one file to your Desktop.
Open a terminal and then:

$ cd .mozilla
$ mkdir plugins

If this errors with mkdir complaining that it 'exists' that's fine, just want to make sure it's there.
Then copy the extracted file from the download into this directory ~/.mozilla/plugins/ that you just created

$ cp ~/Desktop/libflash*.so ~/.mozilla/plugins

Startup firefox and enjoy.

Soon (or currently) you should be able to install this directly from a package manager.

Can you help with this problem?

Provide an answer of your own, or ask JazMac for more information if necessary.

To post a message you must log in.