Online Videos Playing Fast

Asked by James Lucas on 2013-01-01

Online Videos (You Tube etc) are playing in fast-forward. I had this problem previously but it just went away. I've tried clicking 'Flash Aid' at the left of the Firefox address bar, but no change. Problem happens with Chrome also.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-01-03
Last query:
2013-01-03
Last reply:
2013-01-02
N1ck 7h0m4d4k15 (nicktux) said : #1

Probably this is a problem with some codec.. Try to install /or/ upgrade your ffmpeg codec.

Thanks

What is the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

James Lucas (james5000lucas) said : #3

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux james-HP-ProBook-4710s 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:45:18 UTC 2012 i686 i686 i386 GNU/Linux
ii flashplugin-installer 11.2.202.258ubuntu0.12.04.1 Adobe Flash Player plugin installer
ii gnash 0.8.10-5ubuntu1 GNU Shockwave Flash (SWF) player
ii gnash-common 0.8.10-5ubuntu1 GNU Shockwave Flash (SWF) player - Common files/libraries

James Lucas (james5000lucas) said : #4

LSB Version:
core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux james-HP-ProBook-4710s 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5
17:45:18 UTC 2012 i686 i686 i386 GNU/Linux
ii flashplugin-installer 11.2.202.258ubuntu0.12.04.1
Adobe Flash Player plugin installer
ii gnash 0.8.10-5ubuntu1 GNU Shockwave Flash
(SWF) player
ii gnash-common 0.8.10-5ubuntu1 GNU
Shockwave Flash (SWF) player - Common files/libraries

On 01/01/13 20:01, actionparsnip wrote:
> Your question #218048 on adobe-flashplugin in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/adobe-flashplugin/+question/218048
>
> actionparsnip requested more information:
> What is the output of:
>
> lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'
>
> Thanks
>

N1ck 7h0m4d4k15 (nicktux) said : #5

Yeap

@actionparsnip has right :-)

You have to remove gnash . Gnash and Adobe flash together can conflict each other.

sudo apt-get purge gnash gnash-common

Credits to @actionparsnip -:)

James Lucas (james5000lucas) said : #6

NikTh - this has not cured this problem. Video still playing fast with no sound.

Run:

sudo apt-get --purge remove flashplugin-installer gnash gnash-common

enable the partner repo and install the adobe-flashplugin package

James Lucas (james5000lucas) said : #8

Thanks, which Flash Plugin version should I select to install:

YUM for Linux (YUM)
.tar.gz for other Linux
.rpm for other Linux
APT for Ubuntu 10.04+

N1ck 7h0m4d4k15 (nicktux) said : #9

Do not download flash player from adobe site.

When you enable the partner repo , the flashplugin should be available in Ubuntu Software Centre

OR

Just Open a terminal and execute

sudo apt-get install adobe-flashplugin

Then close and open Firefox again.

Thanks

James Lucas (james5000lucas) said : #10

Sorry, no joy. Videos are still playing fast and no sound

N1ck 7h0m4d4k15 (nicktux) said : #11

Lets try something else.

Do the full installation of ubuntu-restricted-extras

Install from terminal

sudo apt-get install ubuntu-restricted-extras

and try again.

Thanks

James Lucas (james5000lucas) said : #12

Thanks, but I have still not solved this. Still playing fast and no sound - I reckon YouTube vids play 5x fast, but play is very jumpy - start-stop.

N1ck 7h0m4d4k15 (nicktux) said : #13

Then maybe a problem with graphics ?

Give the results of

lspci -nnk | grep -iA2 vga

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #14

Wait ...

have you installed the ffmpeg codec as I told you in first answer?

sudo apt-get install ffmpeg

Thanks

James Lucas (james5000lucas) said : #15

Thanks Nick, I've now installed ffmpeg, and results are below:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4300 Series] [1002:9552]
 Subsystem: Hewlett-Packard Company Device [103c:3074]
 Kernel driver in use: radeon

Best N1ck 7h0m4d4k15 (nicktux) said : #16

Lets try to install fglrx (the ATI/AMD driver - closed source - for Ubuntu).

sudo apt-get install fglrx fglrx-amdcccle

After the installation finish , you must reboot for the changes take effect.

Thanks

James Lucas (james5000lucas) said : #17

On the plus side - videos now play at normal speed.

However, I have no sound on videos, and now my second monitor will only operate as a mirror of my laptop screen and not as an extension of my desktop as I had previously.

Help, please - this is getting worse!!

Which browsers have you tried?

James Lucas (james5000lucas) said : #19

Firefox and Chrome.
sound has just suddenly come back 1min 30 into a You tube video and I now have sound and normal speed on both chrome and firefox.

But, I still have this problem with my second screen which will not now work as an extended desktop.

James Lucas (james5000lucas) said : #20

Video is playing at normal speed with sound. However, dual monitor is not working, so I will open a new question to deal with that.
Thank you very much for your attention.
James

James Lucas (james5000lucas) said : #21

Thanks NikTh, that solved my question.