Can't see YouTube videos in either Firefox or Chromium

Asked by William Pabon on 2012-09-17

Dont' know why or if it is related, after upgrading Ubuntu 10.04 kernel ( I guess from 2.6.32-38 to -42) I can's see youtube videos. I checked the flash plug-ins installed and I have: (1) flashplugin-installer, (2) flashplugin-nonfree and (3) flashplugin-nonfree-extrasound. I haven't reinstalled the browsers yet. Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Solved by:
William Pabon
Solved:
2012-09-20
Last query:
2012-09-20
Last reply:
2012-09-18

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi ,

try

sudo apt-get install ubuntu-restricted-extras

reboot your PC.

If you think that is kernel's fault , try to boot from older kernel. (If you don't have grub menu then hold down SHIFT key during boot)

Thanks

William Pabon (williepabon) said : #3

Andrew:
As requested.

williepabon@raquel-desktop:~$ sudo lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'
[sudo] password for williepabon:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux raquel-desktop 2.6.32-42-generic #95-Ubuntu SMP Wed Jul 25 15:57:54 UTC 2012 i686 GNU/Linux
ii flashplugin-installer 11.2.202.238ubuntu0.10.04.1 Adobe Flash Player plugin installer
ii flashplugin-nonfree 11.2.202.238ubuntu0.10.04.1 Adobe Flash Player plugin installer (transit
ii flashplugin-nonfree-extrasound 0.0.svn2431-3 Adobe Flash Player platform support library
williepabon@raquel-desktop:~$

William Pabon (williepabon) said : #4

Nick:
Your suggestion I already did, but didn't solve the problem. I don't really know if it is a kernel fault. The problem just happened after the upgrade, as I explained above. Could be a coincidence.
wp

Try:

sudo apt-get --purge remove flashplugin-installer flashplugin-nonfree flashplugin-nonfree-extrasound

Enable the partner repo and install adobe-flashplugin

should help.

Just so you know, Lucid desktop is EOL in April next year so you may want to think about upgrading soon

William Pabon (williepabon) said : #6

Andrew:
Did the first part of your suggestion. Need to know how to enable partner repo (forgot how to do it, sorry. Don't work with this regularly) to install the plugin. Thanks.

Use software centre, or uncomment the lines with 'partner' on them that start with the word 'deb'

William Pabon (williepabon) said : #8

Andrew:
Sorry. Problem still persists on both browsers. Would re-installing the browsers help?

William Pabon (williepabon) said : #9

Andrew:

I checked if the browsers recognized the plugins, and apparently they did as follows:

In Chromium:

Flash (2 files) - Version: 11.2 r202
Shockwave Flash 11.2 r202
Name: Shockwave Flash
Version: 11.2 r202
Location: /usr/lib/flashplugin-installer/libflashplayer.so
Type: NPAPI
   Disable
MIME types:
MIME type Description File extensions
application/x-shockwave-flash Shockwave Flash
.swf
application/futuresplash FutureSplash Player
.spl

Name: Shockwave Flash
Version: 11.2 r202
Location: /usr/lib/mozilla/plugins/libflashplayer.so
Type: NPAPI
   Disable
MIME types:
MIME type Description File extensions
application/x-shockwave-flash Shockwave Flash
.swf
application/futuresplash FutureSplash Player
.spl

In Firefox:
Shockwave Flash

    File: libflashplayer.so
    Version:
    Shockwave Flash 11.2 r202

MIME Type Description Suffixes
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl

Please, let me know if you have any ideas to solve this. Thinking that it was a kernel problem, I updated it to 3.0.0.26, but nothing happened. Thanks.

William Pabon (williepabon) said : #10

Found a solution. David Mc Cann from Linuxquestions.org indicated that the pc (Compaq Presario) may have the wrong (old) CPU for version 11 of Flash. He suggested to install version 10. When I installed such version, the problem disappeared.

Nice one :)

You could even get rid of all flash and install Chrome, it comes with its own flash.

William Pabon (williepabon) said : #12

Andrew:
Tried that one, but the flash version that comes with Chrome doesn't support the Intel Pentium 3 (no sse2 capability) cpu that my Compaq Presario has, and it also crashed. Had to uninstall it. Thanks for the comment.