Can't play any web based video 10.04lts

Asked by Mike Ashley on 2012-04-11

I was able to play all videos, ie hulu, youtube, etc until a few days ago and now when I try to open a video it just sits there - black screen.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-11
Last reply:
2012-04-23
Mike Ashley (mikerashley) said : #1

Sorry about being so general, but am a new (and Avid) convert to Ubuntu and am not quite sure what info is needed to help solve my problem

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

Mike Ashley (mikerashley) said : #3

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux mike-desktop 2.6.32-40-generic #87-Ubuntu SMP Mon Mar 5 20:26:31 UTC 2012 i686 GNU/Linux
ii flashplugin-installer 11.2.202.228ubuntu0.10.04.1 Adobe Flash Player plugin installer
ii gnash 0.8.7-0ubuntu1 free SWF movie player
ii gnash-common 0.8.7-0ubuntu1 free SWF movie player - common files/librari
ii libswfdec-0.8-0 0.8.4-1build1 SWF (Macromedia Flash) decoder library
ii mozilla-plugin-gnash 0.8.7-0ubuntu1 free SWF movie player - Plugin for Mozilla a
ii swfdec-gnome 2.28.0-1 Tools to play SWF files (Macromedia Flash) o

Is this what you need?

Ok you have THREE flash plugins, this causes a conflict and you get nothing. Run:

sudo apt-get --purge remove flashplugin-installer gnash gnash-common libswfdec-0.8-0 mozilla-plugin-gnash swfdec-gnome

sudo apt-get --purge autoremove

sudo apt-get clean

sudo apt-get install flashplugin-installer

Close all browsers and rerun, is it ok?

Mike Ashley (mikerashley) said : #5

I followed your directions but am getting the same result.

In anticipation I ran the previous command you gave me - lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

And this is what it returned -

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid
Linux mike-desktop 2.6.32-40-generic #87-Ubuntu SMP Mon Mar 5 20:26:31 UTC 2012 i686 GNU/Linux
ii flashplugin-installer 11.2.202.228ubuntu0.10.04.1 Adobe Flash Player plugin installer

Mike Ashley (mikerashley) said : #6

BTW I don't know if it helps, but when I hover the cursor over the screen, I don't even get the play/pause/ffw/rew/max/min buttons.

What web browser do you use?

Mike Ashley (mikerashley) said : #8

Default is Firefox, but have tried both Opera, and Chromium with the same results

Mike Ashley (mikerashley) said : #9

The playback area in Firefox & Opera are entirely blank, in Chromium it says missing plugin

ok lets do this my way:

sudo apt-get --purge remove flashplugin-installer
mkdir ~/.mozilla/plugins; cd ~/.mozilla/plugins; wget http://dl.dropbox.com/u/8850924/libflashplayer.so

Close Firefox and rerun it, should be ok

Mike Ashley (mikerashley) said : #11

Did that - same problem in Firefox

In Opera there is a message in the playback screen that says -

Hulu requires Flash Player 10.1.53.64 or higher. Please download and
install the latest version of Flash Player before continuing.

In Chromium a drop down bar stated that - The Flash Plugin Needs your permission to run , when I clicked the button to allow I got

The Following plugin has crashed: Flash Shockwave

Mike Ashley (mikerashley) said : #12

I went to Firefox web browser - plugin check and updates and it is showing Shockwave Flash 11.2 r202 as installed and up to date. then I noticed this message at the beginning of that page

For your safety, Firefox has disabled your outdated version of Java. Please upgrade to the latest version.

Is that a problem?

Java is fine to ignore. Do you have any addons for your browser?

Mike Ashley (mikerashley) said : #14

Yes, -

QuickTime Plug-in 7.6.4
Gecko Media Player 0.9.9.2
Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

Totem
The Totem 2.30.2 plugin handles video and audio streams.

Shockwave Flash
Shockwave Flash 11.2 r202

Windows Media Player Plug-in

Windows Media Player Plug-in
Gecko Media Player 0.9.9.2
Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

DivX Browser Plug-In
Gecko Media Player 0.9.9.2
Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

RealPlayer 9
Gecko Media Player 0.9.9.2
Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

mplayerplug-in is now gecko-mediaplayer 0.9.9.2
Gecko Media Player 0.9.9.2
Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

IcedTea NPR Web Browser Plugin (using IcedTea6 1.9.13 (6b20-1.9.13-0ubuntu1~10.04.1))
The IcedTea NPR Web Browser Plugin (using IcedTea6 1.9.13 (6b20-1.9.13-0ubuntu1~10.04.1)) executes Java applets.

iTunes Application Detector
This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Addons like flashblock, adblock etc....

Mike Ashley (mikerashley) said : #16

Had adblock lite, disabled it trying to fix problem

Can you help with this problem?

Provide an answer of your own, or ask Mike Ashley for more information if necessary.

To post a message you must log in.