Flash player in Ubuntu 11.10 stopped working with recent update

Asked by Hellminer on 2012-03-09

Adobe flash player stopped working before the end of 2011 with an upgrade.

Followed instructions (thanks guys by the way who helped out!) and adobe ability was restored.

But did an upgrade yesterday morning (3/08/2012) that has made adobe flash cease to work again.

What's up?
Is there a new fix to do?

I need step by step instructions if available (not entirely computer saavy).

Thanks in advance for any help!!!!

(And yes, this is propigated by my wife who is a facebook gaming junkie...) :-)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-03-10
Last query:
2012-03-10
Last reply:
2012-03-10

Can you give the output of:
uname -a; lsb_release -a; dpkg -l | egrep 'flash|grep|gnash|spark'
Thanks.

adelisser (adelisser) said : #2

$ uname -a; lsb_release -a; dpkg -l | egrep 'flash|grep|gnash|spark'
Linux desktop 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
ii adobe-flash-properties-gtk:i386 11.1.102.63-0oneiric1 GTK+ control panel for Adobe Flash Player plugin version 11
ii adobe-flashplugin:i386 11.1.102.63-0oneiric1 Adobe Flash Player plugin version 11
ii browser-plugin-gnash 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player - Plugin for Mozilla and derivatives
rc flashplugin-installer 11.1.102.62ubuntu0.11.10.2 Adobe Flash Player plugin installer
ii gnash 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player
ii gnash-common 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player - Common files/libraries
ii grep 2.9-1 GNU grep, egrep and fgrep

sudo apt-get --purge remove adobe-flash-properties-gtk:i386 adobe-flashplugin:i386 browser-plugin-gnash gnash-common gnash
sudo dpkg -P flashplugin-installer

Enable the partner repo and run:

sudo apt-get install adobe-installer

This will give 64bit flash for your 64bit OS.

Hellminer (mywiseman) said : #4

actionparsnip - I got the first parts of your last message done, but when I went to sudo apt-get install adobe installer the puter told me it couldn't find adobe installer. My guess is I have no idea what enable the partner repo means. Can you hit me back? The commands uptop worked fine. removed all the old junk in other words

Hellminer

ok what is the output of:

apt-cache search adobe

Thanks

Hellminer (mywiseman) said : #6

cmap-adobe-cns1 - CMaps for Adobe-CNS1
cmap-adobe-gb1 - CMaps for Adobe-GB1
cmap-adobe-japan1 - CMaps for Adobe-Japan1
cmap-adobe-japan2 - CMaps for Adobe-Japan2
cmap-adobe-korea1 - CMaps for Adobe-Korea1
gs-cjk-resource - Resource files for gs-cjk, ghostscript CJK-TrueType extension
gsfonts - Fonts for the Ghostscript interpreter(s)
gsfonts-x11 - Make Ghostscript fonts available to X11
libfont-afm-perl - Font::AFM - Interface to Adobe Font Metrics files
libjbig2dec0 - JBIG2 decoder library - shared libraries
libjbig2dec0-dev - JBIG2 decoder library - development files
libquvi-dev - library for parsing video download links (development package)
libquvi-doc - library for parsing video download links (documentation package)
libquvi0 - library for parsing video download links (runtime libraries)
poppler-data - Encoding data for the poppler PDF rendering library
python-reportlab - ReportLab library to create PDF documents using Python
python-reportlab-doc - Documentation for the ReportLab Python library (PDF format)
python-scour - SVG scrubber and optimizer
python-uniconvertor - Universal vector graphics translator
texlive-font-utils - TeX Live: TeX and Outline font utilities
texlive-fonts-extra - TeX Live: Extra fonts
texlive-fonts-recommended - TeX Live: Recommended fonts
xfonts-scalable - scalable fonts for X
xaralx - Heavyweight vector graphics, illustration and DTP Program
flashplugin-nonfree-extrasound - Adobe Flash Player platform support library for Esound and OSS
abr2gbr - Converts PhotoShop brushes to GIMP
aglfn - Adobe Glyph List For New Fonts
autotrace - bitmap to vector graphics converter
bleachbit - delete unnecessary files from the system
cclive - lightweight command line video extraction tool
cenon.app - Vector graphics tool for GNUstep
clive - video extraction utility for YouTube, Google Video and others
cm-super - TeX font package (full version) with CM (EC) in Type1 in T1, T2*, TS1, X2 enc
cm-super-minimal - TeX font package (minimal version) with CM/EC in Type1 in T1, T2*, TS1, X2 enc
dvi2ps-fontdata-three - Font data of Adobe Japanese fonts (futomin, futogo, jun101)
jbig2dec - JBIG2 decoder library - tools
lcdf-typetools - Programs to manipulate OpenType and multiple-master fonts
libdata-amf-perl - Perl module for serialize / deserialize AMF data
libjempbox-java - XMP Compatible Java Library
libjempbox-java-doc - XMP Compatible Java Library (documentation)
libpdf-api2-perl - module for creating or modifying PDF documents in Perl
libpdf-fdf-simple-perl - Perl module to read and write (Acrobat) FDF files
libpostscript-file-perl - module for creating Adobe PostScript files
pdfresurrect - tool for extracting/scrubbing versioning data from PDF documents
pecomato - Picture-embedded contents manipulation tool
pyjamas - Python web widget toolkit and Python-to-Javascript compiler
red5-doc - flash streaming server - documentation
red5-server - flash streaming server
subtitleeditor - Graphical subtitle editor with sound waves representation
t1-cyrillic - A basic set of free PostScript fonts
tex-gyre - scalable PostScript and OpenType fonts based on URW Fonts
texlive-games - TeX Live: Games typesetting
ttf-adf-ikarius - Ikarius font of the Arkandis Digital Foundry
wings3d - Nendo-inspired 3D polygon mesh modeller
xpdf - Portable Document Format (PDF) reader
konqueror-nsplugins - Netscape plugin support for Konqueror
libfreetype6 - FreeType 2 font engine, shared library files
flashplugin-installer - Adobe Flash Player plugin installer
flashplugin-downloader - Adobe Flash Player plugin installer (transitional package)
acroread - Adobe Reader
adobe-flashplugin - Adobe Flash Player plugin version 11
adobereader-deu - Adobe Reader
adobe-flash-properties-gtk - GTK+ control panel for Adobe Flash Player plugin version 11
adobe-flash-properties-kde - KDE control panel Adobe Flash Player plugin version 11
adobereader-fra - Adobe Reader
adobereader-jpn - Adobe Reader
acroread-common - Adobe Reader - Common Files
flashplugin-nonfree - Adobe Flash Player plugin installer

sudo apt-get install adobe-flashplugin

Will install it

Hellminer (mywiseman) said : #8

You are a genius! Thank you times a million!

Hellminer (mywiseman) said : #9

Thanks actionparsnip, that solved my question.