Adobe not recognized

Asked by stoutimore on 2012-02-23

My issue is like #176536. I have Oneiric.

Things worked okay until a couple of weeks ago. Now I'm get error messages saying "Adobe required . . ." but synaptic shows I have it installed. Synaptic shows I have version 11, but Firefox shows 9.4 in its plugin options.

I ran through the terminal proceedures in #176536 without any luck. Then installed Chromium to see if it presents the same issues. It does. A pay site I use, www.Ancestry.com, won't let me view pdf docs at all. Some free sites let me view Adobe docs, but the font sizes are erratic. If I select to view them with Evince, they show perfectly. Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu adobe-flashplugin Edit question
Assignee:
No assignee Edit question
Solved by:
stoutimore
Solved:
2012-02-23
Last query:
2012-02-23
Last reply:
2012-02-23

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

stoutimore (stoutimore) said : #2

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux johnlinux-desktop 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 i686 i386 GNU/Linux
ii adobe-flash-properties-gtk 11.1.102.62-0oneiric1 GTK+ control panel for Adobe Flash Player plugin version 11
ii adobe-flashplugin 11.1.102.62-0oneiric1 Adobe Flash Player plugin version 11
ii browser-plugin-gnash 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player - Plugin for Mozilla and derivatives
ii gnash 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player
ii gnash-common 0.8.10~git20110618-3ubuntu1 GNU Shockwave Flash (SWF) player - Common files/libraries
ii mozilla-plugin-gnash 0.8.10~git20110618-3ubuntu1 dummy package for renaming to browser-plugin-gnash

As I thought, too many plugins. If yuo install more than one plugin, they conflict and you get nothing. If you run:

sudo apt-get --purge remove adobe-flash-properties-gtk adobe-flashplugin browser-plugin-gnash gnash gnash-common mozilla-plugin-gnash; sudo apt-get --purge autoremove

It will remove ALL flash, you can then run:

sudo apt-get clean; sudo apt-get update; sudo apt-get install flashplugin-installer

And you will only have Adobe Flash (Adobe is a company, not a product so you cannot install Adobe, you can however install Adobe flash. By the same token you cannot install Microsoft, but you can install Microsoft Office XP etc).

stoutimore (stoutimore) said : #4

That did the trick. Thank's a million! When you open a document with Adobe in Ancestry.com, you get a floating box that says: "You've been selected to try our new image viewer." Looking back on it, I'll bet I checked the box. Now I know better. Thanks again.