Error with dpkg when install or upgrade : E: Sub-process /usr/bin/dpkg returned an error code (1)

Asked by Hazel on 2017-11-13

Dear all,

I am new to Ubuntu and was totally no idea how to solve this problem. The following is the error getting from my screen. Please help me out with this. Thank you so much.
Setting up dbus (1.6.18-0ubuntu4.3) ...
Can't locate Debian/AdduserCommon.pm in @INC (you may need to install the Debian::AdduserCommon module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/sbin/adduser line 34.
BEGIN failed--compilation aborted at /usr/sbin/adduser line 34.
dpkg: error processing package dbus (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of accountsservice:
 accountsservice depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package accountsservice (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of language-selector-common:
 language-selector-common depends on dbus; however:
  Package dbus is not configured yet.
 language-selector-common depends on accountsservice (>= 0.6.29-1ubuntu6); however:
  Package accountsservice is not configured yet.

dpkg: error processing package language-selector-common (--configure):
 dependency problems - leaving unconfigured
Setting up cmake-data (3.2.2-2~ubuntu14.04.1~ppa1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
               Setting up libjsoncpp0:amd64 (0.6.0~rc2-3ubuntu1) ...
Setting up cmake (3.2.2-2~ubuntu14.04.1~ppa1) ...
Installing new version of config file /etc/bash_completion.d/ctest ...
Setting up cmake-curses-gui (3.2.2-2~ubuntu14.04.1~ppa1) ...
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            No apport report written because MaxReports is reached already
                                                                                                                                                                                          dpkg: dependency problems prevent configuration of dbus-x11:
 dbus-x11 depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package dbus-x11 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-keyring:
 gnome-keyring depends on dbus-x11; however:
  Package dbus-x11 is not configured yet.

dpkg: error processing package gnome-keyring (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of systemd-services:
 systemd-services depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package systemd-services (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpam-systemd:amd64:
 libpam-systemd:amd64 depends on systemd-services (= 204-5ubuntu20.19); however:
  Package systemd-services is not configured yet.

dpkg: error processing package libpam-systemdNo apport report written because MaxReports is reached already
                                                                                                           No apport report written because MaxReports is reached already
                                                                                                                                                                         :amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lightdm:
 lightdm depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package lightdm (--configure):
 dependency problems - leaving unconfigured
Setting up mysql-server-5.5 (5.5.49-0ubuntu0.14.04.1) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            No apport report written because MaxReports is reached already
                                                                                                                                                                                          No apport report written because MaxReports is reached already
                                                   No apport report written because MaxReports is reached already
                                                                                                                 No apport report written because MaxReports is reached already
                                                                                                                                                                               No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
                                                                                                      No apport report written because MaxReports is reached already
                                                                                                                                                                    No apport report written because MaxReports is reached already
                             No apport report written because MaxReports is reached already
                                                                                           No apport report written because MaxReports is reached already
                                                                                                                                                         No apport report written because MaxReports is reached already
                  No apport report written because MaxReports is reached already
                                                                                No apport report written because MaxReports is reached already
                                                                                                                                              No apport report written because MaxReports is reached already
       No apport report written because MaxReports is reached already
                                                                     No apport report written because MaxReports is reached already
                                                                                                                                   No apport report written because MaxReports is reached already
                                                                                                                                                                                                 No apport report written because MaxReports is reached already
                                                          No apport report written because MaxReports is reached already
                                                                                                                        No apport report written because MaxReports is reached already
                                                                                                                                                                                      No apport report written because MaxReports is reached already
                                               No apport report written because MaxReports is reached already
                                                                                                             No apport report written because MaxReports is reached already
                                                                                                                                                                           No apport report written because MaxReports is reached already
                                    No apport report written because MaxReports is reached already
                                                                                                  No apport report written because MaxReports is reached already
                                                                                                                                                                No apport report written because MaxReports is reached already
                         No apport report written because MaxReports is reached already
                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                     No apport report written because MaxReports is reached already
              No apport report written because MaxReports is reached already
                                                                            No apport report written because MaxReports is reached already
                                                                                                                                          No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 dpkg: error processing package mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of policykit-1:
 policykit-1 depends on libpam-systemd; however:
  Package libpam-systemd:amd64 is not configured yet.
 policykit-1 depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package policykit-1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager:
 network-manager depends on dbus (>= 1.1.2); however:
  Package dbus is not configured yet.
 network-manager depends on policykit-1; however:
  Package policykit-1 is not configured yet.

dpkg: error processing package network-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of empathy:
 empathy depends on dbus-x11; however:
  Package dbus-x11 is not configured yet.

dpkg: error processing package empathy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mcp-account-manager-uoa:
 mcp-account-manager-uoa depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.

dpkg: error processing package mcp-account-manager-uoa (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of account-plugin-aim:
 account-plugin-aim depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.
 account-plugin-aim depends on mcp-account-manager-uoa; however:
  Package mcp-account-manager-uoa is not configured yet.

dpkg: error processing package account-plugin-aim (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of account-plugin-jabber:
 account-plugin-jabber depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.
 account-plugin-jabber depends on mcp-account-manager-uoa; however:
  Package mcp-account-manager-uoa is not configured yet.

dpkg: error processing package account-plugin-jabber (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of account-plugin-salut:
 account-plugin-salut depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.
 account-plugin-salut depends on mcp-account-manager-uoa; however:
  Package mcp-account-manager-uoa is not configured yet.

dpkg: error processing package account-plugin-salut (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of account-plugin-yahoo:
 account-plugin-yahoo depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.
 account-plugin-yahoo depends on mcp-account-manager-uoa; however:
  Package mcp-account-manager-uoa is not configured yet.

dpkg: error processing package account-plugin-yahoo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bluez:
 bluez depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package bluez (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bluez-alsa:amd64:
 bluez-alsa:amd64 depends on bluez; however:
  Package bluez is not configured yet.

dpkg: error processing package bluez-alsa:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bluez-gstreamer:
 bluez-gstreamer depends on bluez; however:
  Package bluez is not configured yet.

dpkg: error processing package bluez-gstreamer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-settings-daemon:
 unity-settings-daemon depends on accountsservice (>= 0.6.34); however:
  Package accountsservice is not configured yet.

dpkg: error processing package unity-settings-daemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center:
 unity-control-center depends on accountsservice; however:
  Package accountsservice is not configured yet.
 unity-control-center depends on unity-settings-daemon; however:
  Package unity-settings-daemon is not configured yet.

dpkg: error processing package unity-control-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of udisks2:
 udisks2 depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package udisks2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs-daemons:
 gvfs-daemons depends on udisks2; however:
  Package udisks2 is not configured yet.

dpkg: error processing package gvfs-daemons (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs:amd64:
 gvfs:amd64 depends on gvfs-daemons (>= 1.20.3-0ubuntu1.2); however:
  Package gvfs-daemons is not configured yet.
 gvfs:amd64 depends on gvfs-daemons (<< 1.20.3-0ubuntu1.2.1~); however:
  Package gvfs-daemons is not configured yet.

dpkg: error processing package gvfs:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
 nautilus depends on gvfs (>= 1.3.2); however:
  Package gvfs:amd64 is not configured yet.

dpkg: error processing package nautilus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-bluetooth:
 gnome-bluetooth depends on bluez (>= 4.36); however:
  Package bluez is not configured yet.

dpkg: error processing package gnome-bluetooth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on network-manager (>= 0.9.8); however:
  Package network-manager is not configured yet.
 network-manager-gnome depends on dbus-x11; however:
  Package dbus-x11 is not configured yet.

dpkg: error processing package network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session-bin:
 gnome-session-bin depends on dbus-x11; however:
  Package dbus-x11 is not configured yet.

dpkg: error processing package gnome-session-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session:
 gnome-session depends on gnome-session-bin (>= 3.9.90-0ubuntu12.1); however:
  Package gnome-session-bin is not configured yet.
 gnome-session depends on gnome-session-bin (<< 3.10); however:
  Package gnome-session-bin is not configured yet.

dpkg: error processing package gnome-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs-backends:
 gvfs-backends depends on gvfs (= 1.20.3-0ubuntu1.2); however:
  Package gvfs:amd64 is not configured yet.
 gvfs-backends depends on gvfs-daemons (= 1.20.3-0ubuntu1.2); however:
  Package gvfs-daemons is not configured yet.

dpkg: error processing package gvfs-backends (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs-fuse:
 gvfs-fuse depends on gvfs (= 1.20.3-0ubuntu1.2); however:
  Package gvfs:amd64 is not configured yet.

dpkg: error processing package gvfs-fuse (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hplip:
 hplip depends on policykit-1; however:
  Package policykit-1 is not configured yet.

dpkg: error processing package hplip (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-postscript-hp:
 printer-driver-postscript-hp depends on hplip (>= 3.14.3-0ubuntu3.4); however:
  Package hplip is not configured yet.

dpkg: error processing package printer-driver-postscript-hp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-session:
 indicator-session depends on systemd-services; however:
  Package systemd-services is not configured yet.

dpkg: error processing package indicator-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of landscape-client-ui-install:
 landscape-client-ui-install depends on policykit-1; however:
  Package policykit-1 is not configured yet.

dpkg: error processing package landscape-client-ui-install (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of aptdaemon:
 aptdaemon depends on policykit-1; however:
  Package policykit-1 is not configured yet.

dpkg: error processing package aptdaemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of language-selector-gnome:
 language-selector-gnome depends on language-selector-common (= 0.129.3); however:
  Package language-selector-common is not configured yet.
 language-selector-gnome depends on aptdaemon (>= 0.40+bzr527); however:
  Package aptdaemon is not configured yet.

dpkg: error processing package language-selector-gnome (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-sendto-empathy:
 nautilus-sendto-empathy depends on empathy (= 3.8.6-0ubuntu9.2); however:
  Package empathy is not configured yet.

dpkg: error processing package nautilus-sendto-empathy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio:
 pulseaudio depends on libpam-systemd; however:
  Package libpam-systemd:amd64 is not configured yet.

dpkg: error processing package pulseaudio (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-gconf:
 pulseaudio-module-gconf depends on pulseaudio; however:
  Package pulseaudio is not configured yet.

dpkg: error processing package pulseaudio-module-gconf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
 pulseaudio-module-x11 depends on pulseaudio; however:
  Package pulseaudio is not configured yet.

dpkg: error processing package pulseaudio-module-x11 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of shotwell:
 shotwell depends on dbus-x11; however:
  Package dbus-x11 is not configured yet.

dpkg: error processing package shotwell (--configure):
 dependency problems - leaving unconfigured
Setting up sphinxsearch (2.0.4-1.1ubuntu2) ...
Can't locate Debian/AdduserCommon.pm in @INC (you may need to install the Debian::AdduserCommon module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/sbin/adduser line 34.
BEGIN failed--compilation aborted at /usr/sbin/adduser line 34.
dpkg: error processing package sphinxsearch (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on policykit-1; however:
  Package policykit-1 is not configured yet.

dpkg: error processing package update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of update-manager:
 update-manager depends on policykit-1; however:
  Package policykit-1 is not configured yet.
 update-manager depends on update-notifier; however:
  Package update-notifier is not configured yet.

dpkg: error processing package update-manager (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depends on update-manager; however:
  Package update-manager is not configured yet.

dpkg: error processing package ubuntu-release-upgrader-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-session:
 ubuntu-session depends on unity-settings-daemon; however:
  Package unity-settings-daemon is not configured yet.
 ubuntu-session depends on gnome-session-bin (>= 3.9.90-0ubuntu12.1); however:
  Package gnome-session-bin is not configured yet.
 ubuntu-session depends on gnome-session-bin (<< 3.10); however:
  Package gnome-session-bin is not configured yet.

dpkg: error processing package ubuntu-session (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of usb-creator-common:
 usb-creator-common depends on udisks2; however:
  Package udisks2 is not configured yet.

dpkg: error processing package usb-creator-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of usb-creator-gtk:
 usb-creator-gtk depends on usb-creator-common (= 0.2.56.3ubuntu0.1); however:
  Package usb-creator-common is not configured yet.

dpkg: error processing package usb-creator-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: too many errors, stopping
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone please tell me how to solve this issue?
Many thanks.

Best,
Hazel

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu adduser Edit question
Assignee:
No assignee Edit question
Solved by:
Hazel
Solved:
2017-11-13
Last query:
2017-11-13
Last reply:
2017-11-13

What is the output of:

lsb_release -a; uname -a

Thanks

What is the output of:

lsb_release -a; uname -a

Thanks

Hazel (tkyun31) said : #3

Dear Andrew,

I think i solved the issue already. To solve this issue, I added Debian::AdduserCommon into perl5 folder.

Thank you for your response. Thank you so much.

Best,
Hazel