Acroread: font not found

Asked by Joe Areeda on 2011-04-28

I receive documents in pdf format that acroread will not display properly. If I get to add pictures I will.

First I get a dialog that says "Cannot find or create the font "Arial". Some characters may not display or print correctly" an understatement because if I click OK all characters display as big dots (maybe bullets). Xpdf opens and displays the file just fine. pdffonts shows:
name type emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
Arial TrueType no no no 13 0
Arial,Bold TrueType no no no 19 0

So is there a way to A) get an arial font for acroread or B) map Arial to an existing font.

I know the creator of the document can embed the font if they have the appropriate software but they are a commercial company reporting oil analysis results on a sample from my airplane by email and the likely response is we only support Windows and maybe Macs. It's also nice to keep the emails small.

Thanks,
Joe

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu acroread Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-29
Last reply:
2011-04-29
Joe Areeda (areeda) said : #1

Doesn't seem like I can attach images so here are some links:

The error dialog: http://www.areeda.com/ubuntu/acroreadBug-errorDialog.png

What the document looks like in acroread: http://www.areeda.com/ubuntu/acroreadBug-doesLookLike.png

What the document looks like in Xpdf: http://www.areeda.com/ubuntu/acroreadBug-shouldLookLike.png

I'm running Maveric 10.10 (Linux jsa 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux).

I'll try in on Natty and see if it's any different.

Thanks,
Joe

Hi Joe,

Can you link one of the PDFs in question?

Joe Areeda (areeda) said : #3

Brian,

The actual documents in question have information I'd rather not post but I will see if I can create something with Acrobat Pro to demonstrate the problem.

If I understand it correctly I just need to use a MS specific font and not embed it in the document.

Joe

Joe Areeda (areeda) said : #4

Well it's not that easy.
I have created a document that produces the same pdffonts output but displays fine.

I'll talk to my partners in the airplane and see if they have any objections to posting our oil analysis results. It's not a real big deal.

Joe

John Shortland (jshortland) said : #5

Have you tried installing the Acroread Fonts package? You may need to add the Medibuntu Repo to access the package, I'm not sure.

If you try this in the terminal it should install the package:

sudo apt-get install acroread-fonts

Joe Areeda (areeda) said : #6

Looks like I do need the medibuntu repository. More invasive than I can handle before I leave for the day.

I will try it tonight.

Thanks for the help John! Even though we haven't solved it yet, I appreciate options and an investigative path.

Joe

John Shortland (jshortland) said : #7

No Problem Joe, let us know how you got on...

Can you help with this problem?

Provide an answer of your own, or ask Joe Areeda for more information if necessary.

To post a message you must log in.