[SOLVED] apt-get acpid post-installation error (1) and /proc/acpi/event

Asked by Ricardo Arrue on 2009-07-17

When i was trying to install something i got the error:

* Starting ACPI services... acpid: can't open /proc/acpi/event: No such file or directory
invoke-rc.d: initscript acpid, action "start" failed.
dpkg: error processing acpid (--configure):
 subprocess post-installation script returned error exit status 1

then, since the acpid script was the reason to nothing could be installed, i did:

cd /etc/init.d/
mv acpid acpid_orig
touch acpid
dpkg --force-all --configure -a
mv acpid_orig acpid

and finally apt doesn't give me more errors.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpid Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2009-07-19
Last query:
2009-07-19
Last reply:
2009-07-18
Best Tom (tom6) said : #1

Hi
Is this still a problem or were you helping by saying how you fixed this problem? If this is fixed it might help to mark this question as solved using one of the buttons and then it will be added to the "Solved Answers Database"

Good luck and regards from
Tom :)

Ricardo Arrue (rarruec) said : #2

Thanks Tom, that solved my question.

Ricardo Arrue (rarruec) said : #3

Actually I'm helping by saying how I fixed the problem.
That's exactly what I wanted, an answer so I could click in "that solved my problem". Thanks!

Tom (tom6) said : #4

Brilliant, nicely done :)))
Thanks and regards from
Tom :)

Tom (tom6) said : #5

There's usually a button under the comments/message box rather than giving me credit. Thanks tho, i'm sure people will work it out from that :)

OMG! I spent 5 days looking for this! Thank you so much! You are my hero!