Ubuntu 9.10 Monitor sleeps even when power options are set to never sleep

Asked by Nick N on 2009-12-21

I installed 9.10 on a Dell Vostro 320. The screen saver is disabled and I set the power option to never put the computer or monitor to sleep. Sometimes it works fine, but the monitor goes to sleep one and a while even though I have it set to never sleep. From what I've read it seems to be a problem with gnome, but no one seems to have a good solution other then uninstall gnome and using something else, which I don't want to do.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2009-12-22
Last query:
2009-12-22
Last reply:
2009-12-22
Sam_ (and-sam) said : #1

> monitor goes to sleep one and a while

Every 10 minutes or so?
System preferences -> screensaver
is really disabled
and theme is not 'empty screen'?

#1
try it with disabling 'start screensaver' in:
system preferences -> startup applications

reboot and wait if it occurs again.

#2
check (all) settings of gnome-power-manager via gconf-editor
http://library.gnome.org/users/gconf-editor/2.22/getting-started.html.en
path:
/apps/gnome-power-manager
for example the option:
backlight

#3
(if nothing helps you might need to create a xorg.conf, because Karmic doesn't have one anymore)
Why:
Xserver has independent energy saving functions, aside from how the desktop config is.
It can happen it overlays screensaver or energy saving settings.
First we need the output of:
xset -q

https://help.ubuntu.com/community/UsingTheTerminal

Second diagnose of Xorg.0.log:
grep EE /var/log/Xorg.0.log
grep WW /var/log/Xorg.0.log
grep DPMS /var/log/Xorg.0.log

http://en.wikipedia.org/wiki/VESA_Display_Power_Management_Signaling

How to disable Hibernated and suspend

I know A and B and C and D methods

========================================================
The "A" and "D" method will disable the system wide Suspend Hibernate for all the users

A) - Open a terminal from Applications → Accessories → Terminal and type:

sudo gedit /etc/default/acpi-support

give your user password when requested, you don't see nothing when you type it, then press enter.

Look for and change the rows as below:
Alternatively, they could be simply commented out with a pound sign (#)

ACPI_SLEEP=false

ACPI_HIBERNATE=false

Reboot, these should completely disable hibernation and suspend.

========================================================
The "B" and "C" method will disable Suspend Hibernate only for current logged user

B) - Open the System → Preferences → Power management and play with settings (but sometimes don't works)

C) To disable Suspend and Hibernate for a user account, not system wide.

Open a terminal from Applications → Accessories → Terminal and type:

gconf-editor

Navigate to: apps → gnome power manager → general and remove the ticks at: can_hibernate and can_suspend

Note: this is a user preference: repeat this in each user account.

Hope this helps

D ) Changing the /etc/gdm file

gdm.conf (this is system default and should not be edited - but some values can be copied and altered)
gdm.conf-custom (this is where I made the changes - it will not be overwritten by the system)

sudo cp /etc/gdm/gdm.conf /etc/gdm/gdm.conf-custom

On the

[daemon] section added/modified
SystemCommandsInMenu=HALT;REBOOT;CUSTOM_CMD
(copied this from the gdm.conf but removed HIBERNATE and SUSPEND

This would prevent accidentally hibernating the system

Hth

Nick N (nolannp) said : #3

Thanks marcobra (Marco Braida), that solved my question.

Nick N (nolannp) said : #4

Thank you guys for responding to my problem! I used Marcobra's suggestion of the "A and D Method" because it most directly accomplished what I wanted. I don't think this is necessarily the best answer for people who want the computer to sleep on a timer, but since I'm using this for digital signage and never want the computer to sleep it's the perfect solution.

SOLUTION
"A) - Open a terminal from Applications → Accessories → Terminal and type:

sudo gedit /etc/default/acpi-support

give your user password when requested, you don't see nothing when you type it, then press enter.

Look for and change the rows as below:
Alternatively, they could be simply commented out with a pound sign (#)

ACPI_SLEEP=false

ACPI_HIBERNATE=false

Reboot, these should completely disable hibernation and suspend."

I think the power options in gnome need to seriously be looked at, many forums I've read in the past few day point to issues with sleep mode and power management in general.