My Ubuntu certified laptop won't wake up from suspend

Asked by Roy S on 2012-11-11

My Ubuntu certified laptop (Asus Eee 1001PXD) won't wake up from suspend. I get a black screen with a marker in the top left. If I press the power button for aprox 4 seconds I get my desktop backround image. But there is no window for me to log in, so the only option I have is to make a hard reboot. This happens every time I go to suspend.

I run 12.04 LTS, and have the original hardware except:
- Corsair SSD Force Series F120, 120GB
- Corsair DDR3 SO-DIMM 1066MHz 2GB

Question information

English Edit question
Ubuntu acpi Edit question
No assignee Edit question
Solved by:
Roy S
Last query:
Last reply:

What is the output of:

free -m


                    total used free shared buffers cached
Mem: 2003 808 1195 0 39 487
-/+ buffers/cache: 282 1721
Swap: 2039 0 2039

You have enough swap for the RAM. Are there any bugs reported?

Looks like I've found a workaround (something that's quite usual with laptops and Ubuntu suspend). If I press enter after I lift up the lid, and Immediately wiggle the mouse around as soon as the marker appears, it seems to work. Most of the time that is.