Ventilator allways on high speed.

Asked by Rob Frerejean on 2012-11-05

Ventilator is running on high speed all the time. It never idle´s. How can I fix this? In Windows it was no problem. It did only run when hot.

Ubuntu 12.04 on HP Laptop G72.

How to fix this

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Rob Frerejean
Solved:
2012-11-09
Last query:
2012-11-09
Last reply:
2012-11-06

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Rob Frerejean (hffrerejean) said : #2

Here the output:

rob@rob-HP-G72-Notebook-PC:~$ sudo lshw -C display; lsb_release -a; uname -a
[sudo] password for rob:
  *-display
       description: VGA compatible controller
       product: Manhattan [Mobility Radeon HD 5430 Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:44 memory:c0000000-cfffffff memory:d4000000-d401ffff ioport:4000(size=256) memory:d4040000-d405ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux rob-HP-G72-Notebook-PC 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

N1ck 7h0m4d4k15 (nicktux) said : #3

Hi ,

open a terminal and try these commands

~$ sudo -i
~$ echo low > /sys/class/drm/card0/device/power_profile
~$ exit

wait 5-10 secs and see if temperature is down and ventilator slower.

If above works , you have to make it permanent with other commands. Above commands works only for one session.

Thanks

or in a single command:

echo low | sudo tee /sys/class/drm/card0/device/power_profile > /dev/null

Much easier

If it works, we can add it to your startup

Rob Frerejean (hffrerejean) said : #6

It´s still running fast. Air comming out is hot. I even changed the option in BIOS. Fan always on yes/no. Both options don´t work in my bennefit. Even updated the BIOS.

And that without any CPU drain. Just started Linux.

Rob Frerejean (hffrerejean) said : #7

Are there any other options witch I can try?

Rob Frerejean (hffrerejean) said : #8

I'll install Windows.