Lenovo T60 (1951-FEG) Key does not work sound (VolumeUp, VolumeDown, Mute)

Asked by TAG on 2012-10-25

Lenovo T60 (1951-FEG)
Ubuntu 12.10 (kernel 3.5.0-17)
Key does not work sound (VolumeUp, VolumeDown, Mute)
Sound itself works with applets grokost changing.
But the standard function keys do not work.
Tried to remap the keys, do not respond to pressing.
Hrabochie keys, tried on WinXP and Win7.

Thank you.

Question information

English Edit question
Ubuntu acpi Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

try to use the acpi_osi= parameter to the grub menu . How ?

Open the terminal (CTRL+ALT+T) and copy-paste this command

~$ gksudo gedit /etc/default/grub

search and find the line


and change it to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

save the document and then run in terminal this command

~$ sudo update-grub

Reboot and see if Fn keys work.

IF NOT , then give here the results of this command

~$ cat /etc/default/grub


TAG (p-shvedoff) said : #2

Thanks for the reply, but unfortunately did not help.
All functions Fn worked before.
But the volume keys in a separate block of keys.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Fabio M. Panico (fbugnon) said : #3

I also had this same problem: volume/mute keys of the T60 wouldn't work on Ubuntu 12.10. Or actually the did, but I had no visual return.

Anyhow, the solution I found in the UbuntuForums (for Oneiric Oncilot 11.10, but....) worked fine for me:

1. Open the file with a text-editor such as gedit:
sudo gedit /etc/rc.local

2. Add this line before "exit 0":
cp /sys/devices/platform/thinkpad_acpi/hotkey_all_mask /sys/devices/platform/thinkpad_acpi/hotkey_mask

3. Save & close.

Reboot and you're good.

Source: http://ubuntuforums.org/showthread.php?t=1858508

TAG (p-shvedoff) said : #4

Thank you very much.
Your recommendation has solved the problem.