Cannot shut down from Ubuntu

Asked by Kevin Cuthbertson on 2012-10-10

How do I shut the computer down from Ubuntu. It just goes to purple sreen when asked to shut down.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-18
Last reply:
2012-10-19

This question was reopened

Have you tried:

sudo shutdown -h now

Do not know what that is, or what I would do with that? What is sudo shutdown -h now. I am not a geek.

Its a terminal command, copy the command and press CTRL+ALT+T, paste the command there and hit ENTER. Type your password and hit ENTER.

You don't have to be a geek to do that, bit of typing and copy and pasting of text.....not hard

When I did as asked, it did the same procedure as before. It went to purple screen and nothing can be done from there. I have to do a forced shut down from there.

Does the system have a make and model?

Dell laptop. Don't know the model.

Studio 156G

Anybody?

I don't know how this happened, but a dos screen appeared, I had to force a shut down, and when I rebooted, It seems to shutdown properly now. Did you actionparsnip (andrew-woodhead666) send the dos fix or what? Like I stated earlier I am not a geek by any way shape or form, but I am appreciative!

Too good to be true. After working correctly twice, It is back too same old stuff. This time I did not shut down before I had been doing things with different sites. The times that it did work correctly I didnot open any sites. Is this something on my end?

Andrew is there anything else you can do to correct this issue?

N1ck 7h0m4d4k15 (nicktux) said : #12

On 10/12/2012 04:46 PM, Kevin Cuthbertson wrote:
> Question #210847 on firefox in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/firefox/+question/210847
>
> Kevin Cuthbertson posted a new comment:
> Andrew is there anything else you can do to correct this issue?
>

Hi ,

this problem is probably (but not for sure) caused by the graphics
card's driver. We will see.

Open a terminal (Ctrl+Alt+t) and give the results of these 2 commands

1) lscpi -nnk | grep -iA2 vga

2) sudo lshw -C display

Thanks

I try to use Ctrl-C but it does not copy. Is it a different command in Ubuntu?

If I am typeing it correctly, both are command not found

kevin@ubuntu:~$ sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 18
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:44 memory:f0000000-f03fffff memory:d0000000-dfffffff ioport:1800(size=8)

kevin@ubuntu:~$ lscpi -nnk | grep -iA2 vga
No command 'lscpi' found, did you mean:
 Command 'lscpu' from package 'util-linux' (main)
 Command 'lscp' from package 'nilfs-tools' (universe)
 Command 'lspci' from package 'pciutils' (main)
lscpi: command not found
kevin@ubuntu:~$

Hello?

N1ck 7h0m4d4k15 (nicktux) said : #18

Its OK , I get the info I wanted.

No it is not the driver. Intel and i915 are OK. The problems with shutdown usually appeared with Nvidia or/and Ati.

So the problem here is that hangs ..

Try this command and tell me if it hangs

sudo poweroff -f

Thanks

sudo poweroff -f and the machine shut down immediatly upon entering password. As though it didn't even shut the program running.

N1ck 7h0m4d4k15 (nicktux) said : #20

On 10/12/2012 09:36 PM, Kevin Cuthbertson wrote:
> Question #210847 on firefox in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/firefox/+question/210847
>
> Kevin Cuthbertson posted a new comment:
> sudo poweroff -f and the machine shut down immediatly upon entering
> password. As though it didn't even shut the program running.
>

You know what is the problem here ? That Linux do not store anywhere
any logs for the shutdown. If hanged in startup then we could see the
logs (inside /var/log/) and understand where it hangs.

When you shutdown normally , can you press the [Esc] or [Pause/Brake]
button and see where it hangs ?

Yes the command I gave you with the -f (force) parameter do this.
Shutdown immediately without save anything. Is not good to use it all
the time.. but we understood that is not your system or graphics or
motherboard..

I think now maybe a program hang the shutdown process.

Close all the programs .. eg : Firefox , Libreoffice...etc before you
shutdown normally. Maybe some of these programs hangs during shutdown .

Thanks

When you shutdown normally , can you press the [Esc] or [Pause/Brake]
button and see where it hangs ? NO It closes to the point of the Ubuntu page and hangs. The only recourse I have is a forced shutdown and that is not healthy for the machine.

Close all the programs .. eg : Firefox , Libreoffice...etc before you
shutdown normally. Maybe some of these programs hangs during shutdown . I have had sucess a couple of times = log out, and then shut down, but not always.

Are you thinking that it is a program causing the hang?

I am closing/logging off and then shuting down,again.

Did the same process. Hangs at the Ubuntu screen. Although the little buttons under the Ubuntu logo keep blinking, not like a typical hang. When this screen appears the only optioon is forced shutdown. But like I stated before, the log out, then shutdown sequence has worked a couple times sporadically. Really irritating.

N1ck 7h0m4d4k15 (nicktux) said : #23

On 10/13/2012 12:11 AM, Kevin Cuthbertson wrote:
> Question #210847 on firefox in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/firefox/+question/210847
>
> Kevin Cuthbertson posted a new comment:
> Did the same process. Hangs at the Ubuntu screen. Although the little
> buttons under the Ubuntu logo keep blinking, not like a typical hang.
> When this screen appears the only optioon is forced shutdown. But like I
> stated before, the log out, then shutdown sequence has worked a couple
> times sporadically. Really irritating.
>

Do you have the libreoffice-firefox plugin ?

If yes , then try

  sudo apt-get purge mozilla-libreoffice

Thanks

Do you have the libreoffice-firefox plugin ? How would I find it, if I have it?

N1ck 7h0m4d4k15 (nicktux) said : #25

On 10/13/2012 04:26 PM, Kevin Cuthbertson wrote:
> Question #210847 on firefox in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/firefox/+question/210847
>
> Status: Answered => Open
>
> Kevin Cuthbertson is still having a problem:
> Do you have the libreoffice-firefox plugin ? How would I find it,
> if I have it?
>
Run the command I gave you.

kevin@ubuntu:~$ sudo apt-get purge mozilla-libreoffice
[sudo] password for kevin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mozilla-libreoffice is not installed, so not removed
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
kevin@ubuntu:~$ ^C

kevin@ubuntu:~$ sudo apt-get purge mozilla-libreoffice
[sudo] password for kevin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mozilla-libreoffice is not installed, so not removed
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
kevin@ubuntu:~$ ^C

Can you give instructions as to how? where? Does it remove just what is needed to remove, or do I have to detail what is to be removed. And Also where do I go to get this?

N1ck 7h0m4d4k15 (nicktux) said : #29

The package I told you is not installed , so forget about it.

We don't know yet , what causes this problem.

Run this command so uneeded packages will be removed

sudo apt-get --purge autoremove

Provide some info for you BIOS.. maybe is a BIOS problem.. I mean if you disable some function maybe the problem solved.

sudo dmidecode -t 0,1,2

Thanks

kevin@ubuntu:~$ sudo apt-get --purge autoremove
[sudo] password for kevin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-3.2.0-29* linux-headers-3.2.0-29-generic*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 67.5 MB disk space will be freed.
Do you want to continue [Y/n]? yes
(Reading database ... 190161 files and directories currently installed.)
Removing linux-headers-3.2.0-29-generic ...
Removing linux-headers-3.2.0-29 ...
kevin@ubuntu:~$

Soooooo there is no fix?

N1ck 7h0m4d4k15 (nicktux) said : #32

If there is no fix , and the problem insists and you are sure that the problem affects only Ubuntu (and not other O.S.)

You can close (solve) this question and report a bug.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Kevin Cuthbertson for more information if necessary.

To post a message you must log in.