Battery Doesn't Charge (12.04 LTS)

Asked by Adam Zagoria-Moffet on 2012-10-01

Starting today, Ubuntu is not recognizing that the battery needs to be charged when the AC adapter is plugged in. When unplugged cat /proc/acpi/battery/BAT0/state registers that battery is 'discharging' and when its plugged in it skips right to 'charged.'

Meanwhile its been stuck at 29%. :(

I ducked into Windows 7 to see what's up and there's no trouble over there, so the hardware must be working fine. How do I get it to start charging my battery again?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Warren Hill
Solved:
2012-10-01
Last query:
2012-10-01
Last reply:
2012-10-01
Warren Hill (warren-hill) said : #1

What's the make and model of your PC?

Can you open a terminal and give us the output of

lsb_release -a; uname -a;

Hi Warren,

Thanks for your help! It's a Lenovo Thinkpad Edge E430. Here's that output:

Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux ubuntu 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Warren Hill (warren-hill) said : #3

Just had a quick search. Couldn't find any specific problems with Lenovo batteries on Ubuntu.

1. Are you sure the battery isn't charging? Or could it just be the charge level indication that's wrong?

You can test this by running in windows until its fully charged then flicking over to Ubuntu to check the level or by running in Ubuntu for a while then checking charge level in windows.

It definitely isn't charging. If I pop over to Windows it will register the same % and then start charging. I can always just work-around it then by charging while suspended in Windows and then popping back to Ubuntu.

I tried a trick I found online of booting with AC adapter only, and then inserting battery, without suspending, and it will pick up charging again. Once its disconnected and runs down the battery I have to do it again, but I don't mind a whole bunch, as this just seems to be a bug - and not one with a solid fix at the moment.

Best Warren Hill (warren-hill) said : #5

I suggest you file a bug if its definitely OK under windows I don't see how it can be hardware.

Sorry I can't help more

No problem! Thanks for all your help. For the moment, I'm okay taking it in and out to charge it each time, and I'll submit a bug report with the hope that it might be remedied in 12.10.

Thanks again!

Thanks Warren Hill, that solved my question.