Intermediate levels of brightness

Asked by Pedro Izecksohn on 2012-08-31

After the last upgrade, I'm unable to set an intermediate level of brightness: the level of brightness is being pushed to its maximum or to its minimum. It happens when I press Fn+Up or Fn+Down and it also happens inside the Brightness and Lock window: The level indicator passes through all the levels, changing the brightness at every step, but it does not stop at each level of brightness. I used to use an intermediate level of brightness until some hours ago on this same installation.

I use Ubuntu version 12.04.1 LTS on a Intel(R) Core(TM) i5-2410M CPU with a VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) and a 3D controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1).

What should I do to fix this?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-31
Last reply:
2012-08-31
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,
as you correct , mention the affected package (acpi) maybe is a good idea to try a workaround for this problem.

I will tell you one.

Open a terminal (ctrl+alt+t) and apply this command
+++++++++++++++++++++++++++++
gksudo gedit /etc/default/grub
+++++++++++++++++++++++++++++

at the opened window , find the line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it. Make it like this :GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
save the document and then in terminal run
+++++++++++++++++++++
sudo update-grub
+++++++++++++++++++++

reboot your PC .

Thanks.

N1ck 7h0m4d4k15 (nicktux) said : #2

Because the line braked i will give you again the line as should be after the change.
You must change the line to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Thanks

What is the make and model of the system?

Dual GPU systems are a massive headache in Linux. I expect you will have a tonne of issues with this outside of Windows.

Pedro Izecksohn (izecksohn) said : #4

The solution
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
fixed the Brightness and Lock window scrollbar, but it did not fix the Fn+Up or Fn+Down problem, only changed it: Now the level indicator may be set only to the maximum brightness or to one step below it.

Pedro Izecksohn (izecksohn) said : #5

The Brightness and Lock window scrollbar is working fine.
The Fn+Up or Fn+Down brightness indicator is not working properly.

What is the make and model of the system?

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #7

You can remove the parameter "acpI_backlight=vendor" the same way we added . Do not forget , at the end to run
+++++++++++++++++++++
sudo update-grub
+++++++++++++++++++++
for the changes to take effect.

Another good parameter , as we did above , might be acpi_osi=
line should be: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Because you have 2 GPUs , do you use the bumblebee project or you have been disabled the integrated Intel GPU ?

Bumblebee project is here , take a look : http://bumblebee-project.org/

If this is an ACPI problem then you can test it with the latest Kernel . Latest kernel included in Ubuntu 12.10 (Unstable) .
You can download ubuntu 12.10 Daily-Build from here : http://cdimage.ubuntu.com/daily-live/current/
Do not install 12.10 , just run it as a live Usb / CD and test if keys work there.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Pedro Izecksohn for more information if necessary.

To post a message you must log in.