HP Pavilion dv6 6153CL overheating

Asked by Rebecca Kliever on 2012-08-26

psensor says my laptop is running around 65C and my battery life is very short! I am very new at this and do not know where to start or how to correct, any help would be appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Rebecca Kliever
Solved:
2012-08-26
Last query:
2012-08-26
Last reply:
2012-08-26

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep -i acpi

Thanks

hempster@hempster-HP-Pavilion-dv6-Notebook-PC:~$ sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep -i acpi
  *-display
       description: VGA compatible controller
       product: Whistler XT [AMD Radeon HD 6700M Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:52 memory:a0000000-afffffff memory:c6500000-c651ffff ioport:5000(size=256) memory:c6520000-c653ffff
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:51 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:6000(size=64)
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux hempster-HP-Pavilion-dv6-Notebook-PC 3.5.0-10-generic #10-Ubuntu SMP Mon Aug 13 16:23:53 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii acpi 1.6-1 displays information on ACPI devices
ii acpi-support 0.140 scripts for handling many ACPI events
ii acpid 1:2.0.10-1ubuntu3 Advanced Configuration and Power Interface event daemon
ii kacpimon 1:2.0.10-1ubuntu3 Kernel ACPI Event Monitor
ii libfwtsacpica1 0.24.21 FirmWare Test Suite ACPICA core built for acpiexec functionality
ii libfwtsiasl1 0.24.21 FirmWare Test Suite ACPICA core built for iasl functionality

Yep, you have hybrid graphics which is all kinds of headache in Linux. It is best avoided. This may help:
https://help.ubuntu.com/community/HybridGraphics

but I have never seen a success with this technology.

I would prefer not to use "hybrid graphics"! How can I change this so I am
not overheating?

On Sun, Aug 26, 2012 at 7:45 AM, actionparsnip <
<email address hidden>> wrote:

> Your question #206845 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/206845
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Yep, you have hybrid graphics which is all kinds of headache in Linux. It
> is best avoided. This may help:
> https://help.ubuntu.com/community/HybridGraphics
>
> but I have never seen a success with this technology.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/206845/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/206845
>
> You received this question notification because you asked the question.
>

It's what is in your system. You got it when you bought it. If you can disable one of the GPUs in BIOS then do so. I suggest you try:

echo "OFF" | sudo tee /sys/kernel/debug/vgaswitcheroo/switch

It may help

How can I change this? I would prefer not to use hybrid graphics!

I tried it and thank you - Temperature dropped down to 48C. Usually it's
running around 55C - 60C within minutes of turning it on.

Is there another distribution other than Ubuntu that I should be using or
is there anything else I can do to lower the temperature?

If no - thank you for all the help!

Rebecca

On Sun, Aug 26, 2012 at 7:56 AM, actionparsnip <
<email address hidden>> wrote:

> Your question #206845 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/206845
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> It's what is in your system. You got it when you bought it. If you can
> disable one of the GPUs in BIOS then do so. I suggest you try:
>
> echo "OFF" | sudo tee /sys/kernel/debug/vgaswitcheroo/switch
>
> It may help
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/206845/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/206845
>
> You received this question notification because you asked the question.
>

Thanks for your help

Hybrid GPUs currently do not work well in Linux. You will need to run:

gksudo gedit /etc/rc.local

and add the command above the exit 0 line, to make it run at boot. A little research before you buy will let you know what works and doesn't work.