Dell vostro fan/cooler not stop

Asked by Marcondes Maçaneiro on 2012-07-25


I bought a Dell vostro 3560
3rd generation Core i7
ADM Radeon Video Card 1 GB
HD Hybrid

Well the problem is the fan or cooler.
It does not diminish the rotation, is always high.

Already formatted with windows and everything works just fine.

Can you help?

Question information

You have a switchable video chip. It causes issues in Linux.

you are sure, that too for ubuntu 4.12?
What is it installed?

the first line is excuta.

grep-i switcheroo / boot/config-2.6. *

only so

grep-i switcheroo / * boot/config-

and the return was.

/ boot/config-3.2.0-23-generic-pae: y = CONFIG_VGA_SWITCHEROO
/ boot/config-3.2.0-27-generic-pae: y = CONFIG_VGA_SWITCHEROO

I continue anyway?

you are sure, that too for ubuntu 4.12?
What is it installed?

the first line does not run.

grep-i switcheroo / boot/config-2.6. *

only so

grep-i switcheroo /boot/config-*

and the return was.


I follow anyway?

this is my "lspci"!

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
08:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

Friends help me, please!

I do not want to use windows.


tomml (ts-schauer) said : #6

I do have the same problem with my dell vostro 3560 running ubuntu 12.04
fan is always on high speed!

Amarokk (guillaume-fenollar) said : #7

May I add that on battery, the fan behavior is normal? I mean, am I alone?
Then if I plug AC, the fan starts spining at max speed, everytime again. I installed laptop-mode but don't find any difference between my battery mode and AC mode.
I have a Vostro 3560. Needless to say that even if the fan speed goes to a lower speed on battery mode, the battery life is still ~2h20 without any application running. So that's not a solution to run Ubuntu on battery mode only.
Moreover, I tried installing 3.5 kernel, and after that upgrading to 12.10 ubuntu alpha version. Both don't help.
I'm forced to work on Windows because it's impossible with Ubuntu..please help :-(

Amarokk (guillaume-fenollar) said : #8

Hello dudes,
I'm very pleased to announce that I found a workaround. Surely some of you found the same way but nobody talked about that.
I tried using i8k, which is a util to control cpu temp and fan speed of Dell Inspiron and Latitude laptop. Fortunately, it works for Vostro too.
So install i8kutils package.

# apt-get install i8kutils

You can try to run "i8kfan", which would reply something like "-1 3". 3 is the highest level of fan speed. 0 means lowest.
Then, add the module to the according file:

# echo "i8k" >> /etc/modules

Now, modify the i8k daemon file

# vim /etc/init.d/i8kmon

Change the line I8KMON_ARGS, because with default parameter, the "noauto" disallow the daemon to monitor fan's speed
it should look like this now:
I8KMON_ARGS="--auto --daemon"

You can now enable the i8k daemon at boot. a simple command like that should be sufficient:
# update-rc.d i8kmon enable

Then, modify /etc/default/i8kmon to put ENABLED=1

Finally, you can use a configuration to automate the fan control, according to the temperature. Insert this into /etc/i8kmon and restart to see the changes. WARNING! Please check from time to time the CPU temp to be sure it's working. Any time, you can run "i8kmon" panel to check the cpu temperature and the fan's levels (to change the fan's speed manually). If you have any improvement to this method, please post a comment, I just found this workaround but I'm sure there is a smoother method. Thank you.

/etc/i8kmon file:

# Run as daemon, override with --daemon option
set config(daemon) 1

# Automatic fan control, override with --auto option
set config(auto) 1

# Status check timeout (seconds), override with --timeout option
set config(timeout) 2

# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
set config(0) {{- 0} -1 55 -1 55}
set config(1) {{- 1} 50 60 50 60}
set config(2) {{- 2} 55 125 55 125}
set config(3) {{- 2} 70 128 10 128}

# end of file

tomml (ts-schauer) said : #9

hi amarokk,

i just followed your instructions and now running my ubuntu 12.04 on normal fan speed noise level!! :)
so far so good, but i feel on my hands when touching the laptop that its getting quiet warm and fan does not mean to get faster. maybe we should try to refine the configurations.


Amarokk (guillaume-fenollar) said : #10

Hi tom,

I found out that there is some possibilities, depending on the fact that your /etc/i8kmon is taken into account or not.
On my side, I renamed /etc/i8kmon to /etc/i8kmon.conf, and I also reverted the changes of /etc/init.d/i8kmon script
from "I8KMON_ARGS="--auto --daemon""
to "I8KMON_ARGS="--nouserconfig --daemon""

and restart i8kmon daemon. After that, everything works fine, the fan speed follows the cpu temp.

It seems that the --auto option does not take your i8kmon file into account. Moreover, it seems that this file is not taken into account until you rename it /etc/i8kmon.conf. I saw this "bug" there :

After that, I restarted and everything seems to work fine. I mean, I'm running a lot of application to make the cpu work, monitoring the temp in the meantime, and when my CPU reaches the temperature settings I put into /etc/i8kmon.conf file, the fan speed increases well as I configured it.

Sorry that I didn't completely test it before writing my answer but I was very happy to let you know about that ;-)
I saw in the past that some people had problems about i8k and freeze. I have no freeze on my side.

Rodrigo Primo (rodrigosprimo) said : #11


I have the same issue with my Vostro 3560. I will try the workaround proposed here and I will let you know if it fixes the problem.

I'm wondering if we should open a bug report about this. I'm asking here first but I'm not sure which part of Ubuntu is related with this problem.

Amarokk (guillaume-fenollar) said : #12

Hi Rodrigo,

You can find a post about it in dell forums :

But I don't think there is anything interesting in it. I don't even know if it's fully ubuntu related or not. I tried install a fedora, it was the same problem.

PS: for French speakers, I made this page, shortened.

Rodrigo Primo (rodrigosprimo) said : #13

I have created a bug report for this issue:

MIchal ThomaT (michal-thoma) said : #14

I have Dell Vostro 3360 with Ubnut Precise 12.04 and I also experience problems with fan. It's not noisy all the time though definitely strange behaved (noisy for long time, getting faster and slower etc.) This is with newest A04 BIOS.

I tried to use i8kmon though unfortunately accessing /proc/i8k and runing i8kfan or i8kctl causes computer microfreezes - for quarter of second, mouse, music, everything stops. So this makes i8k utils no help.

vitorafsr (vitorafsr) said : #15

The microfreezes problem is being treated in the link below.

Can you help with this problem?

Provide an answer of your own, or ask Marcondes Maçaneiro for more information if necessary.

To post a message you must log in.