Can't Change Screen Brightness 12.04 Linux

Asked by Kevin N on 2012-05-21

I recently Installed 12.04 Linux on my MacBook Pro (Mac OS X, Core 2 Duo). However, I can't change the brightness of the screen with my F1 or F2 keys (an icon comes up on the screen showing the screen is being reduced, but it doesnt actually change the brightness). If i go into setting and to brightness I can adjust the bar for brightness in there as well but it doesnt change the brightness either. I have tried going online and looking it up but most of the articles I found were for older versions and since this is my first time with linux i didnt want to enter any commands into terminal without making sure it wouldnt mess up my computer. Everything works fine but that.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-22
Last reply:
2013-03-31

Can you give the output of:

sudo dmidecode -t 1; lsb_release -a

Thanks

Kevin N (kevin-n-2008) said : #2

# dmidecode 2.11
SMBIOS 2.4 present.

Handle 0x000F, DMI type 1, 27 bytes
System Information
 Manufacturer: Apple Inc.
 Product Name: MacBookPro5,5
 Version: 1.0
 Serial Number: W8934VR766E
 UUID: 2C7A2E5D-968A-C64D-A1E4-92CD72BB3256
 Wake-up Type: Power Switch
 SKU Number: System SKU#
 Family: MacBook

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

https://help.ubuntu.com/community/MacBookPro5-5/Precise

Keep trying that til the page loads. The servers are having issues right now

Kevin N (kevin-n-2008) said : #4

I followed the website and saw that i have to download nvidia-bl-dkms to solve this issue. However, i am having a hard time downloading this file. http://www.ubuntuupdates.org/ppa/mactel_support?dist=precise is the website i found but i cant seem to get it to work

Run:

sudo add-apt-repository ppa:mactel-support/ppa
sudo apt-get update
sudo apt-get install nvidia-bl-dkms

sergwy (sergwy) said : #6

Hi. nvidia-bl-dkms is not available for 12.04

pranava swaroop (dvpswaroop) said : #7

hi i did the same:
sudo dmidecode -t 1; lsb_release -a
# dmidecode 2.11
SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
 Manufacturer: Acer
 Product Name: AOD270
 Version: V1.06
 Serial Number: NUSGASI003219075DF7614
 UUID: 07E7291B-A915-D14B-94BB-047D7B98D871
 Wake-up Type: Power Switch
 SKU Number: Type1Sku0
 Family: Type1Family

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

I tired to download the nvida but got the same error.
please help

Pranava, please make a separate question. Thanks

Did you add the boot option:
acpi_backlight=vendor

Can you help with this problem?

Provide an answer of your own, or ask Kevin N for more information if necessary.

To post a message you must log in.