Can't disable laptop-mode in 12.04

Asked by Adam on 2012-05-01

laptop-mode is spinning my hard drive up and down too often. I've tried laptop-mode-tools to try and configure this but i couldnt get it to work. I am now trying to diable laptop-mode but it doesn't seem to be working.

I've set 'LAPTOP-MODE=false' in /etc/default/acpi-support

but when i do 'sudo cat /proc/sys/vm/laptop_mode' on battery it gives the value 5 which means it is enabled, and the hard drive continues to spin down.

(please note i'm quite new to linux :-s )

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2012-05-02
Last query:
2012-05-02
Last reply:
2012-05-01
Best Sam_ (and-sam) said : #2

> spinning my hard drive up and down too often

It's a known bug 952556 and in progress for precise.

In the meantime laptop-mode-tools must be turned off or removed.
Workarounds start from #20
e.g. in
/etc/hdparm.conf

add
apm_battery = 128

## it's the standard value for battery mode.

If laptop-mode-tools are installed hdparm configuration won't be responsible.
Hdparm doesn't control if laptop-mode really applies apm settings.

Try in /etc/default/acpi-support
ENABLE_LAPTOP_MODE=false

Sam_ (and-sam) said : #3

Forgot to mention acpi-support is actually deprecated.

Adam (atadws) said : #4

Thanks Sam_, that solved my question.

Adam (atadws) said : #5

Thanks Sam_

This solved my problem. After reading the bug report I set:

apm_battery=127

and

-S 24 for /dev/sda

Thanks