Stops at "ACPI: power button [PWRF]" when trying to run

Asked by no one 123 on 2011-10-22

Every time i got to eather "Run ubuntu from this USB" or "Install ubuntu on a hard disc" it starts for a few sec but then stops with this.

53)
4.966189] io scheduler noop registered
4.966278] io scheduler deadline registered
4.966408] io scheduler cfq registered (default)
4.966871] pci_hotplug: PCI Hot Plug PCI core version: 0.5
4.967026] pciehp: PCI Express Hzot Plug Controller Driver version 0.4
4.967478] input: Power button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/
input/input0
4.967596] ACPI: Power button [PWRB]
4.968945] input: power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/inp
ut1
4.969049] ACPI: Power Button [PWRF]

then it stops there. please help
(also i am trying to run ubuntu 11.10)
anything else you need to ask feel free to ask me.

Question information

Suman Guha (suman-iitk2003) said : #1

I have upgraded from ubuntu 11.04 to 11.10 and after upgrading I am facing the same problem while booting to 11.10 with the latest kernel 3.0.0.12. It stops at:

ACPI: Power Button [PWRF]

I have tried to boot with noapic/acpi=off/nolapic but I am facing the same problem. However, if I boot with the previous kernel then it is working.

Any help in this issue?

Farid Zarbaliyev (sehrbaz) said : #2

I have faced the same issue. Guys can you share your hardware info, maybe we face this problem due to same HW

Suman Guha (suman-iitk2003) said : #3

Here is my hardware info:

    description: Desktop Computer
    product: ()
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall64 vsyscall32
    configuration: boot=normal chassis=desktop uuid=954DAA8C-1E31-11DB-934C-0013D45A015A
  *-core
       description: Motherboard
       product: D102GGC2
       vendor: Intel Corporation
       physical id: 0
       version: AAD42789-203
       serial: BTGC6300095X
       slot: Base Board Chassis Location
     *-cpu
          description: CPU
          product: Intel(R) Pentium(R) D CPU 2.66GHz
          vendor: Intel Corp.
          physical id: 0
          bus info: cpu@0
          version: Intel(R) Pentium(R) D CPU 2.66GHz
          size: 2666MHz
          capacity: 4GHz
          width: 64 bits
          clock: 133MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc pebs bts nopl pni dtes64 monitor ds_cpl tm2 cid cx16 xtpr lahf_lm
        *-cache:0
             description: L1 cache
             physical id: 1
             slot: Unknown
             size: 16KiB
             capacity: 16KiB
             capabilities: asynchronous internal write-back data
        *-cache:1
             description: L2 cache
             physical id: 2
             slot: Unknown
             size: 1MiB
             capacity: 1MiB
             capabilities: asynchronous internal write-back unified
     *-firmware
          description: BIOS
          vendor: Intel Corp.
          physical id: 3
          version: GC11020M.86A.1065.2006.0502.1638
          date: 05/02/2006
          size: 64KiB
          capacity: 448KiB
          capabilities: pci upgrade shadowing cdboot bootselect edd int9keyboard int14serial int17printer int10video acpi usb zipboot biosbootspecification netboot
     *-memory
          description: System Memory
          physical id: 14
          slot: System board or motherboard
          size: 1536MiB
          capacity: 1536MiB
        *-bank:0
             description: DIMM DDR [empty]
             physical id: 0
             slot: DIMM0
        *-bank:1
             description: DIMM DDR [empty]
             physical id: 1
             slot: DIMM1
        *-bank:2
             description: DIMM DDR Synchronous 533 MHz (1.9 ns)
             product: 0x353132554D55525A54474243000000000000
             vendor: 0x0000000000000000
             physical id: 2
             serial: 0x54424A42
             slot: DIMM2
             size: 512MiB
             width: 64 bits
             clock: 533MHz (1.9ns)
        *-bank:3
             description: DIMM DDR Synchronous 533 MHz (1.9 ns)
             product: 0x000000000000000000000000000000000000
             vendor: 0x0000000000000000
             physical id: 3
             serial: 0x00000000
             slot: DIMM3
             size: 1GiB
             width: 64 bits
             clock: 533MHz (1.9ns)
     *-pci
          description: Host bridge
          product: Radeon Xpress 200 Host Bridge
          vendor: ATI Technologies Inc
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 01
          width: 32 bits
          clock: 66MHz
          configuration: latency=64
        *-pci:0
             description: PCI bridge
             product: RS480 PCI Bridge
             vendor: ATI Technologies Inc
             physical id: 1
             bus info: pci@0000:00:01.0
             version: 00
             width: 32 bits
             clock: 66MHz
             capabilities: pci normal_decode bus_master cap_list
             resources: ioport:2000(size=4096) memory:80100000-801fffff memory:60000000-7fffffff
           *-display
                description: VGA compatible controller
                product: RC410 [Radeon Xpress 200]
                vendor: ATI Technologies Inc
                physical id: 5
                bus info: pci@0000:01:05.0
                version: 00
                width: 32 bits
                clock: 66MHz
                capabilities: pm msi vga_controller bus_master cap_list rom
                configuration: driver=radeon latency=64 mingnt=8
                resources: irq:11 memory:60000000-6fffffff ioport:2000(size=256) memory:80100000-8010ffff memory:70000000-7001ffff
        *-ide:0
             description: IDE interface
             product: IXP SB400 Serial ATA Controller
             vendor: ATI Technologies Inc
             physical id: 11
             bus info: pci@0000:00:11.0
             logical name: scsi0
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: ide pm msi bus_master cap_list rom emulated
             configuration: driver=sata_sil latency=64
             resources: irq:10 ioport:3068(size=8) ioport:3084(size=4) ioport:3060(size=8) ioport:3080(size=4) ioport:3030(size=16) memory:80207600-802077ff memory:58000000-5807ffff
           *-disk
                description: ATA Disk
                product: ST380211AS
                vendor: Seagate
                physical id: 0.0.0
                bus info: scsi@0:0.0.0
                logical name: /dev/sda
                version: 3.AA
                serial: 5PS0VYAE
                size: 74GiB (80GB)
                capabilities: partitioned partitioned:dos
                configuration: ansiversion=5 signature=33be33bd
              *-volume:0
                   description: Windows NTFS volume
                   physical id: 1
                   bus info: scsi@0:0.0.0,1
                   logical name: /dev/sda1
                   logical name: /home/suman/win1
                   version: 3.1
                   serial: 0a2a179b-3a18-d64e-beaa-c9cf267879a0
                   size: 14GiB
                   capacity: 14GiB
                   capabilities: primary bootable ntfs initialized
                   configuration: clustersize=4096 created=2010-08-30 05:02:17 filesystem=ntfs mount.fstype=fuseblk mount.options=rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096 state=mounted
              *-volume:1
                   description: Extended partition
                   physical id: 3
                   bus info: scsi@0:0.0.0,3
                   logical name: /dev/sda3
                   size: 37GiB
                   capacity: 37GiB
                   capabilities: primary extended partitioned partitioned:extended
                 *-logicalvolume:0
                      description: Linux swap / Solaris partition
                      physical id: 5
                      logical name: /dev/sda5
                      capacity: 2860MiB
                      capabilities: nofs
                 *-logicalvolume:1
                      description: Linux filesystem partition
                      physical id: 6
                      logical name: /dev/sda6
                      logical name: /
                      capacity: 13GiB
                      configuration: mount.fstype=ext4 mount.options=rw,relatime,errors=remount-ro,barrier=1,data=ordered state=mounted
                 *-logicalvolume:2
                      description: Linux filesystem partition
                      physical id: 7
                      logical name: /dev/sda7
                      logical name: /home
                      capacity: 20GiB
                      configuration: mount.fstype=ext4 mount.options=rw,relatime,barrier=1,data=ordered state=mounted
              *-volume:2
                   description: Windows NTFS volume
                   physical id: 4
                   bus info: scsi@0:0.0.0,4
                   logical name: /dev/sda4
                   logical name: /home/suman/win2
                   version: 3.1
                   serial: 9cfec30b-5718-2d45-8e5e-0bca45af7205
                   size: 22GiB
                   capacity: 22GiB
                   capabilities: primary ntfs initialized
                   configuration: clustersize=4096 created=2010-09-13 20:39:21 filesystem=ntfs label=E Drive mount.fstype=fuseblk mount.options=rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096 state=mounted
        *-ide:1
             description: IDE interface
             product: IXP SB400 Serial ATA Controller
             vendor: ATI Technologies Inc
             physical id: 12
             bus info: pci@0000:00:12.0
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: ide pm msi bus_master cap_list rom
             configuration: driver=sata_sil latency=64
             resources: irq:11 ioport:3058(size=8) ioport:307c(size=4) ioport:3050(size=8) ioport:3078(size=4) ioport:3020(size=16) memory:80207400-802075ff memory:58080000-580fffff
        *-usb:0
             description: USB Controller
             product: IXP SB400 USB Host Controller
             vendor: ATI Technologies Inc
             physical id: 13
             bus info: pci@0000:00:13.0
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: msi ohci bus_master cap_list
             configuration: driver=ohci_hcd latency=64
             resources: irq:11 memory:58100000-58100fff
        *-usb:1
             description: USB Controller
             product: IXP SB400 USB Host Controller
             vendor: ATI Technologies Inc
             physical id: 13.1
             bus info: pci@0000:00:13.1
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: ohci bus_master
             configuration: driver=ohci_hcd latency=64
             resources: irq:11 memory:58101000-58101fff
        *-usb:2
             description: USB Controller
             product: IXP SB400 USB2 Host Controller
             vendor: ATI Technologies Inc
             physical id: 13.2
             bus info: pci@0000:00:13.2
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: pm msi ehci bus_master cap_list
             configuration: driver=ehci_hcd latency=64
             resources: irq:11 memory:58102000-58102fff
        *-serial
             description: SMBus
             product: IXP SB400 SMBus Controller
             vendor: ATI Technologies Inc
             physical id: 14
             bus info: pci@0000:00:14.0
             version: 82
             width: 32 bits
             clock: 66MHz
             configuration: driver=piix4_smbus latency=0
             resources: irq:0 ioport:3010(size=16) memory:80207000-802073ff
        *-ide:2
             description: IDE interface
             product: IXP SB400 IDE Controller
             vendor: ATI Technologies Inc
             physical id: 14.1
             bus info: pci@0000:00:14.1
             logical name: scsi4
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: ide msi bus_master cap_list emulated
             configuration: driver=pata_atiixp latency=64
             resources: irq:11 ioport:1f0(size=8) ioport:3f6 ioport:170(size=8) ioport:376 ioport:3000(size=16)
           *-cdrom
                description: DVD-RAM writer
                product: DVDRAM GSA-H10N
                vendor: HL-DT-ST
                physical id: 0.0.0
                bus info: scsi@4:0.0.0
                logical name: /dev/cdrom
                logical name: /dev/cdrw
                logical name: /dev/dvd
                logical name: /dev/dvdrw
                logical name: /dev/scd0
                logical name: /dev/sr0
                version: JL10
                capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
                configuration: ansiversion=5 status=nodisc
        *-multimedia
             description: Audio device
             product: IXP SB4x0 High Definition Audio Controller
             vendor: ATI Technologies Inc
             physical id: 14.2
             bus info: pci@0000:00:14.2
             version: 01
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list
             configuration: driver=HDA Intel latency=64
             resources: irq:11 memory:80200000-80203fff
        *-isa
             description: ISA bridge
             product: IXP SB400 PCI-ISA Bridge
             vendor: ATI Technologies Inc
             physical id: 14.3
             bus info: pci@0000:00:14.3
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: isa bus_master
             configuration: latency=0
        *-pci:1
             description: PCI bridge
             product: IXP SB400 PCI-PCI Bridge
             vendor: ATI Technologies Inc
             physical id: 14.4
             bus info: pci@0000:00:14.4
             version: 80
             width: 32 bits
             clock: 66MHz
             capabilities: pci subtractive_decode bus_master
             resources: ioport:1000(size=4096) memory:80000000-800fffff
           *-network
                description: Ethernet interface
                product: RTL-8139/8139C/8139C+
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 2
                bus info: pci@0000:02:02.0
                logical name: eth0
                version: 10
                serial: 00:16:76:9a:45:f8
                size: 100Mbit/s
                capacity: 100Mbit/s
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=172.24.57.128 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
                resources: irq:11 ioport:1000(size=256) memory:80000000-800000ff

Farid Zarbaliyev (sehrbaz) said : #4

We have the same Proc. Btw I have managed to make my new system work. I installed ubuntu upon my old system by upgrading it. And old kernel was left and I am using the old Kernel.

Problem seems to be related with new kernel (branch 3x). please try to use old branch 2x and see if it helps you. Temporary at least. I will inform if will find out the main reason.

Suman Guha (suman-iitk2003) said : #5

Thanks for the comments.

As I had already mentioned in my earlier post that I can boot the system using the old kernel (2.***) but the problem is with the latest kernel (3.***).

In the mean time, I found somewhere that if the USB in the BIOS is disabled then it can boot with the new kernel (3.***). I tried this and it worked. However that is not the solution because then all the USB ports are disabled and no USB device would work. I have an USB mouse and it won't work with the USB in the BIOS being disabled.

Hope that a fix might be available soon.

unknown (smile7bolt) said : #6

I've been facing the same problem, except with linux mint and backtrack.
Hardware specs:
core: Intel pentium 4 [HT] 3ghz.
mem: 3gb ddr2
graphics: ati radeon hd 3450 (512 mb)
storage: 80+20 gb

Stephen Franklin (stephen123) said : #7

I have the same Mother Board. Intel Dl02GGC2. Trying to boot from USB. It stops at the same place. BIOS only allows 2 settings for ACPI. S1 and S3.
error line is
[0.xxxxxx] ACPI: Power Button [PWRF]

Stephen Franklin (stephen123) said : #8

Backtrack5 R1 can not start from usb flash drive.
I've got it to work from the same motherboard as you. Intel Dl02GGC2 pentium 4 3.0 Ghz

I also have 5 other computers I am trying it on.
2 dell dimensions 2400 boot just fine from usb (but slow).
1 2003 abit motherboard. It boots fine if I use a "Plos boot manager" CD.
 The BIOS does not support booting from USB.
1 Dell Vostro 200. It fails booting from the USB if it is set in the BIOS.
  However it boots fine using a "Plos boot manager" CD.
1 ASUS motherboard. It boots fine using it's own bios.

First setting the Intel Dl02GGC2 pentium 4 3.0 Ghz to boot from the bios fails. It gives a "Boot Error" on a black
screen the same as the Vostro 200.

I set the computer to boot from the CD first, the USB second and then the hard disk.
(The BIOS seems to forget the usb flash drive if you pull it out between boots. Why?)
So, I downloaded the "Plos boot manager" iso and burned it to a boot CD.
With this the computer boots dependably first to the Plos boot screen.
There is a boot list to choose from.
Plos has it's own CD and USB driver's so it is not depending on the computers bios.
Next choose the usb to boot from. Up comes the Syslinuz 3.83.... boot:
good. press enter. Next comes the Backtrack menu.
I got this far weeks ago.
oh, oh! If you continue it always fails with this Intel Dl02GGC2 motherboard.
Usually with [x.xxxxxx] ACPI: Power Button [PWRF], but also with ? show=dormant + 0x6/0x50
also the keyboard can lock with the lights flashing. Also it can reboot and
get stuck in the initial BIOS screen.

so now the fix.
-Boot up the usb flash drive on another computer. In the Ubuntu site it says to add
"acpi=off" to /boot/grub/menu.lst. Backtrack does not have that file.
Add it anyway with that one line. It seems to be necessary.
Put the usb back in the Intel computer and also the "Plos boot manager" CD and boot.
In the Plos menu choose usb and press enter.
Up comes the Syslinuz 3.83.... boot: Press enter.
the backtrack menu comes up. Press TAB. Underneath the backtrack menu is a boot options
string. add to it <space> acpi=off. Press enter. Now it often (sometimes) boots successfully.
When it boots successfully the wireless adapters seem to work.
Unfortunately the "system monitor" indicates only 1 CPU.
When you shut down you get a screen with the last line saying "system halted".
Because acpi is disabled you have to press the power button to finish shutting down.
(remember DOS and Windows 3.1)

I put a lot of time getting this far. I hope someone takes this further.

PS Just tried with another Flash usb. It is failing at a different point.
"Loading casper/initrd.gz.............................................................."
now failing a "Loading casper/vmlinuz............................................."
too late to do any more.

unknown (smile7bolt) said : #9

i tried what you did Stephen, it doesn't seem to work. when i don't use acpi=off, i get the the same error as you. although when i tried it with that, i just get a blank screen.

Jappreet (bains-jappi) said : #10

Hi all,

I am a newbie here onto Linux.

Was facing same problem as being discussed and system was halting at ACPI [PWRF] for all kernels 3.x till 3.2. acpi=off also did not help to boot the system. (Ubuntu 11.10, same problem i faced on 11.04 also so upgraded but to no use).

With the board D102GGC2 i updated my BIOS first, then tried with boot option idle=poll and idle=halt, separately. Bothe times machine could boot safely.

But now i m not sure wat effect this option has on the system hardware as well as software. Hence i want to request sonmmeone to guide me whether using system with this option is safe or not.

Regards

Jon Ruttan (jonruttan) said : #11

I had the same/similar problem.

Setting acpi=off let me boot, but my computer wouldn't go to sleep or shut down properly (I had to shut it off manually using the power button after the shut down process completed.)

Setting idle=poll also worked, but according to kernel.org, idle=poll will "will use a lot of power and make the system run hot" [http://www.kernel.org/doc/Documentation/kernel-parameters.txt].

I had sporadic problems shutting down my computer using idle=halt, sometimes it would just hang, other times it shut down properly.

After some more digging around I found a website [http://marc.info/?l=linux-acpi&m=133002974918284&w=2] which suggested this:
    processor.nocst=1

So far, so good.

If you've got a single-processor system, according to the same website maxcpus=1 should work as well.

Can you help with this problem?

Provide an answer of your own, or ask no one 123 for more information if necessary.

To post a message you must log in.