Laptop Screen Dims on 11.10 unlike 11.04

Asked by Marco Parillo on 2011-10-14

I use a live USB Image on a Dell Latitude 620 with the default options (Unity, 32-bit).
If I leave the laptop plugged in, but unattended for some time:
11.04: The screen blanks, and a swipe across the trackpad restores it to full brightness.
11.10: The screen blanks, but a swipe only restores to a dim state. I need to use the blue <Fn> <up arrow> key chord to make my screen bright again.

In the system settings, I can find a way to set the behavior under battery power, but not while plugged in.
Is this working as designed?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu acpi Edit question
Assignee:
No assignee Edit question
Solved by:
Marco Parillo
Solved:
2012-04-27
Last query:
2012-04-27
Last reply:
2011-10-14
Kolin S. Murray (kolinab) said : #1

This is exactly the same on my machine (Dell 630m). My other laptop does not have this problem. I found the following thread on ubuntuforums: http://ubuntuforums.org/showthread.php?p=11315622

Problem persists.

Chris (fabricator4) said : #2

No. It should come back to normal brightness when you wake it up. Sounds like it might be a bug though it must be hardware specific. It is working as expected on my Eee PC.

Chris

Marco Parillo (marco-parillo) said : #3

Thank you Kolin for confirming my observation, and while the thread may relate to the same root cause, it is a different set of circumstances.

Thank you Chris for your prompt response. When you write 'wake it up', in my case the laptop does not actually sleep / hibernate. It just blanks the screen, and then does not go back to full brightness when I swipe my finger across the track pad, the way I would expect when plugged in.

John Croll (john585) said : #4

Phew- thought it was my cataracts for a minute there....

I am having the same problem with my Dell Inspiron E1705:

I am on AC power. Screen goes to dim after a period of time, and when moving mouse or using keyboard, screen remains dim.

Went into System Settings>Screen and saw 'dim screen to save power; was checked. Unchecked it and saw the fader bar was all the way to the left. When dragging it to the right, I assumed it would get brighter and brighter when moving it to the right. Instead, as dragging it to the right, the screen alternates dim/bright/dim/bright/dim/bright.

Marco Parillo (marco-parillo) said : #5

Thank you John Croll. I saw something similar when I <fn> <right-arrow> to increase the brightness. It would alternately dim and brighten.

Chris (fabricator4) said : #6

Does leaving the box for "dim screen..." unchecked prevent the dimming altogether (might need a reboot)? If so, leave it like that - it's one of the very first changes I always make because even though it works correctly on my Eee PC, it annoys the *heck* out of me. Turning the screen off or down is an excellent way to extend battery life, but I'm perfectly capable of making that decision when it's useful and appropriate to do so.

Chris

Marco Parillo (marco-parillo) said : #7

Chris, thank you, but the option for "dim screen..." does not appear for when under AC power. It only is applicable for when on battery. And I am fine with that. I can live with the screen blanking (even under AC power) completely after some period of inactivity, but once I am back, I would expect it to be full brightness.

Marco Parillo (marco-parillo) said : #8

Oh, wait. I am sorry. You are not referring to the System Settings > Power option. You are referring to the System Settings > Screen option. I will try that and then update the question.

Marco Parillo (marco-parillo) said : #9

I am sorry, that did not work. I went to System Settings > Screen. I unchecked the Dim screen to save power. I waited and eventually the screen blanked as expected. I swiped across the trackpad, and the screen came back dim. <Fn> <Up Arrow> once brightens the screen, and a notification appears with a slider bar. Continuing to press <Fn> <Up Arrow> alternately dims and brightens the screen, until the slider bar is at the max. After that, the screen is at its brightest and does not alternate brightness when I press <Fn> <Up Arrow>,

Marco Parillo (marco-parillo) said : #10

I believe this is specific to certain HW. On my Acer Aspire One netbook, the behavior is as expected:
After inactivity, the screen dims.
A swipe across the trackpad immediately restores the screen to full brightness.

Prashant Shrestha (acolyte26) said : #11

Yes I have the exact same problem in my Dell latitude D630. This is very annoying as I have to change the brightness everytime.

rbauer (rbauer) said : #12

Same issue is happening on my laptop. It's an "HP - Compaq nc6120."

I've disabled the dimming option for now and will pay close attention to this bug report for the resolution. I'd love to be able to use this feature.

Marco Parillo (marco-parillo) said : #13

I think this might be an upstream problem. I just downloaded Fedora 16 tonight, and the same behavior occurs.

Marco Parillo (marco-parillo) said : #14

@John Croll (john585): Fedora seems to consider the up and down brightness a bug:
https://bugzilla.redhat.com/show_bug.cgi?id=745977

Marco Parillo (marco-parillo) said : #15

Could this be a Gnome thing? It does not seem to be a problem on OpenSUSE 12.1 with KDE.

Marco Parillo (marco-parillo) said : #16

I would say definitely a Gnome thing. I am running Kubuntu at this very moment and a swipe across the trackpad immediately returns the screen to full brightness and the Fn Up Arrow and Fn Down Arrow keychords smoothly increase and decrease the brightness.

Edwin Lee (leeed2001) said : #17

Confirm this same behavior on wife's DELL Latitude D620. Tried updating to x-swat to see if there was anything new, but didn't help.

Marco Parillo (marco-parillo) said : #18

Almost certainly Gnome: it appears on Linux Mint 12, Fedora 16, and Ubuntu 11.10 with Unity, but not KDE: Kubuntu or Open SuSE 12.1

John Croll (john585) said : #19

Thank you for the comments.

I had hoped/thought I could disable ACPI in my systems BIOS, but remarkably, I do not see any controls for it in my particular system (Dell Inspiron E1705 laptop). I'd have been happy enough with that as a workaround :(

Lots of opinion this is a 'Gnome' thing, fair enough. Does anyone know if there is anything I can do in Gnomes controls to tell it to not dim due to inactivity? (Keeping in mind I and maybe the next person seeking this answer might not be a super tech!)

Alternately, I'd even be happy enough with a 'hack' that would send a null keyboard signal to the OS to think i am not AFK. Any ideas about something like that?

I am almost at a point where I am willing to switch desktop environments to avoid this (Unity? Ggaaahhh!)

Marco Parillo (marco-parillo) said : #20

Maybe I should wait another day or two before posting, but I tested last night and this behavior has reverted to expected with Ubuntu 12.04 LTS. That is:
As always, I use a live USB Image on a Dell Latitude 620 with the default options (Unity, 32-bit).
If I leave the laptop plugged in, but unattended for some time:
11.04: The screen blanks, and a swipe across the trackpad restores it to full brightness.
11.10: The screen blanks, but a swipe only restores to a dim state. I need to use the blue <Fn> <up arrow> key chord to make my screen bright again. As noted here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/872932/comments/6
12.04: The screen blanks, and a swipe across the trackpad restores it to full brightness.

Marco Parillo (marco-parillo) said : #21

Upgrading to 12.04 solved my problem.