accounts-daemon using up several gigabytes of RAM

Asked by Adam K

HP Z400 Workstation
Intel Xeon W3520
nVidia QuadroFX 580

Kubuntu Trusty 14.04.2, apt-get says everything is up to date
Kernel 3.13.0-46-generic x64
KDE SC Version 4.13.2
Accountsservice 0.6.35-0ubuntu7.1

My system seems to boot just fine until it tries to bring up LightDM. At that point, accounts-daemon eats up 100% of a CPU core, starts allocating tons of memory and causes LightDM to hang for ~25 seconds. After I put in my username and password accounts-daemon continues eating up 100% of a CPU core, allocates more memory and hangs the login process some more. After being logged in for a few minutes it stops using CPU time but never frees any memory, eventually settling in at ~6GB used. At the time of this writing it is currently at 5,754,280K.

If I kill the process it frees all of the memory, but after locking the screen or similiar action something (dbus?) starts it back up again and the process repeats, although only using up ~2.5GB of RAM. I have tried running accounts-daemon --debug and it doesn't spit out anything indicating an error. The closest that I've found to a problem is in the lightdm.log file excerpted below:

[+0.05s] DEBUG: Using VT 7
[+0.05s] DEBUG: Seat: Starting local X display on VT 7
[+0.05s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.05s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.05s] DEBUG: DisplayServer x-0: Launching X Server
[+0.05s] DEBUG: Launching process 1254: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.05s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.05s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.05s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+25.08s] WARNING: Error getting user list from org.freedesktop.Accounts: Timeout was reached
[+25.08s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+25.09s] DEBUG: User xxxxx added
[+25.09s] DEBUG: Got signal 10 from process 1254
[+25.09s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+25.09s] DEBUG: DisplayServer x-0: Connecting to XServer :0
<snip />

dbus does seem to start the service successfully as evidenced in syslog:

Mar 19 10:32:32 the-cybercraft dbus[791]: [system] Activating service name='org.freedesktop.Accounts' (using servicehelper)
Mar 19 10:32:32 the-cybercraft accounts-daemon[1259]: started daemon version 0.6.35
Mar 19 10:32:32 the-cybercraft dbus[791]: [system] Successfully activated service 'org.freedesktop.Accounts'
<snip />

I'll provide any help that I can, and thanks!

Question information

English Edit question
Ubuntu accountsservice Edit question
No assignee Edit question
Solved by:
Adam K
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
Adam K (m3741) said :

Problem solved. Answer is in the attached bug report.