why no new abiword versions above 2.6.4

Asked by Mike Smith on 2009-04-29

Since the help system in Abiword for xubuntu 8.10 v2.6.4 is broken, and since 2.6.6 is shipping with xubuntu 9.04, why can't I upgrade my 8.10 system?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu abiword Edit question
Assignee:
No assignee Edit question
Solved by:
Micah Gersten
Solved:
2010-05-12
Last query:
2010-05-12
Last reply:
2009-05-01
Best Micah Gersten (micahg) said : #1

As you can see on this link, the Intrepid version is 2.6.4 and the Jaunty version is 2.6.6:
http://packages.ubuntu.com/search?keywords=abiword

If you add the Jaunty repos, you can install 2.6.6, but there are no guarantees that it will work. You can open a request for the Intrepid backports project if you'd like them to backport 2.6.6 or you can upgrade to Jaunty.

https://bugs.launchpad.net/intrepid-backports/

Micah Gersten (micahg) said : #2

Alternatively, you can open up a bug report for the help system in 2.6.4:
https://bugs.launchpad.net/ubuntu/

Mike Smith (mesmith-petaluma) said : #3
Mike Smith (mesmith-petaluma) said : #4

I did open a bug report. It was accepted and confirmed. A fix was created but assigned to the Jaunty release not Intrepid. The help system in Jaunty is fixed. I don't plan on moving to Jaunty for quite some time, as I believe Jaunty is a premature release with too many users having major problems (20%). I guess I'm out of luck, as I don't think a backport request would be accepted.

Shahar Or (mightyiam) said : #5

Dear Mike,

Please link the bug report here by pressing "Link existing bug".

Perhaps you try the jaunty live CD and see if it works for you?

Many blessings.

Mike Smith (mesmith-petaluma) said : #6

Look at question 53561. Can't find original bug report.

Micah Gersten (micahg) said : #7

Was this the bug?
https://bugs.launchpad.net/ubuntu/+source/abiword/+bug/295596

Anyways, you can make the backport request, it can't hurt:
https://bugs.launchpad.net/intrepid-backports/+filebug

If enough people want it, they'll probably do it.

Mike Smith (mesmith-petaluma) said : #8
Mike Smith (mesmith-petaluma) said : #9

The Abiword bug I reported was for 2.6.4 in xubuntu, but was deemed by Abiword to be a distro error rather than an Abiword bug. The following text was what I reported:

"In using Abiword I was inserting page numbers and clicked the Help button. I got a Firefox msg that said it couldn't find the html doc at the path it was looking in: /usr/share/abiword-2.6/AbiWord/help/en-US/interface/dialogpagenumbers.html

I took a look at the path and noticed that Abiword is looking for the file on a path that doesn't exist. The path that does exist looks like this: /usr/share/abiword-2.6/help/en-US/interface/dialogpagenumbers.html

Notice that the installed data path lacks the level /Abiword/ that follows /abiword-2.6/"

Micah Gersten (micahg) said : #10

Seems like a good reason to push through a backport. Put what you just told me in the backport request.

Mike Smith (mesmith-petaluma) said : #11

Thanks Micah Gersten, that solved my question.